Jump to content

Slow response times for Malwarebytes


Recommended Posts

Greetings, everyone. And thanks for many years of allowing me to use this great product!

Starting some time in the last few days, I am noting the below new behaviors:

 

1) Right clicking on the Malwarebytes icon in the task bar is associated with a very long delay before the associated context menu shows up (with check for updates on top). All other icons respond much more quickly when they are right clicked,

2) When I use this method to "show Malwarebytes", it now take more than one minute for the program screen to open; previously, it rarely took more than five seconds. 

 

All other computer functions are operating normally, including their speed. I have updated Malwarebytes (it showed no updates needed), quit and restarted Malwarebytes, without change, and have rebooted, without change. Could this be a manifestation of Friday's component package update? Am running Windows 10, version 1909 (my company is slow to adopt new versions). Happy to send additional information, if desired. 

 

Thanks!

Link to post
Share on other sites

  • Staff

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes for Windows Help forum.

If you are having technical issues with our Windows product, please do the following:

Malwarebytes Support Tool - Advanced Options

This feature is designed for the following reasons:

  • For use when you are on the forums and need to provide logs for assistance
  • For use when you don't need or want to create a ticket with Malwarebytes
  • For use when you want to perform local troubleshooting on your own

How to use the Advanced Options:

Spoiler
  1. Download Malwarebytes Support Tool
  2. Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  3. Place a checkmark next to Accept License Agreement and click Next
  4. Navigate to the Advanced tab
  5. The Advanced menu page contains four categories:
    • Gather Logs: Collects troubleshooting information from the computer. As part of this process, Farbar Recovery Scan Tool (FRST) is run to perform a complete diagnosis. The information is saved to a file on the Desktop named mbst-grab-results.zip and can be added as an email attachment or uploaded to a forum post to assist with troubleshooting the issue at hand.
    • Clean: Performs an automated uninstallation of all Malwarebytes products installed to the computer and prompts to install the latest version of Malwarebytes for Windows afterwards. The Premium license key is backed up and reinstated. All user configurations and other data are removed. This process requires a reboot.
    •  Repair System: Includes various system-related repairs in case a Windows service is not functioning correctly that Malwarebytes for Windows is dependent on. It is not recommended to use any Repair System options unless instructed by a Malwarebytes Support agent.
    • Anonymously help the community by providing usage and threat statistics: Unchecking this option will prevent Malwarebytes Support Tool from sending anonymous telemetry data on usage of the program.
  6. To provide logs for review click the Gather Logs button
  7. Upon completion, click OK
  8. A file named mbst-grab-results.zip will be saved to your Desktop
  9. Please attach the file in your next reply.
  10. To uninstall all Malwarebytes Products, click the Clean button.
  11. Click the Yes button to proceed. 
  12. Save all your work and click OK when you are ready to reboot.
  13. After the reboot, you will have the option to re-install the latest version of Malwarebytes for Windows.
  14. Select Yes to install Malwarebytes.
  15. Malwarebytes for Windows will open once the installation completes successfully.

Screenshots:

Spoiler
 
 
 
 
Spoiler

 

 

01.png

02.png

03.png

04.png

05.png

06.png

 

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/hc/en-us/requests/new to get help

If you need help looking up your license details, please head here: Find my premium license key

 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

Link to post
Share on other sites

Hi drdas,

I got a similar "problem" and I allready opend a new forum thread:

 

Did you allready try to make a clean unistall and reinstall Malwarbytes using the Malwarebytes support tool?

How much Ram do you have? I got 8 GB, having 16 GB or more could  help too.

But anyway´s ... 1 Minute response time is more than to much ... 

Edited by FetzBox22
Link to post
Share on other sites

I don’t think it’s a RAM issue, since I’ve used this for years and the problem just started. I haven’t installed any new software or applied any other updates, which is why I wondered if it could be the recent MWB version that installed itself over the weekend.

Link to post
Share on other sites

Additional information (which may or may not be helpful):

Once the MWB program window is open, everything within that window reacts quickly, and scans seem to function normally and speedily, whether routinely daily scans or on-demand scans. It is simply opening up the context menu (only from the MWB icon) and opening up the program window that take a long time (and I just measured it; it is three minutes after clicking on "show Malwarebytes" for the window to pop up).

Link to post
Share on other sites

And until yesterday mine has always been zippy as well. That’s why I am wondering if there is something in the component package that may have caused this new behavior on some machines. 

Link to post
Share on other sites

Last proactive note (then I'll await wiser minds' input).

I did run the MWB cleaning tool to uninstall and reinstall the software. No change in the symptoms. Happy to post the mbst-clean log if it would be helpful.

Link to post
Share on other sites

Thanks for your reply.

Well it definitely ain't the newest computer. Standard drive (not optical or solid state), but plenty of free space (250G out of 450G free). 8 GB RAM, intel i5-5300 2.30GHz processor. 

But again, everything else is running smoothly and MWB was perfect until this weekend. And it is only MWB that seems to have slowed down.

FWIW: If I run task manager when I'm waiting for MWB to open, neither the CPU nor the memory get above 50% utilization total (among all programs) though MWB does get the lion's share while its awaiting opening (21% CPU).

Link to post
Share on other sites

AdvancedSetup:

 

Thanks for your response. I did this (see my Tuesday evening EST post) and it did not change the behavior. I can post the logs from mbst-clean-results if you would like.

Link to post
Share on other sites

Indeed it is, sir. The problem persists. The reality is that, as long as I don't make any effort to open the main interface or right click on the icon, I wouldn't know that there was a problem at all. And maybe ignoring it is the way to go. Scans are continuing to occur at scheduled times and they seem to run with the appropriate speed. So it is really more of an annoyance than anything else....

Link to post
Share on other sites

  • Root Admin

Not really sure. I can duplicate a slowdown on first start of the computer and trying to open the first time. After that though the average is about 5 seconds give or take for me but I am on a high-end system.

It's after 3 AM for me so I have to get to bed, but will try to check the after reboot speed to see what the initial start time is for me.

 

Link to post
Share on other sites

Just wanted to comment here. I am running the latest beta, clicking on MB icon on desktop it takes about 7 seconds for program to open, clicking on icon in taskbar it takes 10 seconds, way too slow. I have 12 GB of ram so that is not the issue and everything else opens fine on my computer. Not going to provide logs just wanted to let interested parties know.

Link to post
Share on other sites

Will do, @AdvancedSetup. But after the scary warning I got when I tried to activate beta updates, I'm gonna go ahead and backup my files first, so it might take a few hours. 

Has anyone had any problems with bricking after activating beta updates for MWB?

Link to post
Share on other sites

Done. No change in the behavior. Still long delays when right clicking on the icon and a 3-5 minute delay in getting the GUI open either through that mechanism or by using the start menu.Can provide more logs if requested. 

Link to post
Share on other sites

  • Root Admin

Please download process monitor and unzip it.

Then close down and exit out of everything possible including chat, web, games, etc. everything possible you can close please close.

Then run Process Monitor and then click to start Malwarebytes. Once Malwarebytes shows up then stop Process Monitor and save the log. Zip it up and post back here please.

https://docs.microsoft.com/en-us/sysinternals/downloads/procmon

Thanks

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.