Jump to content
Francois_Blais

Firefox freezing

Recommended Posts

Re this (now closed) thread:

https://forums.malwarebytes.org/index.php?/topic/162445-solved-crashing-firefox/

 

The config trick given at post #5 didn't solve my problem.

I had a couple of lockups this afternoon.

These lockups are during between 5 and 10 seconds.

 

Best regards, and Happy Christmas Eve everybody!

 

Share this post


Link to post
Share on other sites

Hi,

 

Until pedro comes along....

I'll bet this is unrelated to MBAE.

Otherwise, the forum here would probably be flooded with reports?

 

But you might want to post the standard logs for pedro to review: https://forums.malwarebytes.org/index.php?/topic/144403-readme-first-how-to-post-here/

 

FWIW, you also might want to try basic Firefox troubleshooting:  http://kb.mozillazine.org/Standard_diagnostic_%28Firefox%29

The first step is Mozilla Safe Mode (not Windows Safe Mode): http://kb.mozillazine.org/Safe_Mode

And you might want to try disabling hardware acceleration in both Flash Player and Firefox:

 

To disable Hardware Acceleration in Firefox:

Go to: Tools > Options > Advanced > General > Browsing, & un-check the "Use Hardware Acceleration" box.

To disable Hardware Acceleration in Flash:

Right click on any Flash video screen (e.g. YouTube) & choose "Settings".
Un-check the Hardware Acceleration box.

 

Just a thought from a basic home user,

 

 

Share this post


Link to post
Share on other sites

Thanks daledoc1, I'll try these settings.

I also thought about MBAM, but one thing at a time.

It's indeed probably more a FF issue.

Share this post


Link to post
Share on other sites

Along with what daledoc1 has said, I would also recommend running with a single tab open in FF.  Its common to have a tab which is open but not in focus attempt to activate Flash (or some other app needed for rendering) and cause hangs for various reasons.  If you can determine which tab is doing it, there is an add-on called "View Dependencies" which allows you to see all connections that the active page is using.  Its very helpful in determining which specific component is causing a problem.

Share this post


Link to post
Share on other sites

Good morning and happy Christmas to you all.

 

Francois_Blais,

 

I'm still looking into this and will still try and help if I can.  For me although switching the about:config preference in Firefox (which I posted in the other thread you quoted) helped alot, it has not solved the problem entirely for me (I am now getting a couple of freezes a day rather than a couple an hour). 

 

Do you have Kaspersky internet security installed (I do)? I'm thinking that the Kaspersky plugins and addons (in Firefox) might have somthing to do with it, because when there is a freeze I can see an error message pertaining to the "Kaspersky Content Blocker" plugin in the "Firefox Error Console".

 

I need to do some more testing with this, but it might take a while because as I said I'm only getting a couple of freezes a day now. As soon as I have anything to report I will post here.

 

Regards.

Share this post


Link to post
Share on other sites

 

"View Dependencies"

 

Interesting -- I researched this extension. It appears to have been abandoned by the developer in 2011, though someone recently hacked it for compatibility with later Fx builds.

Is it compatible with Fx 34.0.5? <just curious>

https://addons.mozilla.org/en-US/firefox/addon/view-dependencies/?src=ss

 

As for the KIS thing, it would easy enough to test by disabling the KL plug-ins, probably from within KIS?

(Standard Fx diagnostics won't isolate the problem to this, as the KL plug-ins are installed globally within Windows, not in the Fxprofile. Such global plug-ins are not disabled in Mozilla Safe Mode.)

 

Francois, you haven't mentioned if you tried the most direct step to troubleshoot for MBAE contribution to the issue: uninstalling MBAE to see if the problem resolves?

<just asking>

 

And you might want to post the standard logs for pedro to review: https://forums.malwa...w-to-post-here/

 

Cheers,

Share this post


Link to post
Share on other sites

Hi daledoc1,

 

I've had the KIS plugins and addons in Firefox disabled for about 3 hours, no hangs so far.

 

I've had a question posted over on the KIS forum (Is there any detriment to my security by disabling the "Content Blocker" plugin?) http://forum.kaspersky.com/index.php?showtopic=313325 I've not had a satisfactory response yet.  I don't suppose you have any idea about this.

 

Your help would be appreciated. :)

Share this post


Link to post
Share on other sites

 

I've not had a satisfactory response yet

 

I wouldn't hold my breath.

Aside from a very small handful of volunteers, I've not found the KL staff or the most active "moderator" to be terribly helpful for these sorts of nebulous issues.

 

My hunch: they will likely provide the usual boilerplate reply they provide to anyone who complains about their outdated and non-functional plug-ins: "it is just cosmetic when they don't work" and "you are still protected".

 

<cynical snark off>

Share this post


Link to post
Share on other sites

Thanks for the reply daledoc1,

 

I seem to recall in previous posts you mentioned that you use KIS, if that is the case do you have the pluggins and addons enabled or disabled, your insight would be most welcome.

 

Kind regards.

Share this post


Link to post
Share on other sites

I am still running KIS 2014 (there were issues with Thunderbird & other problems with 2015), but I plan to upgrade both boxes in the next few weeks (after the Xmas rush).

 

Under KIS 2014 and Win7/64, the Fx plug-ins were only recently re-enabled with the release of patch (i) in the past week.

They had been disabled for months before that (and I had not expected that they would issue an update for 2014).

 

>>>Ennywho, as far as I can tell, there has been no change in Fx behavior since the plug-ins were enabled with the install of KIS 2014 (i).

But each system is different, especially regarding installed Fx extensions and other unique profile features and preferences.

So, YMMV, of course.

 

The best test would be either Mozilla Safe Mode, and/or a new, clean, virgin profile with no installed extensions or changes to settings.

Both Safe Mode and a new profile will still include the globally installed KL plug-ins, but they could be disabled from KIS/Windows.

Then, one would add back extensions and enable plug-ins one at a time, until the problem re-occurs.

 

BTW, I am quite certain that Pedro will likely relocate this thread, perhaps to PC Help, as it likely does not directly involve MBAE. :o

Share this post


Link to post
Share on other sites

Daledoc1 thank you for your insight,

 

I must admit that I too have not noticed any change in behaviour since disabling the plugins and addons.

Share this post


Link to post
Share on other sites

Hi again.

No KIS here. (just updated my signature)

I first completely removed Adobe Flash Player, et voilà, no more hangs!

So for me it seems Flash was really the culprit.

FWIW, I replaced FF with Chrome, which uses its own player, and it works great.

 

Merry Christmas!

Joyeux Noël!

Share this post


Link to post
Share on other sites

Thanks for the update.
Glad you sorted it out.

FWIW:
 

I first completely removed Adobe Flash Player, et voilà, no more hangs!
So for me it seems Flash was really the culprit.
FWIW, I replaced FF with Chrome, which uses its own player, and it works great.


And you might want to try disabling hardware acceleration in both Flash Player and Firefox:

To disable Hardware Acceleration in Firefox:
Go to: Tools > Options > Advanced > General > Browsing, & un-check the "Use Hardware Acceleration" box.

To disable Hardware Acceleration in Flash:
Right click on any Flash video screen (e.g. YouTube) & choose "Settings".
Un-check the Hardware Acceleration box.

Merry Christmas, to you, as well!

 

 

Share this post


Link to post
Share on other sites

Hi Francios_Blais,

 

Although I use Firefox I don't use flash player, it's more trouble than it's worth, not to mention the countless times it's been exploited by malware. I usually just use the HTML5 player.

 

Anyway I'm glad you have sorted it out, It seems as though my hanging problem is over as well.

 

We're literally 5 minutes from starting our Christmas meal (can't wait).

 

Seasons greetings and enjoy the day.

 

Regards. :D

Share this post


Link to post
Share on other sites

Thanks for the update Francois_Blais.

 

Maybe an update of Flash caused some instability within Firefox? If you install it again please check to see if it still has problems with MBAE alongside and if so, please try to stop MBAE to see if the problem persists.

 

In the meantime, moving this to Questions sub-forum. If we do end up seeing this is related to MBAE I will move it back to Product Support.

Share this post


Link to post
Share on other sites

Thanks Pedro.

I reinstalled the Adobe Flash player again, but this time disabled hardware acceleration in FF, as suggested by daledoc1.

Will report back in a few days.

 

Cheers!

François

Share this post


Link to post
Share on other sites

Hi again.

Didn't take days to get lockups again.

Disabling flash's own hardware acceleration didn't help either.

Disabling MBAE and MBAM neither.

So far the only cure seems to remove flash altogether.

 

Regards,

François

Share this post


Link to post
Share on other sites

Weird. Maybe something else is conflicting with your FF's Flash plugin. You don't have EMET installed by any chance, do you?

Share this post


Link to post
Share on other sites

Hi Pedro.

No, never had EMET installed since I reinstalled Windows last week.

(it's fully updated if you're wondering)

Share this post


Link to post
Share on other sites

Update:

Tried a fresh FF profile with no success.

Tried a new Windows user profile with no success.

Older FF versions and older flash versions neither.

Installed Pale Moon, a FF based browser, but no luck either.

 

Strange because under Linux, FF and flash run great.

 

Regards,

François

Share this post


Link to post
Share on other sites

Actually, I reformated my HD and reinstalled Windows 7 from scratch.

Installed the 32 bits version this time. (was on 64 bits before)

Flash is working perfectly so far. (latest version)

I've installed the latest ESR Firefox version. (31.3.0)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.