Jump to content

Errors 440 & 0


Recommended Posts

  • Staff

Greetings :)

Please do the following:

Note: You must be logged into an administrative user account for this to work.

  • Please copy and paste the following text exactly as written into notepad (not wordpad or any other text editor):
    @color 48
    @echo off
    if exist "%programfiles(x86)%" regsvr32 "%programfiles(x86)%\Malwarebytes' Anti-Malware\mbamext.dll"
    if exist "%programfiles(x86)%" regsvr32 "%programfiles(x86)%\Malwarebytes' Anti-Malware\ssubtmr6.dll"
    if exist "%programfiles(x86)%" regsvr32 "%programfiles(x86)%\Malwarebytes' Anti-Malware\vbalsgrid6.ocx"
    if not exist "%programfiles(x86)%" regsvr32 "%programfiles%\Malwarebytes' Anti-Malware\mbamext.dll"
    if not exist "%programfiles(x86)%" regsvr32 "%programfiles%\Malwarebytes' Anti-Malware\ssubtmr6.dll"
    if not exist "%programfiles(x86)%" regsvr32 "%programfiles%\Malwarebytes' Anti-Malware\vbalsgrid6.ocx"
    shutdown -r -t 10
    del /f /q %0

    Once you've done that click on File and select Save As...

  • In the Save dialogue box click on the drop down menu next to Save as type and select All Files
  • Name the file Fix.bat (the .bat extension is very important)
  • Save the file to your desktop double-click on it if running Windows 2000 or Windows XP. If using Windows Vista or Windows 7 you must right-click on it and select Run as administrator then click Continue at the User Account Control prompt.
  • You should see a series of message boxes reporting that the files were registered successfully, click OK to each.
  • Once the tool is finished it will automatically restart your computer, allow it to do so.
  • After your system reboots, try running Malwarebytes' Anti-Malware again to see if it is now working properly or not.

Please post back with your results as well as any error messages if you should encounter any.

Link to post
Share on other sites

Greetings :)

Please do the following:

Note: You must be logged into an administrative user account for this to work.

  • Please copy and paste the following text exactly as written into notepad (not wordpad or any other text editor):
    @color 48
    @echo off
    if exist "%programfiles(x86)%" regsvr32 "%programfiles(x86)%\Malwarebytes' Anti-Malware\mbamext.dll"
    if exist "%programfiles(x86)%" regsvr32 "%programfiles(x86)%\Malwarebytes' Anti-Malware\ssubtmr6.dll"
    if exist "%programfiles(x86)%" regsvr32 "%programfiles(x86)%\Malwarebytes' Anti-Malware\vbalsgrid6.ocx"
    if not exist "%programfiles(x86)%" regsvr32 "%programfiles%\Malwarebytes' Anti-Malware\mbamext.dll"
    if not exist "%programfiles(x86)%" regsvr32 "%programfiles%\Malwarebytes' Anti-Malware\ssubtmr6.dll"
    if not exist "%programfiles(x86)%" regsvr32 "%programfiles%\Malwarebytes' Anti-Malware\vbalsgrid6.ocx"
    shutdown -r -t 10
    del /f /q %0

    Once you've done that click on File and select Save As...

  • In the Save dialogue box click on the drop down menu next to Save as type and select All Files
  • Name the file Fix.bat (the .bat extension is very important)
  • Save the file to your desktop double-click on it if running Windows 2000 or Windows XP. If using Windows Vista or Windows 7 you must right-click on it and select Run as administrator then click Continue at the User Account Control prompt.
  • You should see a series of message boxes reporting that the files were registered successfully, click OK to each.
  • Once the tool is finished it will automatically restart your computer, allow it to do so.
  • After your system reboots, try running Malwarebytes' Anti-Malware again to see if it is now working properly or not.

Please post back with your results as well as any error messages if you should encounter any.

Thanks for your help Exile360.

I created and ran the fix.bat file the confirmation messages appeared and the PC rebooted automatically but after reboot the runtime 440 and 0 errors still report.

Any other suggestions?

Link to post
Share on other sites

  • Staff

Hello again :)

You're most welcome, I'm sorry that it didn't work.

Let's try a slightly different approach:

  • Uninstall Malwarebytes' Anti-Malware from Add/Remove Programs and then reboot your computer
  • Download and run mbam-clean.exe from here
  • Allow it to reboot your computer
  • Download and install version 1.45 of Malwarebytes' Anti-Malware from here
  • Attempt to run it to see if it has the same errors, and if it does not, click on the Update tab and click the Check for Updates button and allow it to download and install the latest version
  • Test to see if it is now working correctly without errors or not

Please let me know if it is working now or not, and if not, at which point it failed (ie, after installing 1.45 or after installing 1.46 again).

Thanks :)

Link to post
Share on other sites

Hello again :)

You're most welcome, I'm sorry that it didn't work.

Let's try a slightly different approach:

  • Uninstall Malwarebytes' Anti-Malware from Add/Remove Programs and then reboot your computer
  • Download and run mbam-clean.exe from here
  • Allow it to reboot your computer
  • Download and install version 1.45 of Malwarebytes' Anti-Malware from here
  • Attempt to run it to see if it has the same errors, and if it does not, click on the Update tab and click the Check for Updates button and allow it to download and install the latest version
  • Test to see if it is now working correctly without errors or not

Please let me know if it is working now or not, and if not, at which point it failed (ie, after installing 1.45 or after installing 1.46 again).

Thanks :)

No Luck!

I did as instructed. On clicking finish, the 0 error appears then the 440 error, after the 440 error is OKed the 0 error appears a second time followed by the 440 error (this is with the launch malwarebytes and download updates boxes checked).

Link to post
Share on other sites

Please click on START - RUN and copy paste the following into the run line and click OK and post back what it says or what happens.

CMD /K regsvr32 "C:\Program Files\Malwarebytes' Anti-Malware\ssubtmr6.dll"

DllRegisterServer in C:\Program files\Malwarebytes' Anti-Malware\ssubtmr6.dll succeeded.

Link to post
Share on other sites

  • 3 weeks later...

@ rroberto18

Greetings! :) You posted under someone else's post Please start your own New Topic If you look at what you posted. Post # 6 above [Is this Windows XP, Vista, or Windows 7 ?] See post # 8 and the rest of the post and tell us what kind of OS you are running? So we can give you the right code

Were always glad to help. regards....

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.