Jump to content
wandering_wizard

MBARW destroyed my photos app

Recommended Posts

the older 0.9.16 beta removed my windows 10 photos - app. (the exe got quarantined)

can anyone please help me to get it back?

I already tried unistalling / reinstalling the app via powershell.

it is listed as installed in the store but won't run.

Thanks

 

Share this post


Link to post
Share on other sites

Hello wandering_wizard and :welcome:

Using only the native Windows built-in zip utility, please create the following, separate, .zip archive files for MBARW developer team analysis:

                              "%ProgramData%\Malwarebytes\Malwarebytes Anti-Ransomware\"
                              "%ProgramData%\Malwarebytes\MBAMService\logs\"
                              "%ProgramData%\MalwarebytesARW\"

Please attach the archives to your next reply.  Thank you for your beta testing contribution to the Malwarebytes Anti-Ransomware (MBARW Beta) project and your valued feedback.

Share this post


Link to post
Share on other sites

Hi, this was fixed a while' already.

Thanks for reporting though.

It's always a good idea to use/update to our latest version because it has many bug and other fixes.

 

Share this post


Link to post
Share on other sites

It should if you restore it from quarantine or just reinstall the app (after uninstalling). It hasn't deleted any of your photos though.

Share this post


Link to post
Share on other sites

Interesting, as it should have been there no matter what.

I wonder if something else was rather interfering.

Anyway, just look if you can uninstall the app first - then also uninstall this older version of malwarebytes antiransomware and reboot.

Then reinstall the app you want - if you're still having problems, then this is certainly not an issue with mbarw since you have it uninstalled already.

Once you get the app installed again, then install latest mbarw build.

 

Thanks!

Share this post


Link to post
Share on other sites

I just now uninstalled MBARW then removed the Photos-App then reinstalled the Photos-App. It does not run.

-

I am not putting the blame on you at all. I think I have emptied the quarantine while I unseccussfully tried to reinstall the Photos-App
at some point. I think I first tried to un-quarantine it with the old version that quarantined it in the first place. That did not work as many
people have also experienced. I then waited for an MBARW update to happen so that I may would be able to un-quarantine it later.
When there was an update it still did not un-quarantine. I then uninstalled and reinstalled Photos via Powershell using  Get-AppXPackage /
Remove-AppxPackage
. When that didn't work I emptied the quarantine in MBARW and tried the Powershell game again to no avail.

I then waited for the Windows 10 Anniversary Update (or whatever that one was called) and thought well it might be back and all new then.
It came and it wasn't. I am not blaming you for it being not in the quarantine but you know... If it weren't for you I would still have that app ;) so...

I thought you may could give me some guidance on what to do here. :rolleyes:


Thank You for answering and thank you for your great products.

Share this post


Link to post
Share on other sites

Can you guide me and post the exact name of the app or the url? Because I don't see why it wouldn't allow to reinstall even with mbarw removed.

Edited to add - I'm sure you've tried this already, but mind to give all steps a try once more: http://www.intowindows.com/how-to-reinstall-the-photos-app-in-windows-10/ ?

Unless something got buggy (windows related) after he anniversary update.. because when I read the comments there, it seems more people are having this issue after the anniversary update.

Edited by miekiemoes

Share this post


Link to post
Share on other sites

I've just did some additional testing here (also windows 10 unniversary update) and I also have problems with the Photos app, even without mbarw installed.

So it rather looks like a Microsoft problem after all.

In my case, it's ok, since I don't use it anyway because I'm using a free alternative So if I can suggest these free alternatives to you, here is what I use:

http://www.phoxo.com/en/

http://www.getpaint.net/index.html

Edited by miekiemoes

Share this post


Link to post
Share on other sites

I just did it again as described in the link you provided. It is the exact thing I did before.

The app's name is Microsoft.Windows.Photos_16.722.10060.0_x64__8wekyb3d8bbwe

Full dump:

Name                   : Microsoft.Windows.Photos
Publisher              : CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US
Architecture           : X64
ResourceId             :
Version                : 16.722.10060.0
PackageFullName        : Microsoft.Windows.Photos_16.722.10060.0_x64__8wekyb3d8bbwe
InstallLocation        : C:\Program Files\WindowsApps\Microsoft.Windows.Photos_16.722.10060.0_x64__8wekyb3d8bbwe
IsFramework            : False
PackageFamilyName      : Microsoft.Windows.Photos_8wekyb3d8bbwe
PublisherId            : 8wekyb3d8bbwe
PackageUserInformation : {S-1-5-21-3723852905-3280769982-1538686743-1001 [Immo]: Installed}
IsResourcePackage      : False
IsBundle               : False
IsDevelopmentMode      : False
Dependencies           : {Microsoft.VCLibs.140.00_14.0.24123.0_x64__8wekyb3d8bbwe,
                         Microsoft.NET.Native.Framework.1.3_1.3.24201.0_x64__8wekyb3d8bbwe,
                         Microsoft.NET.Native.Runtime.1.3_1.3.23901.0_x64__8wekyb3d8bbwe,
                         Microsoft.Windows.Photos_16.722.10060.0_neutral_split.language-de_8wekyb3d8bbwe...}


It does uninstall and reinstalles from the store with no problems. But when I click on 'Run' (It's actually 'Öffnen' in german) nothing happens.

What may be interesting is that there is a Microsoft.Photos.exe in
C:\Windows\InfusedApps\Packages\Microsoft.Windows.Photos_16.511.8780.0_x64__8wekyb3d8bbwe
but its only 17kb...

Share this post


Link to post
Share on other sites

See my post above - I seem to have the same problem (although in dutch in my case) - even without mbarw installed.

Share this post


Link to post
Share on other sites

Well I do have four PCs here. They all had the same updates in the same sequence, one is even the exact same notebook as the
one thats having the Photos app not running. They all run MBARW. They all run the Photos-app.

The only difference is that the one that is having the problem was quarantining the Windows.Photos.exe before.

Share this post


Link to post
Share on other sites

That's interesting indeed - so you don't have the same issue on the other PCs even with mbarw running? So it didn't quarantine there, while it did on that one pc and because of that, you can't reinstall it?

In my case, after uninstalling, I can't run photos app after reinstalling as I get the same errors and this without mbarw, so something is really wrong here.

I'll report this to MS myself as it shouldn't behave like that.

Thanks for beta testing our program, as this always helps to find additional bugs even when not *really* related with our program.

Share this post


Link to post
Share on other sites

Yes it was quarantined only on one PC. The one with the Photos-app not starting now.

So you had 

1. the Photos app unistalled or MBARW unistalled?
2. or was the Photos app already not installed and you unistalled MBARW?

I dont get any errors so I don't know what errors you are talking about.

Edited by wandering_wizard

Share this post


Link to post
Share on other sites

I didn't have mbarw installed on this pc - I just uninstalled photos to troubleshoot (win10 anniversary build) and when I tried to reinstall, I couldn't. It just didn't run.

Share this post


Link to post
Share on other sites

I just uninstalled MBARW on another notebook then unistalled the Photos-app on that machine then reinstalled the Photos-app
and it works fine. I am pretty shure it will work the same way on any other machine I have but the one that had the app quarantined before
by MBARW.

Its actually pretty preposterous to assume that there is a general problem with unistalling / reinstalling apps on Windows 10 that would
not have been known by now.

I must say that you seem to me to be trying to get rid of me by stating you are having the same problem and blaming it on windows.

I was getting suspicious before when you were actually recommending me to use other software rather than fixing the problem.

 

Share this post


Link to post
Share on other sites

What i have tested is - I uninstalled the photos app on my other pc, then upgraded to the anniversary update which took a bit, and then reinstalled the photos app again where it didn't load at all. So not trying to get rid of you as that isn't my intention at all, I am just trying to troubleshoot.

As some additional info, I just noticed that some other apps won't launch either anymore. I'm not really an "app user", so I wouldnt have spot this normally.

Edited by miekiemoes

Share this post


Link to post
Share on other sites

Well uninstalling the photos app then reinstalling it on the PC that had the photos app quarantined by MBARW before did not work
before the anniversary update was installed and it did not after.

You are trying to blame the anniversary update because you think I was referring to it as something I was not entirely comfortable with
because I titled it "Windows 10 Anniversary Update (or whatever that one was called)" earlier. 

Because of that expression you think I would agree to lay blame here but of course that update is not the problem.

You also think that I can not verify what you claim you did in your last post because I have stated that all my PCs are on the update already
and so you have a safe made up argument. But of course I can. I have access to many more machines elsewhere.

Finally applying the anniversary update even on a fast machine takes far longer than the time that has passed between your posts.



 

Share this post


Link to post
Share on other sites
1 hour ago, miekiemoes said:

As some additional info, I just noticed that some other apps won't launch either anymore. I'm not really an "app user", so I wouldnt have spot this normally.


I am sorry but stating that 'other apps' (assuming you mean major apps that come with windows, because of course you have not installed
own apps because you are not an 'app user') will not run after the anniversary update which is a major mainstream update for every Windows 10
system that was tested thoroughly is just plainly ridiculous.

I don't think you are a technically adept person but are pandering to techies by demoting the user experience-oriented and thereby so uncool anniversary update and windows apps usage. 

Edited by wandering_wizard

Share this post


Link to post
Share on other sites

I am sorry that you think that way, but that's ok.

My Windows calculator and finance app quit working as well, so I uninstalled them using the following commands:

Get-AppxPackage *bingfinance* | Remove-AppxPackage
Get-AppxPackage *windowscalculator* | Remove-AppxPackage
Get-AppxPackage *photo* | Remove-AppxPackage

Then these appeared in the Windows store again where I could reinstall. After reinstalling, they didn't launch.

I shut down my pc and went to sleep.

This morning, I tried above again, uninstalled again and this time, after getting/reinstalling them from the Windows store, they did launch properly again.

It's not because I don't use the Windows built in apps (apart from mail and calendar) or other apps, that I dislike them, nor dislike Windows 10 and its updates, on the contrary.

Share this post


Link to post
Share on other sites

Hi,

I did some more troubleshooting for your case.

So I tried to reproduce this by deleting the Microsoft.Photos.exe manually from the C:\Program Files\WindowsApps\Microsoft.Windows.Photos_16.722.10060.0_x64__8wekyb3d8bbwe (as that's actually what MBARW has done before in your case).

Note, by default, you don't have permissions to that folder, but I'll send you a private message how to get permissions to this after all (since I don't want other people tinker with permissions if not needed).

It seems that, using the Get-AppxPackage *photo* | Remove-AppxPackage and reinstalling indeed won't work if Microsoft.Photos.exe isn't there. I verified and after reinstall, no Microsoft.Photos.exe got recreated, nothing launched.

So what I've done instead is, I deleted the C:\Program Files\WindowsApps\Microsoft.Windows.Photos_16.722.10060.0_x64__8wekyb3d8bbwe folder first

Then I used Get-AppxPackage *photo* | Remove-AppxPackage

Then I installed from the Windows store again and this time it installed everything properly again.

 

 

Share this post


Link to post
Share on other sites
On ‎01‎/‎10‎/‎2016 at 4:19 PM, miekiemoes said:

Hi, this was fixed a while' already.

Thanks for reporting though.

It's always a good idea to use/update to our latest version because it has many bug and other fixes.

 

And just how does one check for updates? I don't see any way to do that.

Share this post


Link to post
Share on other sites

Hi,

Automatic upgrades are enabled in latest build, as explained here:

For FP fixes, this doesn't require updates since that is fixed on our end.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.