Jump to content

help with weird firefox issue


fivealive
 Share

Recommended Posts

i know that the plugin container.exe is a ligit process

i just dont know how come it was running

i only have 2 addons installed

noscript

and

adblock plus

neither of which need plugin container.exe so im confused on why it was running in the task manager 3 times

any help on figure this out would be greatly apreciated

Link to post
Share on other sites

Hi, fivealive:

Assuming you don't actually have more than one instance of Fx running...

It looks as if plugin-container.exe actually supports Adobe Flash, Apple Quicktime and MS Silverlight, not regular extensions, such as ABP or NS.

(According to the Mozilla.com support page).

So, perhaps that's why you see more than 1 copy of it in the task manager?

Until one of the pros stops by, perhaps also take a look at this plug-in container KB article at the Mozillazine Fx forums?

You might also search the boards there for related topics, as there are many, many threads about plugin-container.exe -- it's very high volume, with a lot of long-time Fx experts (not that the folks here aren't, of course! :D )

Hopefully, someone more geeky than I will have something more concrete to offer, :)

daledoc1

Link to post
Share on other sites

I was sure this was the case but I couldn't find the reference to it... till you posted that plug-in container KB article ( that I'll now add to my long list of reference bookmarks :) ) its in there under Firefox 4 and above > Windows and Linux

In Firefox 4 and above on Windows and Linux, the OOPP crash protection feature is enabled for all plugins and the preference dom.ipc.plugins.enabled is set to true, by default
Link to post
Share on other sites

Yup -- seems to relate to actual PLUG-INS (hence the name, I suppose), rather than to EXTENSIONS.

(That whole terminology of "extensions" vs. "add-ons" vs. "plug-ins" is VERY confusing, especially when folks inadvertently use the terms interchangeably, as we non-geeks tend to do.)

Regards,

daledoc1

Link to post
Share on other sites

nothing but the normal stuff that firefox has by it self

which is why i was confused on why the plugincontainer.exe was running

i dont have adobe pdf or flash player or shockwave or even java installed on the computer which is where my concern comes in

since only thing installed on the machine was wow ventrillo firefox mbam pro mse

and on firefox only addons i have is adblock plus and noscript

thats it

and only thing running at the time i noticed these was firefox i had 4 tabs open but i was searching on google at the time i noticed these plugins

one other thing to note is i did end the processes right away when i noticed them and went to try and scan the computer with mbam and it crashed istantly on open

Link to post
Share on other sites

Firefox ships with 3 plugins included, from Firefox 4 onward the OOPP crash protection feature is enabled for all plugins by default.

ok so thats what it could have been then still confused cause iv never seen that before

mind you i only switched to firefox 7 the other day on teh advice of shy

Link to post
Share on other sites

ok so thats what it could have been then still confused cause iv never seen that before

mind you i only switched to firefox 7 the other day on teh advice of shy

ok, :) so you where running a 3.6 version before? that may be why you didn't notice it, In the initial release only 3 plug-ins were isolated by default: Adobe Flash Player, Apple Quicktime, and Microsoft Silverlight, ;)

edit:

just noticed your note about mbam crashing, will it run? .... I wouldn't think that's related

Link to post
Share on other sites

ok, :) so you where running a 3.6 version before? that's why you didn't notice it, In the initial release only 3 plug-ins were isolated by default: Adobe Flash Player, Apple Quicktime, and Microsoft Silverlight, ;)

edit:

just noticed your note about mbam crashing, will it run? .... I wouldn't think that's related

well when i noticed the plugincontainer.exe i imediately ended the processes and the nran a quick scan with mbam then went to run a full scan just incase and then mbam crashed

and wouldnt run again even lost it in teh task bar (i use pro)

after that i went to open mse and it crashed so it could be a virus

but im also starting to think its faulty ram i actually formatted my computer like 2 weeks ago because of crashing issues

so im thinking its a ram issue

and your saying the plugincontainer is normal then

and shy i dont blame you at all im still learning about the new firefox XD

ill mention tho i have obsessive compolsive disorder so when stuff like this happens it drives me up the wall

im also rather paranoid when it comes to computer security

i got hit over a year ago by a drive by download and since then iv pretty much restricted my surfing on the web to a limited number of websites havnt got a virus since then but iv had odd errors come up every once in awhile

Link to post
Share on other sites

Hmm.... you definitely have something else going on there if MBAM & MSE are crashing on you.

Will Malwarebytes run in safe mode?

have you had any infections lately?

is this the same computer your having malicious IP's blocked on? --->> http://forums.malwarebytes.org/index.php?showtopic=97285

is this the same computer you had issues with before?

Lets rule out malware infection first

follow the instructions in I'm infected - What do I do now? An Expert will assist you.

Alternatively, as a paying customer, you can contact the help desk at support@malwarebytes.org

if you post a log in the HJT section post a link to it in this thread, I'd like to shadow it.

Link to post
Share on other sites

no its a different computer that the ip blocks where happening and the ip blocks only happened when visiting pogo.com

and windows ended up crashing not long afterwords im starting to think its ram thats the issue

EDIT:

also of note iv yet to get anyone else to goto pogo.com and see if there getting hte blocks like i am

because if there not then that would indicate its a computer issue

Link to post
Share on other sites

Your welcome! :)

yeah im still waiting to hear back from them atm

pogo.com is owned by ea if i recall correctly they answered me twice but never did answer bout the ip addresses claimed its impossible for there ads to spread infections since there in flash and java but we both know thats not true

Link to post
Share on other sites

hmm its not being blocked for me at the moment. as Firefox said it could have been an add being blocked.

hows everything else. How is the machine running?

Is MBAM & MSE working correctly now?

i ended formatting the hd because of hte problem and i havnt reinstalled windows yet because i think its faulty ram causing the issue because i had just reinstalled windows a week before because malwarebytes crashed and then mse and a week after the format it crashed again

and the pogo.com thing was on another computer all together but some how it ended up in this conversation

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.