Jump to content
treed

Apple's Legacy System Extension warning

Recommended Posts

Posted (edited)

Today, Apple released macOS 10.15.4, which adds a new warning when kernel extensions are installed:

646972284_ScreenShot2020-04-06at3_09_55PM.png.18cf692e5e6c36a32d6125b356edbbea.png

More information from Apple can be found here:

https://support.apple.com/en-us/HT210999

We are aware of this, and have been working on replacing our kernel extension since late last year. We plan to replace it with Apple's new EndpointSecurity framework before the release of macOS 10.16, when it is assumed that kernel extensions will no longer work, in part or in full. (We only know that Apple has said they "will not work without compromise" in "a future version of macOS." But we'd rather not find out the hard way exactly what that means.)

The kernel extension will continue to be supported for macOS 10.14 (Mojave) and earlier, but macOS 10.15 (and later) will no longer need it, once we have an update available.

So, no need to panic. We've still got your back, and won't let your protection falter. All you've got to do is make sure you're keeping Malwarebytes for Mac up-to-date. If you have updated to at least version 4.2, and have not disabled the new auto-update feature, it'll update itself in the background without you needing to do anything. To ensure you're up-to-date, just open Malwarebytes and choose Check for Updates from the Malwarebytes menu.

2099339332_ScreenShot2020-03-24at3_58_59PM.thumb.png.cb216e3b25336a524a7a29821343e639.png

Edited by treed

Share this post


Link to post
Share on other sites

Still totally usless information. Since March I have gotten this error on and off.

Goes away, comes back. Came back today.

Do the above, "You are using the current version of Malwarebytes"

So exactly **WHEN** will this be fixed? Maybe indicate the ACTUAL version it was fixed in if that is the case.

To have us find this, and just keep trying to update and get none is totally useless and moronic.

Share this post


Link to post
Share on other sites

I believe I read that it comes back every thirty days.

It should be fixed on or before the time when that "future version of macOS" is released. Not only do we not know exactly when that date is, as of today we don't even know what version of macOS will actually make the current version incompatible.

I would not expect Malwarebytes to have a "compatible" version available for you before whatever macOS becomes available for testing such a version. The whole point of this posting is to let you know you can safely ignore the warning as the developer is already well aware of the requirement. The only thing that now needs to be updated is that the next version of macOS is 11.0 and not 10.16, but even that may not be the OS that breaks things.

Share this post


Link to post
Share on other sites
11 hours ago, GGITech said:

So exactly **WHEN** will this be fixed?

i'd encourage actually reading the information before dismissing it as useless, as the answer is plainly stated:

Quote

We plan to replace it with Apple's new EndpointSecurity framework before the release of macOS 10.16

Apple regularly releases new major macOS updates every fall. We're assuming this one will be no different. If Apple delays it, that won't change our timeline at all.

We cannot give a specific date. If we do, and something happens such that we miss the date by even a few days, we get all kinds of rude messages, here in the forums and elsewhere. I'm sure you understand.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.