Jump to content

Error "Unable to Connect to the Server" - after upgrading to v3

Recommended Posts

I've been a Premium member for many years. A few days ago I updated to v3.x via the link in the MB application.
There was a glitch of some sort causing me to get the the blue screen (Windows 7). After rebooting, MB ran fine for about a day. All of a sudden I can't get it to open. I'm getting the error "Unable to connect to the server".

Should I uninstall MB and reinstall my older version and start over again with the update? I'm assuming the update is free for Premium members (lifetime license). Otherwise it would have asked for a payment. Is that correct?

Any help is appreciated.

Link to post
Share on other sites

Hello and Welcome

You mentioned you upgraded ,Sometimes the upgrades do not go smoothly, so lets try a clean re-install to see if that helps. (remember to deactivate your license first) If you need instructions on how to deactivate please ask before proceeding.

Let's try this first....

  1. Please follow the steps in this pinned topic to uninstall your current version of MBAM and reinstall the latest build - Malwarebytes mb-clean tool (after uninstalling you can download the latest version to re-install from HERE)
  2. If that does not correct the issue, then please read the following and attach to your next reply the 4 requested logs - Diagnostic Logs (the 4 logs are: mbam logs zipped, FRST.txt, Addition.txt and mb-checkResult.txt)
  3. NOTE: More info about Malwarebytes 3.0.6 CU3 HERE; MB 3 User Guide ONLINE; MB 3 User Guide PDF; MB 3 FAQ: Malwarebytes 3.0 - Frequently Asked Questions

Please let us know how it goes.
Thank You,

Edited by Porthos
Link to post
Share on other sites


I just want to clarify & pin down a few details.  I take it that the pc had had version 2 before & you only recently accepted the upgrade to version 3.  is that right ?

Second, was a restart done immediate after the setup got done ?  Is that the point on which the message 


 "Unable to connect to the server"

started to show ?

Thirdly, does this pc have by chance a antivirus from F-Secure ?  else, is there some 3rd-party brand of antivirus?  which one ?

Four, does this pc have any add-on type program that possibly has a "web filter" or "web shield" or a 3rd-party firewall?


Link to post
Share on other sites

Thank you for your replies.

Porthos - I'm afraid I don't know how to deactivate my license, so I'll have to ask.

Will I have any issues entering my older license in to the newer 3.x version?


Maurice -

1. Yes, You are correct: my pc had had version 2 before & I accepted the upgrade to version 3 2 days ago.

2. Yes, a restart was done immediately. The BSOD left no option and No, the "Unable to connect to the server" error did not occur immediately. The first thing that happened when I executed the MB install was that I got the BSOD before it could completely install. From the BSOD, I let the system reboot itself. Everything looked fine. I was familiarizing myself with the new interface and choosing my MB settings. Even ran a scan (nothing found). Now here's the twist. I've been having ongoing issues with my Dell Precision M6500 Workstation running at a crawl. I have a remote tech service (TechtoUs.com) and called to have my system cleaned. I know they use MB as well in their cleaning process but he may have downloaded his own MB app to use, rather than my newly installed MB. Cleaning was temporarily successful (as usual) and system ran like lightening all night. This morning I'm back to something dragging my system down so I tried to launch MB for a scan and got the  error message, "Unable to Connect to the Server". My first thought was to call my tech service back but I wanted to see if I could get any advice here first.

3. No F-Secure installed on this system that I'm aware of. I use MS Sec Essentials.

4. No 3rd party web filters that I'm aware of. I use the Windows firewall.

~Thank you again~

Link to post
Share on other sites

Producer -

Wish I'd tried that first but, in my case, I didn't uninstall my old v2 first, which may have resulted in the blue screen and the issues I'm having now. 

Porthos is saying that it's necessary to deactivate your license first. Trying to find out how/why to do that since I can't open MBAM now.

Link to post
Share on other sites

37 minutes ago, artgal said:

Trying to find out how/why to do that since I can't open MBAM now.

Since you cant open MB now you cant deactivate. Dont worry right now..  When you reinstall if MB does not activate when you insert the license the only way to reset it is thru the help desk (via E-mail). That is the reason to deactivate first.

Edited by Porthos
Link to post
Share on other sites

1 hour ago, artgal said:

Were the log files I uploaded of any help?

I am not authorized to give any advice on the logs. Only staff are allowed to post that advice /fixes.


1 hour ago, artgal said:

Do I need to uninstall first (through Windows)?

I would try that and reboot then run the clean tool. I would try to add exclusions for MB in MSE before you do this if possible.

I suggest adding these to the exclusion list in MSE And exclude MSE in Malwarebytes.


C:\Program Files\Malwarebytes\Anti-Malware\MbamPt.exe
C:\Program Files\Malwarebytes\Anti-Malware\mbam.exe
C:\Program Files\Malwarebytes\Anti-Malware\assistant.exe
C:\Program Files\Malwarebytes\Anti-Malware\MBAMWsc.exe
C:\Program Files\Malwarebytes\Anti-Malware\mbamtray.exe
C:\Program Files\Malwarebytes\Anti-Malware\MBAMService.exe

Link to post
Share on other sites

Hello Artgal,

How are things now ?   If there is still the same "message" then  

Let's please make some adjustments for the startup settings of Malwabytes
Inside of *Malwarebytes* under *Settings* -> *Protection*,
scroll down to Startup Options   ( see image snapshot below)
Start Malwarebytes at Windows startup  should be on by default.

Be sure that *Delay* Real-time Protection is set to OFF ( 1) & lets have it OFF

Look at Enable *self-protection module* (2)  and lets have it OFF


When all done, close Malwarebytes.
Please use the Windows Start menu and do a Restart.
Perhaps if this is on Windows 10, you should do a Restart >> Shutdown  ( then wait a minute)  & then power back ON & startup Windows.

Have patience on the next round as Windows loads up.


Link to post
Share on other sites

Well, I got the application uninstalled and reinstalled and it seems to be working fine. Trying to add the MSE Exceptions and the problem is that MB is showing as the active Virus app. MSE is listed under it but is not clickable to get into it. Seems as If I have to first deactivate MB to do that. I don't remember MB as being listed as a virus app but rather a malware app, able to run along with MSE without conflict. Is that something new with 3.x? To top things off I'm having multiple other system issues, with the system running slow and can't even get my image editing app up to do a screenshot. Many fish to fry here :(

Link to post
Share on other sites

Hi @artgal, sorry to hear you're having so many issues. Malwarebytes 3.x does function as an AV replacement, but is able to run alongside other AV programs if you wish. If you want MSE to stay enabled, open up Malwarebytes 3.x, go to Settings -> Application and scroll down to the Windows Action Center section. In here, set Malwarebytes to never register with Windows Action Center like in the screenshot below.


What image editing app are you having issues with? Do you get any specific errors?

Link to post
Share on other sites

  • 1 month later...

According to Dell Precision M6500 Manual- guideusermanual.com/product-name-precision-m6500-manual&po=344512&lang=English, to fix this issue:
STEP 1: Restore the default proxy settings to your machine
STEP 2: Remove Unable to connect to the proxy server adware from Internet Explorer, Firefox and Google Chrome with AdwCleaner
STEP 3: Remove Unable to connect to the proxy server browser hijacker with Junkware Removal Tool
STEP 4: Remove Unable to connect to the proxy server pop-up virus with Malwarebytes Anti-Malware Free
STEP 5: Double-check for the “Unable to connect to the proxy server” malware with HitmanPro
(Optional) STEP 6: Remove Unable to connect to the proxy server pop-up ads from Internet Explorer, Firefox and Google Chrome

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.