Jump to content
Rigsby

MBAE service taking too long to start

Recommended Posts

I installed the latest version (1235) when it came out and all was fine until today. I noticed it wasn't running and when I tried to start it I got the the message "MBAE service is taking to long to start. Please reboot your computer".

Rebooting the computer had no effect and the above message continued to be displayed so I re-installed the previous version and all is well.

There is obviously a conflict somewhere.

[Windows 7 Pro; Panda Antivirus Free; Zonealarm Firewall Free]

Share this post


Link to post
Share on other sites

same problem started for me this morning, reset does not help.

win XP x64

malwarebytes anti-exploit 1.9.1.1235

copied message below:

---------------------------
Malwarebytes Anti-Exploit
---------------------------
The Malwarebytes Anti-Exploit service is taking too long to start.
Please reboot your computer to restart protection.
---------------------------
OK   
---------------------------

 

Share this post


Link to post
Share on other sites

I have exactly the same problem - only started happening today.

I use the free version, and can't find any error logs to help find out what's causing it.

Share this post


Link to post
Share on other sites
Can you all attach your MBAE Logs and other information specified in this link for Malwarebytes staff to look at.
https://forums.malwarebytes.org/topic/144403-readme-first-posts-here-need-to-include-mbae-logs/
The easiest way to zip the logs is to select all the files in the folder C:\ProgramData\Malwarebytes Anti-Exploit, right click > Send to > "Compressed (zipped) folder".  Then attach the zip file to a reply here.

Share this post


Link to post
Share on other sites

See customerxyz post above.  Yesterday, I downloaded and installed the latest temporary version of the MBAE program and today, Oct 30 2016 at 1330h Eastern time in the USA, the MBAE loaded successfully upon start-up.  Now I have the challenge to regain the non-temporary status for the program.  

Share this post


Link to post
Share on other sites

Hello everyone,

Can you please take a screenshot of the C:\Program Files (x86)\Malwarebytes Anti-Exploit and post it here?

 

As well, if you have not tried a clean re-install I would recommend trying that next. Go ahead and remove the program from the un-install menu and once you do that, download the cleaning tool from this location:

 

https://forums.malwarebytes.org/applications/core/interface/file/attachment.php?id=199258

Run the tool in there and reboot the computer. Once you do that, download the latest version again from this link:

 

https://downloads.malwarebytes.org/file/mbae

 

If that does not work after you install it, please let me know. 

Share this post


Link to post
Share on other sites

OK. This is a bit complicated but I'll try to keep it simple.

Uninstalled v1.04.1.1012. (which worked OK).
Was unable to run the cleaning tool. "Must have administrator privileges".

Installed v1.09.1.1235 from website given. It ran and worked fine until I rebooted the computer then the same thing happened and the '...taking too long...' window was displayed. When I manually ran the program, it ran for about 5 mins then terminated with the same message. The service MbaeSvc was in the list of services but stopped and I couldn't start it (access denied).

I've uploaded a screenshot of the mbae directory in Program Files and 2 zips - new version working before the reboot and after the reboot (not working). I hope this helps.

MBAE directory.png

 

Malwarebytes Anti-Exploit-BEFORE REBOOT.zip

Malwarebytes Anti-Exploit - AFTER REBOOT.zip

Share this post


Link to post
Share on other sites

This is weird.

I have not re-installed Anti-Exploit or changed anything on my PC other than send in the required logs, and this morning Anti-Exploit started successfully on boot up at 7 am and has been running fine ever since!

Yes, of course I'm pleased, but I'd really like to know why.....

Share this post


Link to post
Share on other sites

Hello Rigsby,

 

I want to collect some more system information from you. I want to have you use a tool called FRST. To do this:

1: Please download FRST from the link below and save it to your desktop:

http://www.bleepingcomputer.com/download/farbar-recovery-scan-tool/

2: Double-click the purple FRST icon to run the program. Click Yes when the disclaimer appears.

3: Click the Scan button

4: When the scan has finished, it will make 2 log files in the same directory the tool is run, FRST.txt and Addition.txt. Please attach both files in your reply.
 

 

Share this post


Link to post
Share on other sites

Hello everyone,

 

Thank you for the logs. I am going to be sending each of you that has provided the logs so far a PM to give further instructions on some logs to collect. You will be hearing from me soon! 

Share this post


Link to post
Share on other sites

I have a similar issue, when I start windows the network icon freezes with the circle as if the network is not ready

I load up firefox and can surf the net instantly.

Meanwhile MalwareBytes Anti-exploit still isn't loaded

I cannot launch any system program, regedit or event viewer during this time.

Event viewer shows that Anti-exploit was hung on starting.

1 minute later, the network icon is back to normal, anti-exploit is loaded, and the system application is now UAC prompting.

It is irrefutably a bug.

Please provide the latest stable version prior to all these caught caught new features

Or provide the latest beta.

Windows 7 64 Bit Ultimate SP1 completely updated with only zone alarm firewall free installed.

Edited by neonred

Share this post


Link to post
Share on other sites

Malwarebytes Anti-Exploit 1.08.1.2572 is the last known working version.

Maybe the bug is related to a windows update.

Share this post


Link to post
Share on other sites

One more thing, even though Malwarebytes Anti-Exploit 1.08.1.2572 is starting without flaw, I cannot see the indicator that I am protected when I run Firefox which is Extremely particular.

Share this post


Link to post
Share on other sites

This happens when service application doesn't respond to SCM in specified time. You can increase time to respond by adding value to registry.

Try this: Open regedit (run it as a administrator), go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control and look for value ServicesPipeTimeout,

if you don't have it create it by right clicking NEW DWORD value, name it ServicesPipeTimeout and in newly opened window, this is important, check decimal value.

It measures in miliseconds (2 minutes will be 120 000). After you did this go to Services ( run as a Admnistrator), open Malwarebytes Anti-Exploit Service and in startup type change it to Automatic (Delayed Start). Although I haven't had messages to restart computer, except in the Event Viewer that AE service hung on starting this helped me to get rid of the error messages. This would be a temporary fix until they release a patch.

Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.