Jump to content
Rigsby

MBAE service taking too long to start

Recommended Posts

Hello Neonred,

 

Can you try the instructions I left above to do a clean re-install? It seems  a majority of the issues are just coming from the upgrade and a re-install will fix it. Make sure you use the clean tool and run it as admin as it will make sure all of our directories are removed so you can do a clean re-install. 

Share this post


Link to post
Share on other sites

No, I can confirm the issue is not limited to upgrading.  It was on a new Windows 64 bit ultimate system.

More likely the devs have shorted investment in Windows 7 debug.

Your suggestion makes sense, eventlog told me the same thing just not how to fix it.

It's irritating now that Windows 10 is out, Windows 7 gets left in the dust.

I expect your suggestion to work, if I don't report back it did.

Just an FYI, the last version that doesn't have the bug is 1.08.1.1189 (which runs flawlessly under any condition).

The devs did something between this version and all the ones that followed that crippled the software at least on Windows 7 64 bit.

Seems they innovated too quickly and focused on making sure it worked on Windows 10 but left Windows 7 in the dust.

New versions since then all have the same Windows 7 bug that is not limited to upgrading, but on new installs as well.

In the software world from such a highly regarded company, this is unbelievable.

Nevertheless, thank you.

Share this post


Link to post
Share on other sites

Unfortunately, your solution did not work.  It had no effect.  Something triggers the service to hang almost immediately such that your tweak cannot have any effect.

Going back to the stone age 1.08.1.1189

Share this post


Link to post
Share on other sites

ISSUE FIXED:

Select Automatic Delayed start for Malwarebytes Anti-Exploit service

Run regedit.exe, HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control, Create 32-bit DWORD AutoStartDelay, edit value, select decimal put 15.

Do not use "servicespipetimeout".  The problem is that Anti-Exploit loads before critical Windows Networking Services.  Since the Windows Networking Services are not fully loaded and malwarebytes requests data from these services and does not get it when it requests it, this triggers Anti-Exploit to hang.  

Edited by gonzo
Standardized font used in post

Share this post


Link to post
Share on other sites

Hi neonred. Followed your instructions re. Issue Fixed. Unfortunately it didn't work for me. Problem still remains.

Edited by Rigsby
spelling mistake

Share this post


Link to post
Share on other sites
3 minutes ago, Rigsby said:

Hi neonred. Followed your instructions re. Issue Fixed. Unfortunately it didn't work for me. Problem still remains.

What is the error you got in Event Viewer?

Share this post


Link to post
Share on other sites

Have never used Event Viewer before. Am running it now - what do you want me to look for ??

Share this post


Link to post
Share on other sites

Open Event Viewer as administrator on the left pane look for Windows Logs, open it and look under System.

Check for Service Control Manager Errors.

Share this post


Link to post
Share on other sites

OK. There are 5 'Service Control Manager' entries within the last hour all with a status of 'Information'. No mention of MBAE.

Share this post


Link to post
Share on other sites

Can I just add that I too am having teh same issue.  Windows 10, but I have delayed updates on my system ... so if it is update related, that would explain why I am only just getting it.  If I try and start it manually I get the following popup ...

warning.jpg

Share this post


Link to post
Share on other sites
On 10/11/2016 at 1:27 PM, neonred said:

ISSUE FIXED:

Select Automatic Delayed start for Malwarebytes Anti-Exploit service

Run regedit.exe, HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control, Create 32-bit DWORD AutoStartDelay, edit value, select decimal put 15.

Do not use "servicespipetimeout".  The problem is that Anti-Exploit loads before critical Windows Networking Services.  Since the Windows Networking Services are not fully loaded and malwarebytes requests data from these services and does not get it when it requests it, this triggers Anti-Exploit to hang.  

This has worked for me ...

Share this post


Link to post
Share on other sites

Hello Everyone,

 

We have a test build we want to see works for everyone that is having this issue. This build can be found here:

 

https://malwarebytes.box.com/s/n6cdj8wss05jlepevauf5lwowlq2g9bg

 

If possible, please do an un-install of the previous one and use this clean tool after to cleanup any leftover files: https://forums.malwarebytes.org/applications/core/interface/file/attachment.php?id=199258 (note: this will be the same one I left before for anyone trying the steps earlier in the thread). After you do that, reboot and try that build. Please let me know of any feedback on the build! 

Edited by Rsullinger

Share this post


Link to post
Share on other sites
On ‎18‎/‎11‎/‎2016 at 4:06 PM, Rsullinger said:

Hello Everyone,

 

We have a test build we want to see works for everyone that is having this issue. This build can be found here:

 

https://malwarebytes.box.com/s/n6cdj8wss05jlepevauf5lwowlq2g9bg

 

If possible, please do an un-install of the previous one and use this clean tool after to cleanup any leftover files: https://forums.malwarebytes.org/applications/core/interface/file/attachment.php?id=199258 (note: this will be the same one I left before for anyone trying the steps earlier in the thread). After you do that, reboot and try that build. Please let me know of any feedback on the build! 

I did every single step as you instructed and everything went ok. Thanks a lot.

Share this post


Link to post
Share on other sites

I uninstalled the previous version, but try as I may I couldn't get that cleanup batch file to run. (Administrator privileges needed).

Anyway I re-installed it using the link given and it's working. I rebooted to check and it's still working.

Share this post


Link to post
Share on other sites

Dear All,

I have the new version running, having followed Rsullinger's instructions.  All seems well - no errors - but earlier versions notified me (Windows 10 x64 v1607) when Malwarebytes Anti-Exploit was running, i.e. on launch of browser, and I don't see where the setting is to re-enable this feature.  Any clues?  Otherwise, all OK.

Share this post


Link to post
Share on other sites

Hi Cyberwhelk,

Check the below circled setting and you should be getting the notifications again. We turned it off by default from the 1.09 versions of MBAE.

 

screenshot-1.png

Share this post


Link to post
Share on other sites

I too have had the same problem. I followed the procedure outlined above and it seems to be working. Snag is it thinks I'm on the free trial rather than the paid for application. How do I activate it with my existing credentials please?

Share this post


Link to post
Share on other sites

Hello Colin,

 

To activate the product, open up the program and click on the 'activate' button on the bottom of the interface. You should be able to activate it with your ID and Key at that point. 

Share this post


Link to post
Share on other sites

It manifested with mbae-setup-1.09.1.1291 after an in-place upgrade of Windows 10.

Resolved the pop-up by uninstalling and reinstalling.

Share this post


Link to post
Share on other sites

today

me too after " sign out " "

MBAE service taking too long to start

win8.1 64bit

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.