Jump to content

Taskbar icon not responding

Recommended Posts


I am using MBAM Full ver. 1.46 on a Windows 7 64bits machine and I have noticed that the task bar icon becomes UN-responsive to the RIGHT click command (not showing the context menu) and also to the double left click NOT opening the GUI. I have noticed also, that this happens apparently after the automatic definitions update which i have set to run every 1 hour (now changed to every 5 hours jut to check if it is a determining factor)

Now, if I open the task manager, there it is the mbamgui.exe x32 apparently working, BUT the ONLY way to have access to the GUI without having to kill the mbamgui.exe x32 process (and restart it) or to RE-Start the PC, is by going to the Start Menu and from there select MBAM program in order to open the GUI which this time, opens fine.

Of course, after a PC re-boot it works fine for a while.

Maybe there is some corrupted file? ...maybe a bug?

I have not ried an Un-install/re-install process, because this is a fairly new installation, but I can do that if there is not any other option.

I am running avast Pro and have set in it, the pertinent MBAM folders on it

Link to post
Share on other sites

Hi Enrique -

You can Un/Re install the program if there are some problems (Keep your Key and ID to reinstall when finished) and you will need to reset schedules -

To Fully Remove and Reinstall a Fresh New Copy of Malwarebytes - Read Carefully

Windows Vista and Windows 7:

  • Click on the Start button and select Control Panel
  • Click on Programs and Features
  • Uninstall Malwarebytes' Anti-Malware
  • Restart your computer very important !
  • Download and run mbam-clean.exe from -->Here

It will ask to restart your computer, please allow it to do so, very important

After the computer restarts, temporarily disable your Anti-Virus and install the latest version of Malwarebytes' Anti-Malware from -->Here

Note: You will need to reactivate the program using the license you were sent via email if using the Paid version only

Launch the program and set the Protection and Registration. Then go to the UPDATE tab if not done during installation and check for updates.

Restart the computer again and verify that MBAM is in the task tray if using the Pro version. Now reset any file exclusions as may be required in your Anti-Virus/Internet-Security/Firewall applications and restart your Anti-Virus/Internet-Security applications.

You may use the guides posted in the FAQ's here or ask me and I'll explain how to do it.

Can you post back and list your Antivirus programs also -

Setting up The Scheduler - Just to make sure you have a copy -

Thank You - :welcome:

Link to post
Share on other sites

Thank you Noknojon,


Now I will have to wait :welcome:

BTW Now whenever I restart or turn on the PC, a small window appears saying something about MBAM running and protecting (or something like that) and I have to close it, I guess this is normal, but is there any way to stop it from appearing?


Enrique Diazruanova

Link to post
Share on other sites

Greetings :welcome:

Please do the following:

Create an Autoruns Log:

  • Please download Sysinternals Autoruns from here and save it to your desktop.
    • Note: If using Windows Vista or Windows 7 then you also need to do the following:
      1. Right-click on Autoruns.exe and select Properties
      2. Click on the Compatibility tab
      3. Under Privilege Level check the box next to Run this program as an administrator
      4. Click on Apply then click OK

    [*]Double-click Autoruns.exe to run it.

    [*]Once it starts, please press the Esc key on your keyboard.

    [*]Now that scanning is stopped, click on the Options button at the top of the program and select Verify Code Signatures so that it is now checked

    [*]Click on the Options button again and this time uncheck Hide Microsoft and Windows Entries

    [*]Once that's done press the F5 key on your keyboard, this will start the scan again, this time let it finish.

    [*]When it's finished and says Ready. on the lower left of the program window, please click on the File button at the top of the program and select Save and save the Autoruns.arn file to your desktop and close Autoruns.

    [*]Right click on the Autoruns.arn file on your desktop and hover your mouse over Send To and select Compressed (zipped) Folder

    [*]Attach the Autoruns.zip folder you just created to your next reply

Link to post
Share on other sites

Instructions sent :D

The problem with the window appearing at start-up is still there after I followed your latest instructions that came with your PM and that were essentially the same that noknojon wrote on the second post on this thread.

Now if the appearance of this window, does NOT interfere with MBAM good performance, I can live with it by just dismissing it, but certainly I am curious about what is happening :welcome:

Any more ideas?


Link to post
Share on other sites

The tool I gave you was different, and should have corrected the problem. It appears that for some reason mbamgui.exe is trying to execute twice instead of just once.

You haven't used StartupDelayer on it have you? That might have something to do with it.


You are correct Exile, StartupDelayer was the culprit!!! I modified the MBAM entrance in it and the window is not appearing

any more :welcome:

Thank You very much for your time and effort, it is now solved and the only thing that remains to be seen is the problem with the Icon, but I suspect, it is also related to StartUpDelayer

Greetings from Mexico!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.