Jump to content

MB 5 problems with tamper protection

Recommended Posts

I am running MB 5.  I have tamper protection turned on and all items selected.  When I open MB 5 to the Dashboard and click on Scanner I am not prompted for the password so that Scan, Scan Scheduler, and Reports are all accessible.


Also If I go to settings and enter my password and then close the GUI, when I reopen it, it shows the same tab in settings that I was in without prompting me for the password.

Edited by BillH99999
  • Like 2
Link to post
Share on other sites

  • BillH99999 changed the title to MB 5 problems with tamper protection
  • Root Admin

Thank you for the report @BillH99999

Have you restarted the computer since you installed MB5 ?

Can we please get some logs


To begin, please do the following so that we may take a closer look at your installation for troubleshooting:

NOTE: The tools and the information obtained are safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  • Download the Malwarebytes Support Tool
  • In your Downloads folder, open the mb-support-x.x.x.xxx.exe file
  • In the User Account Control pop-up window, click Yes to continue the installation
  • Run the MBST Support Tool
  • In the left navigation pane of the Malwarebytes Support Tool, click Advanced
  • In the Advanced Options, click Gather Logs. A status diagram displays the tool is Getting logs from your machine
  • A zip file named mbst-grab-results.zip will be saved to the Public desktop, please upload that file on your next reply

Thank you


Link to post
Share on other sites


Here are the logs you requested.


I had not restarted my computer since installing MB 5.  The install did not do a restart.

I restarted it just now as a test.  The symptoms are slightly different now.

When I start MB 5 I am still not prompted for a password when I click on Scanner.  I am able to use what's on the Scan tab without entering a password.  However, now when I click on Scan Scheduler and Reports I am prompted for a password.

When I go to settings I am prompted for my password.  If I close the GUI on one of the Settings tabs, when I reopen it, it no longer is showing the same tab in Settings that I was in.  Instead it opens to the Dashboard.  However, I am still able to go into Settings and Scan Scheduler and Reports without being prompted for the password.

Edited by AdvancedSetup
Corrected font issue
Link to post
Share on other sites

5 minutes ago, boombastik said:

If you unlock the mbam with password , it stays unlocked for 30 minutes. It is written in the tool tip.


Are you saying that was also the case in MB 4?  That isn't what I experienced in MB 4.  When I closed the GUI and reopened it, I was required to enter a password.  If it is a change in MB 4 it would be nice to be able to set the time limit as I would prefer a shorter time period.

As far as my issue, I am not being prompted for the password even after more than 30 minutes.


Edited by BillH99999
Link to post
Share on other sites

OK... after testing more today I have some observations.

When I start MB 5 I am still not prompted for a password when I click on Scanner and then go to the Scan tab. I am also not prompted for a password when I click on View Details in the Trusted Advisor area.  Neither of these is a huge problem as it would only allow a scan to be run or Auto Updates to be turned on (I currently have this ignored as I have it off on purpose).  I really feel that both of these should be protected by tamper protection anyway.

All other functions are protected by the password prompt except within 30 minutes of entering a password at the prompt.  I think you should always be prompted after the GUI is closed and reopened as it was in MB 4.  If I were using a laptop this would be especially important to me.  I don't like this change in MB 5.  If MB is going to allow a time frame where no password is required, then I think users should be able to set the time frame through a setting in tamper protection.


  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.