Jump to content

Is the MB Privacy VPN down for everyone?


Recommended Posts

All of my systems that use MB Privacy for VPN are unable to connect today.  Have tried various servers, restarting systems, etc.  This happened in early January at which time it was impossible to tell if it was just me or a larger system outage.  Would be great if there was a server status page...


So is this affecting others as well?  Anyone know how long the outage is expected?  (yes, I already opened a support ticket)


Link to post
2 minutes ago, borked said:

So is this affecting others as well?

No. mine is working.

Please do the following so that we may take a closer look at your system.



Then please restart the computer and then do the following.

WARNING: Do Not click the Repair option under Advanced unless requested by a Malwarebytes support agent or authorized helper

NOTE: The tools and the information obtained are safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  • Download the Malwarebytes Support Tool
  • In your Downloads folder, open the mb-support-x.x.x.xxx.exe file
  • In the User Account Control pop-up window, click Yes to continue the installation
  • Run the MBST Support Tool. The tool also downloads and runs a file called FRSTEnglish. Please allow it to run.
  • In the left navigation pane of the Malwarebytes Support Tool, click Advanced
  • In the Advanced Options, click Gather Logs. A status diagram displays the tool is Getting logs from your machine 



  • A zip file named mbst-grab-results.zip will be saved to the Desktop or on the hidden Public desktop (usually C:\Users\Public\Desktop), please upload that file on your next reply


Thank you

  • Like 2
Link to post
  • 1 month later...

Thanks for the reply but I was told via support ticket the problem was in Mullvad's network and there was nothing Malwarebytes support could do. The same problem is happen again today, same presentation.  I have given up complaining about it since Malwarebytes is not Mullvad.

Link to post

I was able to find a workaround for my occasional experience with days and days of endless connecting/reconnecting issues regardless what Mullvad's server status page says.  (For the record, Mullvad's server status page does not list "Malwarebytes Inc" as a "provider" in its rented space, so I assume that is an additional third party involved like Tzulo or HostRoyale).

On two android devices and two windows PCs, I verified the problem was still occurring (2 days now) by attempting vpn connection to three servers at random and watching the endless "connecting.... reconnecting..." behavior.  I went to Malwarebytes Privacy VPN settings, copied my license key to clipboard, deactivated the device, then exited the program.  I then uninstalled and reinstalled the app, entered my license key, and tried connecting to the first server (Los Angeles) it defaulted it.  In all four cases, it connected first try without any trouble.  It's been working without failure since.   Odd but ok - just glad to have a way to get it back up and running without just waiting for however many days?

Link to post
On 4/12/2024 at 5:31 PM, borked said:

In all four cases, it connected first try without any trouble.  It's been working without failure since.   Odd but ok - just glad to have a way to get it back up and running without just waiting for however many days?

If you posted the log I requested, I would have seen an issue and I would have had you do the clean reinstall back at the end of February.

At least it is fixed now.

Do you use Malwarebytes Premium as well along with the VPN?

Edited by Porthos
Link to post

Same problem just occurred.  All four devices using MB Privacy VPN stopped communicating, disconnecting leads to endless "connecting/reconnecting."  Once again, uninstall/reinstall resolved the issue on both platforms.  An android device I did not do the uninstall/reinstall on still can't connect.  While I appreciate Porthos's suggestion to move to Version 5, I am hesitant to do so without consulting support.  This certainly wasn't offered as a possible solution by them on the previous two tickets I opened for the same issue, so I was surprised when Porthos suggested it.

Link to post
25 minutes ago, borked said:

so I was surprised when Porthos suggested it.

It is an option. Not saying git will fix anything.

I personally turn on the VPN when "I" think it is needed.

I do too much Amazon Prime videos, Netflix, local Grocery store website and the list goes on that I can not access properly with it on.

  • Like 1
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.