Jump to content

Long Scan Time

Recommended Posts

Hello. I just downloaded malwarebytes and am doing the first scan on my MacBook Pro. I am a little concerned with the length of time the scan is taking. It's been scanning for 1 hours and 32 minutes, and it isn't even one-quarter of the way through. This means, this scan likely won't be finished for about 15 hours! Is this normal? On the site's Info page, it says how fast the program scans - just a couple of minutes. Why is mine taking 15 hours?

Link to post
Share on other sites

Yes, that's much too long from my experience. I suspect it must have gotten hung up early on in the process for some reason. The developer may ask you to run an analysis program to get additional factors. At this point I would suggest you force quit the app (Type <Command>-<Option/Alt>-<exc>, highlight MalwareBytes, click the "Force Quit" button and confirm). Then try a second scan to see if the problem cleared.

It would also help if you tell us the exact model of your MBP and version numbers for OS X/macOS and MalwareBytes.

Link to post
Share on other sites

I appreciate the reply, but this whole experience with this app has been a nightmare. The scan was still going on more than four hours later (The tracker showed it was moving - so I knew it was about a quarter of the way through - so it wasn't "hung up" as you say). So, I thought I'd just uninstall the whole thing. When I went to this site, it said I needed to run the malwarebytes.dmg file and click uninstall. But when I did that, another screen came up asking me to download yet another file in order to uninstall the original app. So after I downloaded that, it still didn't get rid of this God-awful malware program. Now I'm stuck with a whole bunch of malwarebyte files on my computer -both the original app and all the crap I downloaded to get rid of it. Horrible experience.

I'm on a Macbook Pro - Yosemite 10.10.5.

Any assistance you can offer in just getting all of this off of my computer would be greatly appreciated.

Edited by madison
Link to post
Share on other sites

I have no idea why you are having all these issues. It doesn't match my experience nor anybody else's that I've read in this Forum.

Since you said you just downloaded it, I'll have to assume you were running Malwarebytes for Mac version 3.0.3. If it was some other version then the removal instructions will probably be different.

The correct way to remove v3.0.3 would be to double-click the Malwarebytes- that you originally downloaded and then double-click the wire basket icon labeled "Remove Malwarebytes.pkg". There is no "uninstall" to click on, so I don't know what that was. That should bring up the Installer application with a window labeled Install "Malwarebytes for Mac Uninstaller". Click the "Continue" and then the "Install" buttons. It will ask you for your Admin password and then proceed with the uninstall that takes only a few seconds and does not download or ask you to download anything else.

It removes the following files:

  • /Applications/Malwarebytes.app
  • /Library/LaunchAgents/com.malwarebytes.mbam.frontend.agent.plist
  • /Library/LaunchDaemons/com.malwarebytes.mbam.rtprotection.daemon.plist
  • /Library/LaunchDaemons/com.malwarebytes.mbam.settings.daemon.plist
  • /Library/Extensions/com.malwarebytes.mbam.rtprotection.kext
  • /Library/Application Support/Malwarebytes/

Removing the .kext file can be tricky, so if it's still there and you can't move it to the trash, come back and I'll try to help with that.

Link to post
Share on other sites

  • Staff

I saw that you also submitted a ticket to customer support, and have responded to that with a request for more information.

I can't say what might be going on with the uninstall process without more information. You can find some instructions, including a screenshot, on how to uninstall here:


Link to post
Share on other sites

  • 2 weeks later...

I have the same issue. The scan seems to be stuck on the item OSx.Backdoor.Adwind

A quick google search tells me it requires some level of stupidity to install that particular one. Although it's dangerous to assume, I'm quite confident I don't have this on my system.

Scanned for about an hour when I just stopped. Tried restarting  to no avail.

Running 3.0.3 on High Sierra.

Link to post
Share on other sites

Am I completely blind to not see an edit button?

Anyways, I now tried first to reinstall Malwarebytes and reboot the machine. The new scan was then stuck, not on the Osx.backdoor.adwind, but rather on the very first item: Trojan.Steamstealer.csgo.

I didn't let it run for that long (3:30), but I've never seen one item take that long to scan previously.

I then tried to download directly from the website instead of through cask, with the same result.

Link to post
Share on other sites

On 26/10/2017 at 6:58 PM, treed said:

I'm glad to hear that! I suspect something may have been wrong with your previous installation, and it was the act of reinstalling that fixed it, not specifically upgrading to 3.1. But that's just a guess.


Yeah that's a possibility. I did reinstall the 3.0 first, but I may not have gotten all the config files removed.

Tbh I just wanted it to work, and didn't try to isolate the error.

Link to post
Share on other sites

  • 2 months later...

Since this doesn't appear to have anything to do with Long Scan Times, it would seem best to have started a new discussion on Uninstalling the app. 

I am unable to replicate your problem with Malwarebytes on macOS 10.13.2 so if those are the versions you are using, then choosing "Uninstall Malwarebytes" from the Help menu should have taken care of it for you. Are you logged in as an admin user?

You can try downloading the following script, which may remove the software for you if the removal software is still in tact.


If that fails, then you will probably either have to reinstall the current version of Malwarebytes for Mac or utilize a series of Terminal commands to remove it.

Edited by alvarnell
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.