Jump to content

Phxflyer

Members
  • Content Count

    74
  • Joined

  • Last visited

Posts posted by Phxflyer

  1. I've discontinued my auto pay for MB Premium from Cleverbridge and purchased a new Product Key for 3 PC's from N--E--. My subscription expires in May but in preparation for that event I have a question. What's the best way to enter the new key? I've seen in the main MB interface, under settings, you have account. There it gives you the option to deactivate or change your product key. Do you just need to "change" the key and deactivate your old key or just change the key or deactivate first then change the key? I also see you can go to "my account" and register a new key. Seems like lots of ways to do it, but what is the correct way to do it? Thanks for any help.

  2. I know this has been covered before but I just wanted to recheck. I've been using Norton Internet Security for many years but as it was coming up for renewal I decided to remove it and just use MB premium and Window Defender. The uninstall went fine. All check boxes for Windows security are green. What I wanted to check was again, does MB need to be registered in Windows security and if so, how do you do that? Do any other settings in MB need to be changed? Right now everything looks good. Windows Defender is up to date and so is MB. Thanks for any input on this.

  3. I just saw this YouTube review of MB. What are they doing wrong or looking at incorrectly? Or are they right? I know MB gets panned as an antivirus but this is panning MB in it's ability to prevent malware. I'm very skeptical of what they are coming up with and how they doing this test by throwing out dozens of malware loaded links and programs at one time. This doesn't seem realistic????

    https://www.youtube.com/watch?v=9clWAlxZloI

     

  4. Everything seems to be working fine with the new version. I'm running v4.0.4.49, update package 1.0.14838, component package 1.0.718. But I do see a glitch (i think) on the home screen. I have a scheduled quick scan to run daily at 955pm. It does run every day at that time, but the screen shows, scheduled run TOMORROW at 955pm in lieu of saying TODAY at 955pm. Again, it d oes run as scheduled, it's just the picture. This occurs everyday (saying tomorrow) in the morning when I look at it. Screen shot and logs attached. 

    MB.JPG

    mbst-grab-results.zip

  5. Will do. I couldn't this last time as I couldn't open a browser page to get the support tool. I didn't think about getting it from another PC first. Too much going on to think about it. Now I have it and will definitely use it if I get this on the next update. All is running fine after the second install.

  6. Maybe I did something wrong, but I clicked on the link Erix gave today (from this link) and installed 4.0.3 over 4.0.2. Maybe that was the problem. The install went quick and everything looked okay in the interface, but I couldn't open any web browser; Edge, Chrome or Firefox. I tried turning MB off but that didn't help. I also rebooted. No help. I used the Windows uninstall applet to remove MB Beta 4.0.2 and then reinstalled it to 4.0.3.48. This went quick and now the browsers are working but in this install, my scheduled scans were deleted. I only run two. A nightly quick scan and a weekly threat scan. Both are reset and I did a quick scan and it worked okay.

    If my problem was trying to install the new without removing the old, then it's my fault. If that should have worked, we can go from there submitting logs, etc.

    Thanks in advance.

  7. At the top of the MB 3 forum, it said to try the MB 4 beta. Well, I did and found the following:

    Easily installed over MB 3.8.3.

    Kept all my setting and scan schedules intact including all my account data.

    In the last 2 days, it has run 2 scheduled quick scans and 1 weekly Threat scan quickly and worked fine.

    I've used it with Chrome and Edge (dev) with no problems. No false positives. (No positives but I guess I didn't visit any bad sites since install.)

    So, all in all, I'm pretty happy with its performance and with how things are now displayed. Of course the interface is very different but like with anything else that's new, I'm sure in a few weeks it will be usable without even thinking about it. Only time will tell if what's under the hood is working better and at this time I can only assume its doing fine. 

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.