Jump to content

Malicious Website Protection blocking browser


Recommended Posts

Ever since I got Xfinity internet installed, the Malicious Protection Module has been blocking/slowing down both browsers (Chrome & IE11) The only way I can browse is by disabling the Malicious Website Protection. This only affects the wired connection. If I use the desktop wirelessly, everything is fine. Any suggestions would be greatly appreciated. So far I've used Combofix, MBAM and a few other utilities, but the find nothing. This only happens on my desktop PC. When I plug any laptop into the modem/router, everything works fine...

Link to post
Share on other sites

Hello and :welcome: :

 

Hmm - that's the *opposite* of the typical problem we see (wifi connection blocked on systems with certain wireless cards).

 

Let's start here:

  • Please follow the steps in this pinned topic to uninstall your current version of MBAM and reinstall the latest build - MBAM Clean Removal Process 2x
  • If that does not correct the issue, then please read the following and attach to your next reply the 3 requested logs - Diagnostic Logs (the 3 logs are: FRST.txt, Addition.txt and CheckResults.txt)
  • NOTE: There is an FAQ section with valuable information located here - Common Questions, Issues, and their Solutions

Please let us know how it goes.

Thanks,

Link to post
Share on other sites

First off, its not advisable to run tools such as combofix without expert advice, these tools are dangerous if used in the wrong hands or by folks that are not familiar with the tools.

That being said, I see you have a Killer Network Card that could be the issue here...

This is a simple fix and has worked for folks with the Killer e2200:

For Windows 7:

  • Navigate to Start --> Control Panel
  • Click Network and Internet then Network and Sharing Center
  • Click Change Adaptor Settings
  • Right-click the Killer wireless connection and select Properties
  • Under the Networking Tab, uncheck Qualcomm Atheros Bandwidth Control
  • Click OK
  • Reboot
This resolved the conflict for most.
Link to post
Share on other sites

Hi:

 

EDIT: Dang! Great minds think alike!  Firefox, you beat me to the punch! :D

 

Until someone else comes along to peek at your logs....

You do seem to have the relevant wireless card.

 

Go into Killer Network Manager and disable the setting for "Enable Bandwidth Control".

That might fix your issue.

 

Please let us know.

 

Thanks,

post-29793-0-59397500-1419456260_thumb.j

Link to post
Share on other sites

You guys are awesome! Thank you very, very much. I knew this had to be caused by the network adapter, just didn't know how to set it. Thanks again. I've been scratching my head for the last week. Should've consulted you fellas before doing a reformat, which obviously didn't fix the issue. Merry Christmas guys and thanx again!

Link to post
Share on other sites

 

Should've consulted you fellas before doing a reformat,

 

OUCH!

A nuke and pave would not be my way of spending a fun holiday! :D

 

There must be something peculiar about THAT wireless card/KNM and MBAM 2.x.

There have only been a handful of reports, but it is an easy fix, once we identify the hardware/software install on the affected system.

 

Cheers,

Link to post
Share on other sites

 

Qualcomm Atheros Bandwidth Control Filter Driver (Version: 1.1.42.1045 - Qualcomm Atheros) Hidden

Qualcomm Atheros Killer E220x Drivers (Version: 1.1.42.1045 - Qualcomm Atheros) Hidden

Qualcomm Atheros Killer Network Manager Suite (HKLM-x32\...\{E70DB50B-10B4-46BC-9DE2-AB8B49E061EE}) (Version: 1.1.42.1045 - Qualcomm Atheros)

Qualcomm Atheros Network Manager (Version: 1.1.42.1045 - Qualcomm Atheros) Hidden

 

This was the key to the mystery, at least for me. :)

I guess it's not wifi, per se, but rather the make/model of the card and that darn KNM suite. :)

 

Ennywho, it's a rarely reported issue, to be sure.

But we've seen it enough times to look for the offending software, when we see a similar issue.

 

Anyway, we're glad we could help. :)

 

Cheers,

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.