Jump to content

Another scan won't complete with v.

Recommended Posts

Also a user of the free Malwarebytes for several years. Upgraded my 2.01.1004 to the new, updated, and tried a custom scan with Rootkits checked, on my "C" drive alone, plus my temp files and browser cache ("D" drive folders only). It stops at 75,119 files, on the same windows.log file, with or without Rootkits selected. Progress bar sits and moves, elapsed time increases, no further action (about 8 minutes in). Tried to turn off the scan, Malwarebytes continued to run in the tray, would not exit, and had to stop the service to shut it off. Also did a full uninstall/reboot/reinstall and the same thing happened with the clean install.


My system is a home built, Win 7 Ultimate 64-bit, Intel mobo, Intel I-5, Intel SSD, and 16Gb of Crucial DDR3 10600. Never had a hang up with either of the previous 2.0.1's, nor with 1.75 or earlier versions going back 3 years.


I prefer using custom scans, as I sometimes help friends and relatives with their computer problems, and Malwarebytes is very good at cleaning up an infected or unbootable drive from their computers, slaved to my machine via outboard usb caddy.

Link to post
Share on other sites

Hello and :welcome::


Have you tried disabling rootkit and archive scanning to see if that resolves the issue?

The new MBAM 2.0 works differently from the older version, and scans may take longer (that is normal).

Hanging or freezing could have many possible causes (file corruption, malware, software conflict, file size (especially large archives), etc).


Basic troubleshooting starts here, please - I see that you reinstalled once already, but it's not clear if you followed the recommended method with the removal tool:

If you have already cleanly upgraded to/reinstalled, then please start with step #2, the logs.


Also, MBAM is designed to be installed and run from the OS boot drive (typically C:).  Using it as you described to clean other computers is not supported and may be a violation of the EULA.  There are other tools built-in to MBAM now (such as Chameleon) to help get it installed and running on heavily infected computers.


Thank You,

Link to post
Share on other sites

Yes I did try it with Rootkit turned off - still hung up.

Yes I did a full uninstall and a clean install, and tried again with and without Rootkit checked. Results were the same - progress stops.

No large files on "C" - just Windows and my programs. Even pagefile.sys is on a second drive.

Used to the Custom Scan running slower, going back several versions. Never seen it just quit progressing.

Read the FAQ's - found nothing similar to help. I always reboot after any uninstall. Today was the first time I ever installed Malwarebytes over an old version, as far as I remember.


Violation of the EULA? Sorry, but if a friend from church or a relative brings me a machine that just won't boot because it's infected, I've found Malwarebytes is the only program that can find junk on a Windows install that is not "running". When I get it cleaned up enough to boot, then I install Malwarebytes for them and finish it up.


I'm aware of Chameleon - works well to keep the program running on an infected machine, re: a friend's drive which is partially cleaned, out of their chassis, then a clean install and full scan once I get it running again.


Currently using MS Security Essentials on this machine, never had a conflict with it and Malwarebytes, any version.


I'll do the log check.

Link to post
Share on other sites

Update: It seems that it finally passed that log file after little over an hour.


Kind of a silly amount of time for a single log file, but I guess it didn't really freeze after all. It just literally took that long?


pasound, maybe you can try letting the scan run for awhile and see if it finally passes that log file? (Up to an hour or more.)

Link to post
Share on other sites



OK, thanks for the updated information.

Please post back with the diagnostic logs (as attachments, if possible) when you are ready.



Sorry to hear you are having issues, too.
Each computer is unique.
Problems that sound "the same" most often are not.
The same is true for solutions.
They most often need to be individualized.

It is less confusing for everyone if we try to stick to "one user per topic".

If you could please stay with your own topic >>HERE<<, the staff and experts will be able to more easily provide both you and the OP with individual help to get you both up and running.

Thanks for your patience and understanding,


Link to post
Share on other sites

ATM, am running the earlier version, 2.01.1004, doing the same sort of scan plus rootkits. It's hung up again, except at a different point, 72226 files, which on is *.* \Media Player\CurrentDatabase372.wmdb. Just need to see what's going on. Last scan I did with was three weeks ago, and didn't have a problem then.


Beginning to wonder if there is a problem with the latest set of Windows Updates. Not impossible. My WinRAR associations were changed after I did those last week. MS had no comment on that...


Running on an SSD, this sort of behavior is a lot of wear and tear on the drive - 40 minutes so far, 36 minutes hung up. Waiting, as Gob said it finally cleared on his.


(Posting from my W8 rig, so as to not disturb the scan.)

Link to post
Share on other sites

It's entirely up to you, but the earlier build had quite a few bugs that were fixed in the latest version, including scan times.

That's why it is suggested to clean upgrade to -- doing so has improved scan times for many users.


The steps to do so are here: MBAM Clean Removal Process 2x.

That, and the earlier suggestion to disable archive scanning are the current suggestions at this time.


Otherwise, the staff/experts will need some data about the system, in the form of the Diagnostic Logs.


Thank you,

Link to post
Share on other sites

I understand. I'm giving this scan another 10 minutes, then it's uninstall, clean up, reboot, install the new version and try again. Then I'll run new logs. I looked at the original logs, and they didn't show any obvious errors. I'm used to reading error logs.


Please note, I'm a tech for a museum. I admin 50+ Windows 8.1, and 8.1 RT Surface rigs, plus another four dozen W7 rigs and a few XP Embedded (Legacy) that I can't get rid of because the apps they run will never be updated. I have two W7 Ultimate desktops at home, plus one Windows 8.1 desktop, one WHS 2011, one Ubuntu, and one Surface 8.1 RT. I know my way around troubleshooting - just never had a problem with one of my favorite fixit apps, ever before...

Link to post
Share on other sites

It finished scanning. Four reboots, three full clean installs later. I'm thinking it's windows problems - at least it feels like that. Will try one scan tomorrow with only the rootkit scan enabled, just to see how it works.


Moderators - consider this solved, until further questions.


Thanks to everyone.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.