Jump to content

Error Updating


Recommended Posts

I receive the following error message when I try to update my Malwarebytes anti-malware (free version):

MBAM_ERROR-UPDATING (12007,0,WinHttpSendRequest)

Help.

I'm getting the same error message -- so I uninstalled mbam -- used mbam-clean -- reinstalled mbam and I'm now getting the

error message -- mbam_error_load_database(0,5) -- I also tried downloading 1.50.beta but it said that the downloaded copy was

corrupt. I've googled the problem and tried other things but still no good -- can somebody help me please as I have been having

these update problems for about 6 months now (1.46 version 4052) I've got no viruses or malware as far as I know it's just this

updating problem. Last year I had no problems at all with updating etc and now nothing but.

Link to post
Share on other sites

Hello,

Ive been going through these forums for a long time, helped me a lot. Malware Bytes Anti-Malware has also, but i face the same problem as mcroce.

MBAM_ERROR-UPDATING (12007,0,WinHttpSendRequest)

This problem is driving me crazy. I have uninstalled and reinstalled, I'm open to other suggestions if anyone has found a fix so i may update the program.

Thanks,

Chris

Link to post
Share on other sites

Hello radiosnowcode: :)

I would suggest you to start your own new topic, so that you may not get lost in shuffle. Please provide following details, someone will help you:

  1. OS version including 32/64-bit
  2. Installed Security Product(s) including Firewall
  3. MBAM version (current 1.46)
  4. Definition version (current 5164)
  5. Do you use a router to connect to Internet

Please post back using PogTD.png button

Link to post
Share on other sites

Hi -

Depending on your system and Antivirus/firewalls , here are some steps to diagnose update issues: This is for free or paid versions -

Step 1

Please note that if you have a version of Malwarebytes' Anti-Malware
older than 1.46
, that it will not be able to connect to our update servers. If you have an outdated version of Malwarebytes' Anti-Malware, then please click on
to be forwarded to one of our download mirrors in order to get the latest version of Malwarebytes' Anti-Malware. If that does not resolve the issue, then please continue on to steps 2 thru 4.

Step 2

Click on
and let me know what it says. It should be just a 4-digit number in the upper-left corner.(
about 5165
)

Step 3

Only if you use
Norton Internet Security
, and you have the
Add-On Pack
installed, then please note that the Add-On Pack will block the Malwarebytes' Anti-Malware update process. Symantec has discontinued support for the Add-On Pack, and they have asked us to recommend to their customers that they uninstall the Add-On Pack and replace it with
. Since Norton Online Family is compatible with the Malwarebytes' Anti-Malware update process, replacing the Add-On Pack with it will solve any Norton Internet Security related update issues.

Step 4

Please download and run the traceroute utility at
. It will run a traceroute to our update servers to see if it can find the connection issue, and then it will write it to a log, and open that log in Notepad when it is done. Please either save the log as a Text File and then attach it to a reply, or copy and paste it into a reply, and I will forward it on to our server guy.

Note that it may take several minutes to run, and it may look like it is not doing anything for a few minutes. Normally it takes longer when there are errors that it has to log, but it's rare for it to go more than 5 minutes.

We await your responses , along with your operating systen (XP Vista Win7) A/virus and Firewall programs

Thank You - :)

Link to post
Share on other sites

@ kingpin only -

Almost every MBAM_ERROR_LOAD_DATABASE error is corrected by deleting the current rules.ref file and having MBAM download a new copy. In cases where the problem keeps happening repeatedly on a particular system it's usually due to dropped connections and/or packets (often with the slower connection types such as satellite and dialup) or because of antivirus/firewall software interfering. Select your O/System from below and try this fix -

Show Hidden Files and Folders in Windows XP:

  • Click Start and select My Computer
  • Click the Tools item from the menu at the top of the window (if you don't see Tools press the Alt key on your keyboard and it will appear)
  • Select Folder Options
  • Click the View tab and make sure Show hidden files and folders is selected under Hidden files and folders
  • Next, uncheck the box next to Hide protected operating system files (Recommended)
  • Then, uncheck the box next to Hide extensions for known filetypes
  • Click Apply then click OK

Then go to C:\Documents and Settings\All Users\Application Data\Malwarebytes\Malwarebytes' Anti-Malware and delete rules.ref. Once you've done that, start MBAM and when it shows the error and asks to update, let it do so and see if that corrects it.

Reset Hidden Files and Folders in Windows XP:

  • Click Start and select My Computer
  • Click the Tools item from the menu at the top of the window (if you don't see Tools press the Alt key on your keyboard and it will appear)
  • Select Folder Options
  • Click the View tab and make sure Do not show hidden files and folders is selected under Hidden files and folders
  • Next, check the box next to Hide protected operating system files (Recommended)
  • Then, check the box next to Hide extensions for known filetypes
  • Click Apply then click OK

Show Hidden Files and Folders in Windows Vista and Windows 7:

  • Click on the Start vista-7-start.png button and select Computer
  • Press the Alt key on your keyboard and click on Tools
  • Select Folder Options
  • Click the View tab and make sure that Show hidden files and folders is selected under Hidden files and folders
  • Next, uncheck the box next to Hide protected operating system files (Recommended)
  • Then, uncheck the box next to Hide extensions for known filetypes
  • Click Apply then click OK

Then go to C:\ProgramData\Malwarebytes\Malwarebytes' Anti-Malware and delete rules.ref. Once you've done that, start MBAM and when it shows the error and asks to update, let it do so and see if that corrects it.

Reset Hidden Files and Folders in Windows Vista and Windows 7:

  • Click on the Start vista-7-start.png button and select Computer
  • Press the Alt key on your keyboard and click on Tools
  • Select Folder Options
  • Click the View tab and make sure that Do not show hidden files and folders is selected under Hidden files and folders
  • Next, check the box next to Hide protected operating system files (Recommended)
  • Then, check the box next to Hide extensions for known filetypes
  • Click Apply then click OK

Link to post
Share on other sites

@ kingpin -

Almost every MBAM_ERROR_LOAD_DATABASE error is corrected by deleting the current rules.ref file and having MBAM download a new copy. In cases where the problem keeps happening repeatedly on a particular system it's usually due to dropped connections and/or packets (often with the slower connection types such as satellite and dialup) or because of antivirus/firewall software interfering. Select your O/System from below and try this fix -

Show Hidden Files and Folders in Windows XP:

  • Click Start and select My Computer
  • Click the Tools item from the menu at the top of the window (if you don't see Tools press the Alt key on your keyboard and it will appear)
  • Select Folder Options
  • Click the View tab and make sure Show hidden files and folders is selected under Hidden files and folders
  • Next, uncheck the box next to Hide protected operating system files (Recommended)
  • Then, uncheck the box next to Hide extensions for known filetypes
  • Click Apply then click OK

Then go to C:\Documents and Settings\All Users\Application Data\Malwarebytes\Malwarebytes' Anti-Malware and delete rules.ref. Once you've done that, start MBAM and when it shows the error and asks to update, let it do so and see if that corrects it.

Reset Hidden Files and Folders in Windows XP:

  • Click Start and select My Computer
  • Click the Tools item from the menu at the top of the window (if you don't see Tools press the Alt key on your keyboard and it will appear)
  • Select Folder Options
  • Click the View tab and make sure Do not show hidden files and folders is selected under Hidden files and folders
  • Next, check the box next to Hide protected operating system files (Recommended)
  • Then, check the box next to Hide extensions for known filetypes
  • Click Apply then click OK

Show Hidden Files and Folders in Windows Vista and Windows 7:

  • Click on the Start vista-7-start.png button and select Computer
  • Press the Alt key on your keyboard and click on Tools
  • Select Folder Options
  • Click the View tab and make sure that Show hidden files and folders is selected under Hidden files and folders
  • Next, uncheck the box next to Hide protected operating system files (Recommended)
  • Then, uncheck the box next to Hide extensions for known filetypes
  • Click Apply then click OK

Then go to C:\ProgramData\Malwarebytes\Malwarebytes' Anti-Malware and delete rules.ref. Once you've done that, start MBAM and when it shows the error and asks to update, let it do so and see if that corrects it.

Reset Hidden Files and Folders in Windows Vista and Windows 7:

  • Click on the Start vista-7-start.png button and select Computer
  • Press the Alt key on your keyboard and click on Tools
  • Select Folder Options
  • Click the View tab and make sure that Do not show hidden files and folders is selected under Hidden files and folders
  • Next, check the box next to Hide protected operating system files (Recommended)
  • Then, check the box next to Hide extensions for known filetypes
  • Click Apply then click OK

Hi "N" thanks for your quick reply. My operating system is in my signature (32bit)

I forgot to mention that I am on dialup but this hasn't been a problem in the past --

ok here is what you wanted -- i deleted ref.rules and doubleclicked the mbam icon

but no good -- it asked if I wanted a new copy downloaded (1,46) so I said yes.

will let you know how I get on after my new copy has been downloaded. Once again

thanks for your help and your clear concise instructions

mbam_fix_noknojon.txt

traceroute_malwarebytes_cdn.txt

Link to post
Share on other sites

My results - Name: edge.data-cdn.mbamupdates.com

Address: 68.232.45.133

Your results -Name: gs1.wpc.edgecastcdn.net

Address: 68.232.45.133 Aliases: edge.data-cdn.mbamupdates.com

You are able to access the download site OK , but you still show update 1.46 version 4052 -

Also note that both items you sent were the same item - The tracert item -

Please try the ERROR _LOAD_DATABASE item listed above for XP - This will only take a few mins like the last item -

Disable your Nod32 , PC Tools firewall and Spyware Blaster as this is a checked and safe site -

Do you have Dial up internet ?? It seems that you are in Kiwiland and having trouble getting out ??

Also please use the ADD REPLY Tab at the bottom of the screen so you do not quote all of the last post -

Thank You for your quick reply - :)

EDIT -

You also have the option of installing our new Beta V1.50 if you like -

Link to post
Share on other sites

My results - Name: edge.data-cdn.mbamupdates.com

Address: 68.232.45.133

Your results -Name: gs1.wpc.edgecastcdn.net

Address: 68.232.45.133 Aliases: edge.data-cdn.mbamupdates.com

You are able to access the download site OK , but you still show update 1.46 version 4052 -

Also note that both items you sent were the same item - The tracert item -

Please try the ERROR _LOAD_DATABASE item listed above for XP - This will only take a few mins like the last item -

Disable your Nod32 , PC Tools firewall and Spyware Blaster as this is a checked and safe site -

Do you have Dial up internet ?? It seems that you are in Kiwiland and having trouble getting out ??

Also please use the ADD REPLY Tab at the bottom of the screen so you do not quote all of the last post -

Thank You for your quick reply - -_-

EDIT -

You also have the option of installing our new Beta V1.50 if you like -

Hi N

Sorry for the delay in answering had to go away for a few days for family reasons -- anyway Yes me in Kiwiland and using dialup

I deleted the rules.ref icon then double clicked on the desktop icon but it came up with an error so I uninstalled it asper yr instructions.

I will try the "ERROR _LOAD_DATABAS" and see what happens -- if that dont work will try and download the 1.50 beta version

Once again thanks for your help

Link to post
Share on other sites

I'm still having troubles updating mbam -- I uninstalled version 1.46 ran

mbam-clean then downloaded version 1.50 (free) -- then updated or

attempted to -- it came up with the same error at the start of this thread --

I deleted the rules.ref file and ran updates again -- this time I get this error

(see attached file). I'm at my wits end as I have been having probs since

April of this year with version 1.46 -- before this no probs at all.

post-59858-1291183067_thumb.jpg

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.