Jump to content

V2.2.1.1043 database update problem

Recommended Posts


Updated to the latest version V2.2.1.1043 but now I cannot update the database from v2016.02.16.06 and the error is "unable to access update server."

Is there a know cause for this?


Link to post
Share on other sites


There are several possible reasons for updating problems.

If rebooting the computer does not resolve the problem, then I suggest starting here, as it often resolves many minor issues:

Please carefully follow all the steps in this pinned topic to uninstall your current version of MBAM and reinstall the latest build - MBAM Clean Removal Process 2x

Please let us know how it goes.


Link to post
Share on other sites

Hello daledoc1,

Many thanks for your suggestion although I had done that without any luck, but since discovered what's stopping it from updating; but not why, especially when nothing has changed. Transpires it's Kaspersky that was blocking it internet access even though all settings are set to allow. I have reset Kaspersky and will wait wait and see when Malwarebytes auto updates next as it still fails unless Kaspersky is disabled. I suspect an update has caused the problem and will report my findings to them.

Thanks again,


Link to post
Share on other sites


Thanks for the update.

I run KIS 2016 on my main desktop PC with MBAM Premium and have seen no such updating problems with MBAM. 
But, of course, each computer is unique (and I'm not sure if you are running KAV, KIS or KTS, or the version; nor do we know your Windows OS version).

Although it's not strictly necessary to do so, you may wish to set mutual exclusions between MBAM and Kaspersky. 
Since we don't know  your Windows OS version or exactly what Kaspersky product or version you have, I can only provide "generic" instructions for the trust settings.
The attached screenshot shows how to add the KL folder to MBAM exclusions.
The MBAM files listed below are the ones to "exclude" in Kaspersky.

Please feel free to post back, if you need more help.



Please exclude the following files from your Antivirus Software for your version of Windows:

For 32-bit versions of Windows XP, Windows Vista, Windows 7 & Windows 8 & Windows 10:

  • C:\Program Files\Malwarebytes Anti-Malware\mbam.exe
  • C:\Program Files\Malwarebytes Anti-Malware\mbamdor.exe
  • C:\Program Files\Malwarebytes Anti-Malware\mbampt.exe
  • C:\Program Files\Malwarebytes Anti-Malware\mbamservice.exe
  • C:\Program Files\Malwarebytes Anti-Malware\mbamresearch.exe
  • C:\Program Files\Malwarebytes Anti-Malware\mbamscheduler.exe

For 64-bit versions of Windows Vista, Windows 7 & Windows 8 & Windows 10:

  • C:\Program Files (x86)\Malwarebytes Anti-Malware\mbam.exe
  • C:\Program Files (x86)\Malwarebytes Anti-Malware\mbamdor.exe
  • C:\Program Files (x86)\Malwarebytes Anti-Malware\mbampt.exe
  • C:\Program Files (x86)\Malwarebytes Anti-Malware\mbamresearch.exe
  • C:\Program Files (x86)\Malwarebytes Anti-Malware\mbamservice.exe
  • C:\Program Files (x86)\Malwarebytes Anti-Malware \mbamscheduler.exe

Note: If you are using a software firewall besides the built in Windows Firewall, you'll need to exclude MBAM.EXE, MBAMSERVICE.EXE and MBAMRESEARCH.EXE from it, as well.
Note: Once that's done, please make sure that if either of those programs has any sort of web filter, that you add the following as a trusted site:



Link to post
Share on other sites

I also had this problem over the last few days.

Turns out it was the SSL scanning function of KIS. I had to turn it off (and leave it off). It's under Settings->Additional->Network.

I guess the issue is Malwarebytes is verifying the SSL certificate of the update server, but since KIS is effectively running a proxy (and signing using its own cert) Malwarebytes is rejecting the connection.

Link to post
Share on other sites

Hello Daledoc1,

I had inadvertently selected "always scan encrypted connections" rather than "Scan Encrypted connection upon request from protection components" and that resolved the problem. All working as expected with no issues.

Thanks for your assistance, much appreciated.




Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.