Jump to content

unsufficient privileges to install windows defender -please help


macbryde

Recommended Posts

Hi,

I am having difficulties with installing Windows defender to my laptop.

I have downloaded the file "WindowsDefender.msi" and after running

I get this windows message Windows defender installlation information with a yellow exclamation mark:

The installer has insufficient privileges to modify this file C:\program files\windows Defender\MsMpEng.exe.

I have to cancel and the installation rolls back.

Can you please help me i have tried many things I I cannot get it installed......

Link to post
Share on other sites

Hi, did you look into the file which it lists ? How about this part : Defender\MsMpEng.exe ?

If you Google it as I have, you will find some different avenues to look into.

Here is a listing from Google I received : http://www.google.com/search?q=Defender\MsMpEng.exe&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

Granted it is a lot to go thru, but the answer you seek might be in it. I'm not trying to give you a hard time or tell you what to do, this is just my opinion and the path I personally would take.

Link to post
Share on other sites

Hi, I see you are using Sophos as your security system. Why do you want to install Defender also ? If you just want to replace your security system, there are more modern choices available, a lot of them are free also. Do you realize you can not run two anti-virus programs on the same machine ?

What is the operating system you are using ?

In this case, if you really want to try to install Defender, you will have to at least disable Sopho and see if you can install Defender in this manner. I would go thru the process listed below in the M$ solution to remove all traces of Defender first, then download a fresh copy and leave it on the Desktop.

Then, before you do anything else, take the machine off the internet altogether, even if you have to pull the Ethernet cable or shut off the router.

Disable Sopho, install Defender, go back on line so Defender can update itself. This should work.

This is a M$ Troubleshooting possibility, here: http://support.microsoft.com/kb/555957

I think at this point you should download, update, and run SuperAntiSpyware free. I will give you peace of mind about anything hiding in your machine, its a possibility. If it does not find anything, it still is a good program to have on hand.

You can find it here: http://www.superantispyware.com/

Remember to click on the free download.

Link to post
Share on other sites

I have no virus or malware. I ran malwarebytes and I have an updated virusprogram "sophos".

this must be something else.... I also googled as suggested but could not come any further.

happy for any suggestion

As you've stated you are using Sophos this seems to be a company pc. You'll need to contact your IT team.

Link to post
Share on other sites

Yes Sophos is a corporate solution. The high school I went to had it installed. It is not a home solution.

Thank's for the reply. I was wondering why I have never heard of it before.

It will be interesting to hear back further about this machine. I'm thinking now, maybe this was a "acquired machine", hence the difficulties.

Link to post
Share on other sites

Thank's for the reply. I was wondering why I have never heard of it before.

It will be interesting to hear back further about this machine. I'm thinking now, maybe this was a "acquired machine", hence the difficulties.

You're welcome. :) They have a Facebook page, blog and a news letter(email). :)

Yes it will. :) Very possible. :)

Link to post
Share on other sites

"acquired (ex)corporate machines"

yessir , i have seen problems along those lines .

i knew the machines were legit (receipts , etc) , but how they made it "out the doors" without being wiped/cleaned out was never known .

with a couple of them there was no response from the AV/M companies as to a removal tool so the only option was to wipe the drive entirely ... and load a new OS .

Link to post
Share on other sites

  • 2 weeks later...

The discussion is going in the wrong direction. First of all :

1.the laptop is not infected. I have no viruses or malware. I checked the laptop with Kaspersky and with Superantispyware.

2. I have acquired my laptop in a store. I did not very much appreciate the remark BWD.

3. TYhe google suggestion followed by the Microsoft support did not solve my problem.

4. it is not only related to windows defender, today I tried to install I-tunes and I got the same message.

5 it seems as if any installation is rejected that uses windows installer although I am logged on as administrator.

6. I downloaded from Microsoft a program to fix "problems installing and uninstalling programs on Windows-based computers" from here:

http://support.microsoft.com/kb/2438651/ but it did not solve the porblem.

Error message says:

I-tunes: There is a problem with Windows installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor.

After selecting OK the install rolls back completely.

Happy to get some useful input and/or suggestions to solve this

Link to post
Share on other sites

"2. I have acquired my laptop in a store. I did not very much appreciate the remark BWD."

i'll take it you were referencing my comments ... could you explain your objections to my post ?

this is my frame of reference :

when it comes to enterprise and/or corporate "solutions" for AV and "security" programs , things are/can be a bit different than for "home use" solutions .

in your case , you bought the laptop (it is your privately owned machine) and installed an AV solution provided by your school (they provided/required it for sundry reasons that are not relevant to this thread) .

in some cases the AV/security package has "locked down" the machine ... the user is not allowed to install certain programs as it goes against what the corporate/company/entity IT policy deems "safe and acceptable" .

in some cases the "user" of a corporate machine is not allowed to anything but (basically) run the already installed programs ...

it takes the password of the system IT admin to "unlock" the machine in order to install some types of programs .

in the name of "self protection" the user cannot even uninstall the AV/security program .

much of the above is determined by the AV/security program used and it's options and the decisions made by those in charge of the "corporate/licensing entity(ies)" in charge of such matters .

plus "weird things happen" ... it is a part of life .

as an example pertaining to one of the machines i mentioned in my prior post :

there was no way to reset any passwords (the admin account i had access to was limited)

there was no way to be able to download and install any programs

one could not unlock the hidden files

etc ...

in essence the machine was locked down very tight .

what i did know was where the machine came from (receipts) .

i contacted the place (a college) and explained the situation , i was referred to their IT department .

after some serial number tracking and such (proving that the machine had indeed been cycled out of service and was sold) , i was given the password to the "god account" on the machine and pointed toward the uninstaller for the AV/security program .

i am not saying that this is the exact same case as your machine ... but it may be a possible solution to keep in mind/pursue .

Link to post
Share on other sites

  • 2 weeks later...

Anyone in this forum to advise me how to,solve this problem. I have admin rights to my "own" laptop whcih I bought 5 years ago.

In the last 5 years that i have used it I have installed many programs

Why can't I install programs like windows-defender or i-tunes. Whereas for example at the same time I can install a number of other programs without any problem.

Link to post
Share on other sites

You can try this, but no guarantees that it will resolve the issue:

Note: Only attempt this if you are running an English installation of Windows XP as this tool has NOT been tested on Windows Vista or Windows 7 or on non-English installations of Windows:

Reset Default Permissions:

  • Please download ResetDefaultPerms by AdvancedSetup from here and save it to your desktop
  • Close any open programs and save anything you were working on
  • Double click on restoredefaultperms.exe to run it
  • Once it completes it will restart your computer

Link to post
Share on other sites

  • 2 weeks later...

At the end I have solved it.

I used subinacl (http://www.ponx.org/download/CD/Outils-Win/subinacl.htm)

I created a file called "reset.cmd" in C:\Program Files\Windows Resource Kits\Tools

You run this from the cmd prompt

change username into the excisting windows user and run.

*****************

subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f /grant=restricted=r /grant=username=f /setowner=administrators > %temp%\subinacl_output.txt

subinacl /keyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f /grant=restricted=r /grant=username=f /setowner=administrators >> %temp%\subinacl_output.txt

subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f /grant=users=r /grant=everyone=r /grant=restricted=r /setowner=administrators >> %temp%\subinacl_output.txt

subinacl /keyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f /grant=users=r /grant=everyone=r /grant=restricted=r /setowner=administrators >> %temp%\subinacl_output.txt

subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f /grant=users=r /setowner=administrators >> %temp%\subinacl_output.txt

subinacl /keyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f /grant=users=r /setowner=administrators >> %temp%\subinacl_output.txt

subinacl /subdirectories %SystemDrive% /grant=system=f

********************************

this has solved my problem

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.