Jump to content

Malwarebytes icon changed to generic Windows icon


Recommended Posts

Just installed Malwarebytes on a new Windows 7 computer 3 days ago. Installed OpenOffice today and suddenly the Malwarebytes icons in the taskbar and the start menu have changed to a generic Windows icon (the white page with one corner turned down and a picture of a little window on it). If I right-click that and go to properties, under the shortcut tab, it shows the correct "big red M" icon. But if I use "send to...desktop" to create a shortcut, the shortcut that appears is still a Windows icon. (I didn't have a shortcut on the desktop at all, I only had a quick launch icon in the task bar.) All of the other icons in my taskbar are fine, and all appear fine in the start menu, as well. Malwarebytes appears as a folder in my start menu. It's when I open the folder that the actual Malwarebytes application has the Windows icon.

Should I re-install?

Link to post
Share on other sites

Hi, starfishtwo:

Welcome to MBAM.

I and several folks have experienced this once or twice before with MBAM and another program or 2.

IIRC It typically results from the occasional iconcache corruption in Win7.

Until an MBAM staffer arrives with additional info...

You can try to reinstall MBAM (instructions below).

However, the last time this happened to me, it did not fix the issue. (However, that was a long time ago, and an earlier version of MBAM....)

What ultimately worked for me was running the iconcache repair batch file from sevenforums.com.

Links to that tutorial and more info may be found here:

http://forums.malwarebytes.org/index.php?showtopic=70605

If you want to try a clean reinstall of MBAM first, please follow these instructions, step by step:

  • If you are using MBAM PRO, be sure to have your license ID and key handy first.
  • Download and run mbam-clean.exe from here.
  • It will ask to restart your computer, please allow it to do so (very important!).
  • After the computer restarts, temporarily disable your Anti-Virus and install the latest version of Malwarebytes' Anti-Malware from here.
    Note: You will need to reactivate the program using the license ID & key you were sent via email, if you are using the PRO version.
  • Launch MBAM and set the Protection and Registration (if using the PRO version).
  • Then go to the UPDATE tab (if not done during installation) and check for updates.
  • Restart the computer again and verify that MBAM is in the task tray (if using the PRO version).
  • Now set up any file exclusions as may be required in your Anti-Virus/Internet-Security/Firewall applications. Then restart your Anti-Virus/Internet-Security applications. You may use the guides posted in the FAQs here, or ask and we'll explain how to do it.

Please post back and let us know if your issue is resolved,

daledoc1

Link to post
Share on other sites

thanks for your quick reply! i have tried to respond to you twice but i am having a major keyboard problem that has taken precedence over my icon problem. every time i've tried to respond my keyboard would stop working and seem to be locked into firefox short cuts. i could suddenly not type any letters in this box and the keyboard would only type firefox shortcuts -- if i tried to type an h in this box, it opened firefox history; typing an n would open a new tab. even quitting firefox did not solve the problem, i had to restart each time. i think i am hitting a very bad combination of keys while typing. i am having a hard time adjusting to this new keyboard, as the shift key is shortened to make room for a number pad. that's why i'm not using any capital letters now and am having to type very slowly.

i will try your suggestions but i'm curious: how could i get this iconcache corruption in a computer i've only had for 3 days? i haven't done a lot to it other than install the stuff you've gotta have: avast av, mbam free, firefox, java, flash, etc. i did change the size of my desktop icons using the control key, but mbam wasn't one of them. do you think openoffice could have anything to do with it? the icon changed at the same time i installed openoffice last night.

also i discovered while investigating this new keyboard problem that openoffice had installed an older version of java than i already had. i uninstalled that. but can't imagine what that would have to do with an icon.

i'll try your suggestions and get back to you and let you know how it went. but i have to figure out what's up with my keyboard first.

Link to post
Share on other sites

Hi Daledoc,

After reading all the links you gave me, I was shocked to see how many people have had this problem. I'll bet you are tired of answering this question. I decided to try the easiest fix first: the Properties and then Change Icon route. That has worked for me so far, but I'm wondering if it will revert again and I'll have to do the batch file thing. I didn't find a single person in the links you sent me that was successful at fixing their icon by re-installing, so I decided to forgo that route altogether.

I don't know if this has anything to do with it, but I had no trouble with this 3 day old computer until I downloaded OpenOffice. Right after that, I lost the MBAM icon and then had the stuck ctrl key problem mentioned above. (I discovered after I wrote the above post that the system was behaving as if the ctrl key was pressed even though it wasn't. Only fixable by a re-boot, and then recurring again. After some research, I discovered that this is also a common Win7 problem, with many offered solutions.) While poking around, I discovered that OpenOffice had installed another version of Java that was older than the one I installed the day I got the computer. I uninstalled that version of Java, uninstalled OpenOffice, and then tried the Change Icon on the MBAM icon.

I haven't spent much time on the computer since, so I don't know if either the icon problem or the ctrl key problem are solved permanently, but I thought I'd toss it out there that my problems all started with OpenOffice and this older, duplicate Java.

I'll keep this thread posted as to whether my fixes continue to hold, and will try the batch file thing if necessary.

Link to post
Share on other sites

I certainly don't want to blame OpenOffice. I've been using it happily for years on my old XP computer with no problems whatsoever. But my troubleshooting experience has been to look to the last change was made, and that was the only change I'd made in the 24 hours before the 2 problems started. I'd love to continue using OOo, but I'm going to wait awhile and see if my fixes start before trying again.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.