Jump to content

MBAM won't load@startup for non-Admin user profile


Recommended Posts

I am running the PRO version of MBAM. When I log on to my (occasional use) user account with full administrative privileges, MBAM loads & starts the Protection Module during computer startup.

However, when I log into my (daily use) user account withOUT administrative privileges, MBAM won't load automatically and I have to right-click, load MBAM using the "Run As" option, and then select Protection>Enable Protection Module. All checkboxes below the red/green "Protection Enabled" indicator are always checked, but only become active after "Enabled Protection Module" is manually checked.

Is there anything that can be done so we don’t have to remember to manually load MBAM & enable Protection Module every time we sign on using the non-admin user account?

Link to post
Share on other sites

Hello and :welcome:

Please do the following from the admin account:


  • Download and run mbam-clean.exe from here
  • It will ask to restart your computer, please allow it to do so very important
  • After the computer restarts, temporarily disable your Anti-Virus and install the latest version of Malwarebytes' Anti-Malware from here

    • Note: You will need to reactivate the program using the license you were sent via email if using the Pro version
    • Launch the program and set the Protection and Registration. Then go to the UPDATE tab if not done during installation and check for updates.
      Restart the computer again and verify that MBAM is in the task tray if using the Pro version. Now setup any file exclusions as may be required in your Anti-Virus/Internet-Security/Firewall applications and restart your Anti-Virus/Internet-Security applications. You may use the guides posted in the FAQ's here or ask and we'll explain how to do it.

Link to post
Share on other sites

I ran all directions as asked above. I am running McAfee Total Protection, so through the FAQ guides I was not able to perform the procedures suggested for E - McAfee VirusScan Enterprise 8.x.

Now when log onto the non-Admin account, there is no MBAM icon in the system tray, and if I check the Processes tab in Windows Task Mgr, only mbamservice.exe is running.

When you right-click on the MBAM icon and select “Open”, the “Protection (tab)>Enable Protection Module” checkbox is unchecked, and the red/green Protection icon shows red=disabled. If I click the Enable Protection Module checkbox, I get a popup message that says “[Open SCManager] Failed to perform desired action – Error Code: 5”.

Then a few moments later a box comes up that says “The Anti-Malwarebytes protection module is already running”. At this time the “Enable Protection Module” checkbox becomes checked, and the red/green Protection icon switches to green=enabled. The Windows Task Mgr>Processes tab then shows mbamgui.exe and mbamservice.exe both running.

After a shut down/restart (non-Admin account) if I right-click on the MBAM icon and select “run-as” and sign on using my Admin ID & password, the “Protection (tab)>Enable Protection Module” checkbox still shows unchecked. If I click the Enable Protection Module checkbox, I get a popup message saying “MBAM is now protecting your system actively”. The red/green Protection icon then shows green=enabled, and the “Enable Protection Module” checkbox is grayed out (no longer available for select/deselect). The Windows Task Mgr>Processes tab then shows mbamgui.exe and mbamservice.exe both running.

Link to post
Share on other sites

Hello FightinTheFection,

Please follow the below directions to set exclusions with McAfee Total Protection 2011.

Set Exclusions for Malwarebytes' Anti-Malware in McAfee Total Protection 2011 on 32 bit Windows Versions:

  1. Open McAfee and click on Navigation in the upper right hand corner.
  2. Click on Firewall located under Features.
  3. Click on Program Permissions and wait for the list to populate.
  4. Click the Add button and then click browser.
  5. Add the following files to the firewall with full access:
    Note: On 64 bit Windows versions these files will be located in C:\Program Files (x86)\Malwarebytes' Anti-Malware
    • C:\Program Files\Malwarebytes' Anti-Malware\mbam.exe
    • C:\Program Files\Malwarebytes' Anti-Malware\mbamservice.exe

[*]Click OK

[*]Close the McAfee main window and restart your computer.

Set Exclusions for McAfee Total Protection 2011 in Malwarebytes' Anti-Malware:

  • Open Malwarebytes' Anti-Malware and click on the Ignore List tab
  • Click the Add button on the lower left
  • In the small browse window that opens, navigate to C:\Program Files and click once on McAfee and click OK.
  • Click the Add button on the lower left
  • In the small browse window that opens, navigate to C:\Program Files and click once on McAfee.com and click OK.
    Note: For 64 bit Windows versions these folders will be in C:\Program Files (x86)
  • Close Malwarebytes' Anti-Malware

Thank you.

Link to post
Share on other sites

Thanks for the help. My Mcafee (copyright 2010) didn't have a "Program Permissons" selection under the Navigation>Features>Firewall, but I found what you said to look for under Navigation>Features>Firewall>Internet Connections For Programs.

I made all the changes you listed and perhaps we are not finished with all of the steps, but under the non-Admin account MBAM is still not appearing in the system tray, and the red "Protection disabled" indicator still appears under the Protection tab. I continue to get the same messages ("Error Code 5", followed by "protecting your system actively") as in my previous post.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.