Jump to content

Hijack.Comsysapp FP in registry


Tarnak
 Share

Recommended Posts

I run various snapshots for testing purposes.

I was surprised find to a detection when I ran todays quick scan.

I allowed MBAM to clean the detection.

However, I booted into another snapshot, and updated the definition set to the latest before I ran a quick scan, lo and behold I got the same detection.

As I don't believe lightning strikes in the same place twice, it seems to me that this is a false positive.

I have included the scan details:

Malwarebytes' Anti-Malware 1.51.0.1200

www.malwarebytes.org

Database version: 7118

Windows 5.1.2600 Service Pack 3

Internet Explorer 6.0.2900.5512

14/07/2011 10:27:56 AM

mbam-log-2011-07-14 (10-27-48).txt

Scan type: Quick scan

Objects scanned: 157762

Time elapsed: 6 minute(s), 7 second(s)

Memory Processes Infected: 0

Memory Modules Infected: 0

Registry Keys Infected: 0

Registry Values Infected: 0

Registry Data Items Infected: 1

Folders Infected: 0

Files Infected: 0

Memory Processes Infected:

(No malicious items detected)

Memory Modules Infected:

(No malicious items detected)

Registry Keys Infected:

(No malicious items detected)

Registry Values Infected:

(No malicious items detected)

Registry Data Items Infected:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\SERVICES\COMSYSAPP\Start (Hijack.Comsysapp) -> Bad: (2) Good: (3) -> No action taken. [9836e6350ef2af51ead64b5e93724bb5]

Folders Infected:

(No malicious items detected)

Files Infected:

(No malicious items detected)

Link to post
Share on other sites

  • Staff

This will be fixed in the next update.

Did you change the comsysapp service startup type?

This def was part of a companion def that hijacked the service and replaced the exe

This part of the def that was detected on your snapshots detects the service being changed from manual startup to automatic.

What is being detected is not normally the correct startup type for this service.

http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/sys_srv_default_settings.mspx?mfr=true

Just wondering if you may be able to shed some light on why yours may be different.

Thanks!

Link to post
Share on other sites

I have 3 snapshots currently that I use.

The particular service would be common to these snapshots. As far as I know I did nothing special with the service. See screenshot.

Hope this helps.

P.S. I can't post the screenshot, but it has C:\WINDOWS\system32\dllhost.exe /Processid:{02D4B3F1-FD88-11D1-960D-00805FC79235} showing under "Path to executable"

Link to post
Share on other sites

  • Staff

The path is correct. The def that hit was the startup type being set to automatic. Just curious as the default for that service type is manual and yours is set to automatic.

If you check the link at msft i provided you will see is normally set to manual. Just was wondering if you may have changed It.

Thanks.

Link to post
Share on other sites

I had a problem back in February, where I had the motherboard replaced. See Wilders > Hardware > hardware

So, maybe something was changed, then.

Yes...the service is set to automatic, but does it really matter whether the recommended setting is manual as per that msft link you posted?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.