Jump to content

I can not enable protection module


Recommended Posts

Hello and :welcome:

Sorry to hear you are having problems...

Please do the following:


  • Download and run mbam-clean.exe from here
  • It will ask to restart your computer, please allow it to do so very important
  • After the computer restarts, temporarily disable your Anti-Virus and install the latest version of Malwarebytes' Anti-Malware from here

    • Note: You will need to reactivate the program using the license you were sent via email if using the Pro version
    • Launch the program and set the Protection and Registration. Then go to the UPDATE tab if not done during installation and check for updates.
      Restart the computer again and verify that MBAM is in the task tray if using the Pro version. Now setup any file exclusions as may be required in your Anti-Virus/Internet-Security/Firewall applications and restart your Anti-Virus/Internet-Security applications. You may use the guides posted in the FAQ's here or ask and we'll explain how to do it.

Link to post
Share on other sites

  • Root Admin

Hello and Welcome to Malwarebytes

If you think you are infected, here are the steps needed to get your computer cleaned....

Please read the following so that you can begin the cleaning process:

You have 3 Options that you can choose from as listed below:

  • Option 1
Link to post
Share on other sites

  • 2 weeks later...

Having exactly the same problem. Tried all the above; but, no help. Need more ideas.

History:

This is a client computer on the bench right now. This is a paid MBAM Pro license installed 11/12/2010. System

is Windows XP SP3 with no other AV or firewall software installed. Problem is occuring now _after_ a malware

cleanup. I'm trying to get MBAM working properly after the malware is gone. Computer had become infected badly.

First removed the malware with the following steps:

Before even booting it up, I removed the hard drive, and on another computer, made a complete image backup (to

be able start all over if necessary), manually cleaned out all the malware files (anything ugy or fishy looking)

from the following places:

C:\<top>

\Windows\Temp (emptied)

\Windows\System32

\System32\drivers\etc\<host files>

<all users>\

<all users>\Application Data

<user>\Application Data

<user>\Local Settings

<user>\Local Settings\Temp (emptied)

<user>\Local Settings\Temporary Internet Files (emptied)

<user>\Local Settings\Application Data

That having been completed, I reinstalled the HD in computer and booted to Windows. Once up, ran the currently

installed MBAM, updated to 1.51, rebooted, ran MBAM, updated definitions, and performed a Quick Scan. That

found and cleaned any remaining files and the couple dozen registry entries. Rebooted and ran MBAM Quick Scan

again, nothing further found.

But now the Potection Module was no longer running. Gave Error 2 on startup. Investigation revealed

MBAMSerfvice set to Automatic but not "Started". Protection tab shows green and looks like Protection is

"Enabled". Box is checked and grayed. But service not actually running. Tried to "Start" MBAMService, get Error

1068, Dependecy Group failure. Dependency reported as "MBAMProtector" which itself depends on a "FltMgr"

service. Neither of these two services can be found in the Services list.

On a known, good XP SP3 system, running MBAM 1.51 Trial enabled, protection enabled, I also see the same

dependencies listed, though not found in Windows list of services and the mbamservice.exe process is indeed

running. And I can successfully kill the mbamservice.exe process (only way to stop it), then Start it from

Management Cosole | Services, bring up MBAM and reenable Protection. Just like it ought to behave.

But on the problem system, attempting to start the mbamservice.exe service (no matter how you try to do it)

always gives Error 1068, Dependency Group failure.

Followed the recommended steps:

0. Perform all Windows Updates (none needed)

1. From Add & Romove Programs control panel, Unistall MBAM

2. Reboot Windows

3. Download and run mbam-clean.exe (1.50.1.0003)

4. Reboot Windows

5. Install MBAM (1.51.0.1200) (Decline Trial)

6. Allow it to Update definitions to today

7. Protection tab | Register, enter license info, Protection enabled.

8. System Try: set MBAM to "Always Show" (I like it that way), icon appears.

9. Reboot computer

10. System comes up, no MBAM icon in system tray, double-check "Always show", still set. Check Task Manager and

System Console | Services, "MBAMService" still set to Automatic, but not "Started", mbamservice.exe missing from

Task Manager.

11. Try to start MBAMService from System Console | Services or by executing mbamservices.exe directly from MBAM

folder. Fails with Error 1068.

Repeated steps 1. thru 11. Same result.

Rather than repeat the above a third time, for which I expect the result will be the same :-), I want to try

something different. Any suggestions?

Obviously, reinstalling a fresh, clean copy of Windows XP SP3, installing all Windows Updates, reinstalling all

applications, including MBAM, replacing all user's files, etc. ought to "fix" the problem. But I'm hoping to

avoid that.

Thanks in advance for anyone's help!

- John

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.