Jump to content

Malwarebytes disables McAfee realtime scanning


Recommended Posts

I am running Malwarebytes version 1.50.1.1100 and McAfee Total Protection. Every time I enable the Protection Module, it causes McAfee Real-Time Scanning to stop running. In order for McAfee to run correctly, I cannot have the Protection Module running. I have read the other posts about McAfee affecting Malwarebytes, but nothing about Malwarebytes affecting McAfee. Anyone have the solution? :welcome:

Link to post
Share on other sites

Hello and :)

Please provide following details, so that someone may be able to assist you:

  • 1. OS version including 32/64-bit
    2. Installed Security Product(s) including Firewall and Program Versions
    3. MBAM version (current 1.50.1.1100) (Free or Pro)
    4. Definition version (current 5457)

Also you can start by excluding the Malwarebytes files in your McAfee Antivirus, and also in Malwarebytes, exclude the install folder for the McAfee product.....

Please exclude the following files from your antivirus:

Note: If using a software firewall besides the built in Windows Firewall you'll need to exclude them from it as well

For Windows XP:

  • C:\Program Files\Malwarebytes' Anti-Malware\mbam.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamgui.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamservice.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\mbam.dll
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamext.dll
  • C:\Documents and Settings\All Users\Application Data\Malwarebytes\Malwarebytes' Anti-Malware\rules.ref
  • C:\Windows\System32\drivers\mbam.sys
  • C:\Windows\System32\drivers\mbamswissarmy.sys

For Windows Vista or Windows 7:

  • C:\Program Files\Malwarebytes' Anti-Malware\mbam.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamgui.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamservice.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\mbam.dll
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamext.dll
  • C:\ProgramData\Malwarebytes\Malwarebytes' Anti-Malware\rules.ref
  • C:\Windows\System32\drivers\mbam.sys
  • C:\Windows\System32\drivers\mbamswissarmy.sys

For 64 bit versions of Windows Vista or Windows 7:

  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbam.exe
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbamgui.exe
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbamservice.exe
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbam.dll
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbamext.dll
  • C:\ProgramData\Malwarebytes\Malwarebytes' Anti-Malware\rules.ref
  • C:\Windows\System32\drivers\mbam.sys
  • C:\Windows\SysWoW64\drivers\mbamswissarmy.sys

Note: If using a software firewall besides the built in Windows Firewall you'll need to exclude MBAM.EXE from it as well

Note: Once that's done, please make sure that if either of those programs has any sort of web filter, that you add the following as a trusted site:

data-cdn.mbamupdates.com

The FAQ contains examples of setting file exclusions for some known AV products

Please post back and let us know how it went.

Link to post
Share on other sites

To make it a lot easier here are the McAfee files to add to the ignore tab in Malwarebytes:

Folders:

C:\Program Files\McAfee

C:\Program Files\McAfee.com

C:\Program Files\Common Files\Mcafee

Files:

C:\WINDOWS\system32\drivers\mfeapfk.sys

C:\WINDOWS\system32\drivers\mfeavfk.sys

C:\WINDOWS\system32\drivers\mfebopk.sys

C:\WINDOWS\system32\drivers\mfeclnk.sys

C:\WINDOWS\system32\drivers\mfefirek.sys

C:\WINDOWS\system32\drivers\mfehidk.sys

C:\WINDOWS\system32\drivers\mfendisk.sys

C:\WINDOWS\system32\drivers\mferkdet.sys

C:\WINDOWS\system32\drivers\mfetdi2k.sys

I'm assuming that the drivers and folders are the same in Total Protection as in Internet Security.

If this doesn't work then keep these in the ignore list and edit McAfee's registry as shown in my previous post then that should be that and run MVT as well.

Stay away from McAfee support as they won't help and will tell you to uninstall Malwarebytes.

Link to post
Share on other sites

OK. I'm using Windows 7 64-bit, McAfee Total Protection 2010 with it's own firewall; MBAM version 1.50.1.1100 Pro; definition version 5475. I was able to add the Program Files to the exclusion list but was not able to access the system32\drivers\ from the add popup box. I even went to my file folder and unchecked hide protected system files. I am able to find them outside of MBAM via my Computer\c:...

I know that McAfee is not the issue here, it is MBAM that is affecting McAfee. I did try to add the files to the firewall exclusion list, of which MBAM was already allowed full acess, but I could not access any files you listed in post #2. I also followed the links provided and read that McAfee TP 2011 will not function with MBAM. Any other suggestions? :blink:

Link to post
Share on other sites

OK. I think I have solved the issue thanks to hwedin. Even though I could not excuse the system32 driver files , I excluded the following folders:

C:\ProgramData\McAfee

C:\Program Files\McAfee

C:\Program Files\McAfee.com

C:\Program Files\Common Files\McAfee

I use Windows 7 64-bit, so I also excluded the following folders:

C:\Program Files (x86)\McAfee

C:\Program Files (x86)\McAfee.com

C:\Program Files (x86)\McAfee Online Backup

C:\Program Files (x86)\McAfee\Commom Files\McAfee

I'll sure be back if the issue pops up again. Thanks for everyone's help and I hope this helps others with the same problem. :blink:

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.