Jump to content

SOLUTION TO: c:\program files\malwarebytes' Anti-Malware\mbamext.dll Unable to register the dll/ocx: RegSvr32 failed with exit code 0x5


Recommended Posts

I've encountered on my and some other computers this error:

c:\program files\malwarebytes' Anti-Malware\mbamext.dll Unable to register the dll/ocx: RegSvr32 failed with exit code 0x5

during the installation. That means that right-click scanning is not available. I found a solution to a problem.

Please try opening run, and then typing:

regsvr32  atl.dll

After, that, go to

C:\Program files\Malwarebytes' Anti-Malware\

and copy mbamext.dll to

C:\Windows\system32

Then open run again and type:

regsvr32  mbamext.dll

That worked for my and other computers. I hope it works for you!

Link to post
Share on other sites

  • 2 weeks later...
  • Root Admin

I'm reasonably certain I've found the solution to fixing this. Not certain what causes the issue though in the first place.

It's very late here right now and I still need to write up some documentation and do a little more testing but will try to post the fix some time this weekend.

Link to post
Share on other sites

I've encountered on my and some other computers this error:

c:\program files\malwarebytes' Anti-Malware\mbamext.dll Unable to register the dll/ocx: RegSvr32 failed with exit code 0x5

during the installation. That means that right-click scanning is not available. I found a solution to a problem.

Please try opening run, and then typing:

regsvr32  atl.dll

After, that, go to

C:\Program files\Malwarebytes' Anti-Malware\

and copy mbamext.dll to

C:\Windows\system32

Then open run again and type:

regsvr32  mbamext.dll

That worked for my and other computers. I hope it works for you!

You are kind of right cuz my right click scan really wasn't working. But the solution didnt work for me tho. Ppl are getting closer and closer to solving this error once and for all, but this was the closest ive seen so far. Thanx Man

Link to post
Share on other sites

  • 8 years later...
2 hours ago, mundane said:

Wow, this post dates way back 2008 but I'm having the same issue now. I can't seem to find the solution. I wonder if you guys have found it and would like to share.

Since this is quite an old post, things have changes since then....

Please start your own topic with the following info below.

  1. If that does not correct the issue, then please read the following and attach to your next reply the 3 requested logs - Diagnostic Logs (the 3 logs are: mb-check-results.zip, FRST.txt, Addition.txt)


Please let us know how it goes.


Thank You,

Firefox

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.