Jump to content

MBAM_ERROR_UPDATING (122,0,MultibyteToWide Char)

Recommended Posts

MBAM_ERROR_updating (122, 0, multiByteToWideChar) The data area passed to a system call is too small."

Windows 7 Ultimate x86 32 bit

CA ISS 2010 Plus, and CA Firewall

Malwarebytes db ver 4052

Mbam scans okay, but I am unable to update it. I am unable to install CA AV with Malwarebytes installed, so uninstalling then reinstalling mbam is not an option. The fix posted elsewhere on here does not work for me.

This happened after installing CA anti-virus. I'd like to keep CA and mbam. Haved there been any updates on a fix for this? I haven't found anything on the CA AV site about it.

Link to post
Share on other sites

@ GJoz it may help if you start your own topic....

Please exclude the following files from your antivirus:

Note: If using a software firewall besides the built in Windows Firewall you'll need to exclude them from it as well

For Windows Vista or Windows 7:

  • C:\Program Files\Malwarebytes' Anti-Malware\mbam.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamgui.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamservice.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\zlib.dll
  • C:\Program Files\Malwarebytes' Anti-Malware\mbam.dll
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamext.dll
  • C:\ProgramData\Malwarebytes\Malwarebytes' Anti-Malware\rules.ref
  • C:\Windows\System32\drivers\mbam.sys
  • C:\Windows\System32\drivers\mbamswissarmy.sys

Note: If using a software firewall besides the built in Windows Firewall you'll need to exclude MBAM.EXE from it as well

Note: Once that's done, please make sure that if either of those programs has any sort of web filter, that you add the following as a trusted site:


The FAQ contains examples of setting file exclusions for some known AV products

Please post back and let us know how it went.

Link to post
Share on other sites

Hi -

Please note that data-cdn.mbamupdates.com is the most important item to ensure you install to the firewall setup of CA -

This should then allow updates - Or disable CA while you perform the updates , as it can block your system -

Thank You -

EDIT - These methods seem to work -

With CA 2010

Open 'My Internet' section.

If so open that up and click 'View Settings'.

Look for 'Identity Protection'

Scroll down to 'Trusted and Untrusted Sites'

Paste in the following:


Tick 'Trusted Site-always allow'

Click 'Add'

Click 'Apply' and reboot

See if that helps


In CA ISS 2007 and 2008:

Open the CA Personal Firewall GUI;

Click the 'Privacy' icon;

On the tab: "Internet Browser Protection", click the "Manage Sites" button;

In the 'manage sites' dialog box, click "Add";

In the 'URL' field, paste this URL:


In each tab of that dialog box, make sure that no boxes are checked;

Click OK;

On the 'manage sites' dialog box, click 'Close";

Close CA Personal Firewall GUI.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.