Jump to content

Malwarebytes anti-malware wont start


Recommended Posts

when i try to start malwarebytes' anti malware i get the following error

An error has occurred. Please report this error code to our support team.

MBAM_ERROR_EXPANDING_VARIABLES (0,9)

Thanks for ur help in advance

Also when i close the box i get the following

An error has occurred. Please report this error code to our support team.

MBAM_ERROR_MISSING_FILE (3, 0, mbamswissarmy.sys)

The system cannot find the path specified

Link to post
Share on other sites

MBAM_ERROR_EXPANDING_VARIABLES (0,9)

MBAM_ERROR_MISSING_FILE (3,0, mbamswissarmy.sys)

The system cannot find the path specified.

Here's a fix that exile360 made, it is universal for XP, Vista and Windows 7 and should fix the problem:

Note: If using Windows Vista or Windows 7 you MUST right-click on the file and select "Run as administrator".

  • Please copy and paste the following text in the Code box exactly as written into notepad (not wordpad or any other text editor):
    @color 48
    @echo off
    if exist "%allusersprofile%\Microsoft\Windows\Start Menu" md "%allusersprofile%\Microsoft\Windows\Start Menu\Programs\Startup"
    if not exist "%allusersprofile%\Microsoft\Windows\Start Menu" md "%allusersprofile%\Start Menu\Programs\Startup"
    if exist "%appdata%\Microsoft\Windows\Start Menu" md "%appdata%\Microsoft\Windows\Start Menu\Programs\Startup"
    if not exist "%appdata%\Microsoft\Windows\Start Menu" md "%userprofile%\Start Menu\Programs\Startup"
    del /f /q %0


  • Once you've done that click on File and select Save As...
  • In the Save dialogue box click on the drop down menu next to Save as type and select All Files
  • Name the file Fix.bat (the .bat extension is very important)
  • Save the file to your desktop and double click it to run it if using Windows XP. If using Windows Vista or Windows 7 you MUST right-click on the file and select Run as administrator otherwise it will not work.
  • Once that's complete try running Malwarebytes' Anti-Malware again to see if it now works without error or not.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.