Jump to content

Error Updating -- mbam_error_updating(0,0,WinHttpSendRequest)


Recommended Posts

Hi, A while ago my malwareBytes refused to update to level 17 in the database. I have tried several of the fixes provided but none have worked. I have noticed that only I have received an Error Code of 0,0. I suspect a new combination router/modem (ActionTec) but really don't know the answer. What does that Error Code mean?

Thank you,

Ron Baker

Link to post
Share on other sites

refused to update to level 17 in the database
Welcome -

I am not sure exactly what you mean by Level 17 - Our current Version is V1.46 and datadase update is 4653 as I type this -

Click on this link and let me know what it says. It should be just a 4-digit number in the upper-left corner.

To Fully Remove and Reinstall a Fresh New Copy of Malwarebytes - Read Carefully

Windows XP:

  • Click on Start and select Control Panel
  • Open Add/Remove Programs
  • Uninstall Malwarebytes' Anti-Malware
  • Restart your computer very important !
  • Download and run mbam-clean.exe from Here

It will ask to restart your computer, please allow it to do so, very important

After the computer restarts, temporarily disable your Anti-Virus and install the latest version of Malwarebytes' Anti-Malware from Here

Windows Vista and Windows 7:

  • Click on the Start button and select Control Panel
  • Click on Programs and Features
  • Uninstall Malwarebytes' Anti-Malware
  • Restart your computer very important !
  • Download and run mbam-clean.exe from Here

It will ask to restart your computer, please allow it to do so, very important

After the computer restarts, temporarily disable your Anti-Virus and install the latest version of Malwarebytes' Anti-Malware from Here

Note: You will need to reactivate the program using the license you were sent via email if using the Paid version only

Launch the program and set the Protection and Registration. Then go to the UPDATE tab if not done during installation and check for updates.

Restart the computer again and verify that MBAM is in the task tray if using the Pro version. Now reset any file exclusions as may be required in your Anti-Virus/Internet-Security/Firewall applications and restart your Anti-Virus/Internet-Security applications.

You may use the guides posted in the FAQ's here or ask me and I'll explain how to do it.

Thank You - :)

EDIT -

Please post a quick reply if I have misunderstood -

Edited to include the Quick link item and a request for a quick reply -

Link to post
Share on other sites

Hi,

Sorry, forget about the 17 reference.

The number in the top left corner is 4656

Current DB info is:

Date 4/29/10

DB Version 4052

Fingerprints loaded 227746

When I attempt to Update, a picture shows 'connecting to server' then immediately that is superseded by the error message I.E.

Update Failed Mbam_error_updating(0,0,WinHttpSentRequest)

I am using Microsoft Windows 7 (64) with the very latest level Firefox Browser. I have installed a new ActionTec GT724WGR combination router/modem some two months ago and maybe his is related. Updating always worked in the past but I have no exact idea when it started failing.

I have disabled both Windows Firewall and Threatfire's Firewall. No help.

I have also tried the remedy suggested in your post (a couple of times) with no help.

The error code should point to some kind of answer?

I hope this helps.

Thanks,

Ron Baker

Welcome -

I am not sure exactly what you mean by Level 17 - Our current Version is V1.46 and datadase update is 4653 as I type this -

Click on this link and let me know what it says. It should be just a 4-digit number in the upper-left corner.

To Fully Remove and Reinstall a Fresh New Copy of Malwarebytes - Read Carefully

Windows XP:

  • Click on Start and select Control Panel
  • Open Add/Remove Programs
  • Uninstall Malwarebytes' Anti-Malware
  • Restart your computer very important !
  • Download and run mbam-clean.exe from Here

It will ask to restart your computer, please allow it to do so, very important

After the computer restarts, temporarily disable your Anti-Virus and install the latest version of Malwarebytes' Anti-Malware from Here

Windows Vista and Windows 7:

  • Click on the Start button and select Control Panel
  • Click on Programs and Features
  • Uninstall Malwarebytes' Anti-Malware
  • Restart your computer very important !
  • Download and run mbam-clean.exe from Here

It will ask to restart your computer, please allow it to do so, very important

After the computer restarts, temporarily disable your Anti-Virus and install the latest version of Malwarebytes' Anti-Malware from Here

Note: You will need to reactivate the program using the license you were sent via email if using the Paid version only

Launch the program and set the Protection and Registration. Then go to the UPDATE tab if not done during installation and check for updates.

Restart the computer again and verify that MBAM is in the task tray if using the Pro version. Now reset any file exclusions as may be required in your Anti-Virus/Internet-Security/Firewall applications and restart your Anti-Virus/Internet-Security applications.

You may use the guides posted in the FAQ's here or ask me and I'll explain how to do it.

Thank You - :)

EDIT -

Please post a quick reply if I have misunderstood -

Edited to include the Quick link item and a request for a quick reply -

Link to post
Share on other sites

Hi -

Please use the method I have listed above and then try to update your database - Your log shows 4052 , current is 4660 as I type -

You appear to be able to access the update number (4656 yesterday) -

(Date 4/29/10) - Would this be an estimate of the date you installed the new router ?? - This is your last successful update -

The router May not have been set up 100% correctly (as a guess only) -

Thank You -

EDIT -

Can you list the full security (mainly your full Antivirus program) and I may be able to help more -

After spending about $80 on a new modem/router we would like to help set it up if you need help -

Link to post
Share on other sites

Hi -

Please use the method I have listed above and then try to update your database - Your log shows 4052 , current is 4660 as I type -

You appear to be able to access the update number (4656 yesterday) -

(Date 4/29/10) - Would this be an estimate of the date you installed the new router ?? - This is your last successful update -

The router May not have been set up 100% correctly (as a guess only) -

Thank You -

EDIT -

Can you list the full security (mainly your full Antivirus program) and I may be able to help more -

After spending about $80 on a new modem/router we would like to help set it up if you need help -

Link to post
Share on other sites

Hello,

Well, I have, done as requested. I.E. removed MalwareBytes, used the Malware Cleaner from that location and followed the instructions exactly and the end result is the same. I had done that at least twice previously.

The level of MalwareBytes is 1.46 and the other DB info is the same. The DB had updated previously at 1.46 and was originally higher before this problem began. Once again, I will ask. Does the error code of 0,0 mean anything?

Everything else works perfectly fine with the new ActionTec router/modem.

I don't use a specific Anti-Virus program . I rely on Malware, Spyware Terminator, and the Firewalls of Windows, and Threatfire (an heuristic program from PC Tools) to keep out bad software.

I have no other problems and I am beginning to think I should just forget about MalwareBytes.

thanks,

Ron Baker

Link to post
Share on other sites

Hi -

Please use the ADD REPLY Tab or The QUICK REPLY Tab at the bottom if you want to respond to anything -

The link that showed 4656 meant you accessed the latest update at the time -

This next test is to find if your router can access our downloader or if you are redirected during the attempt -

Please download and run the traceroute utility at this link. It will run a traceroute to our update servers to see if it can find the connection issue, and then it will write it to a log, and open that log in Notepad when it is done. Please either save the log as a Text File and then attach it to a reply, or copy and paste it into a reply, and I will forward it on to our server guy.

Note that it may take several minutes to run, and it may look like it is not doing anything for a few minutes. Normally it takes longer when there are errors that it has to log, but it's rare for it to go more than 10 minutes.

Error code (0,0) is a M/soft code that usually means no basic problems are involved -

First : Open the program from the Icon and click Settings > Scanner settings and untick the bottom item in there -

Next : Please exclude the following files from all your antivirus programs -

For 64 bit versions of Windows Vista or Windows 7:

  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbam.exe
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbamgui.exe
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbamservice.exe
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\zlib.dll
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbam.dll
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbamext.dll
  • C:\ProgramData\Malwarebytes\Malwarebytes' Anti-Malware\rules.ref
  • C:\Windows\System32\drivers\mbam.sys
  • C:\Windows\SysWoW64\drivers\mbamswissarmy.sys

Note: If using a software firewall besides the built in Windows Firewall you'll need to exclude MBAM.EXE from it as well

Note: Once that's done, please make sure that if any of your programs has any sort of web filter, that you add the following as a trusted site:

data-cdn.mbamupdates.com

Then try a manual update from Here - It will not be the latest update but it will only be a few days old usually -

Thank You -

EDIT -

Spyware Terminator has included the popular award winning open-source antivirus, Clam AntiVirus (ClamAV), for optional integration to achieve a higher level of security. ClamAV can be integrated into spyware scans, updates and the real-time protection.
Link to post
Share on other sites

Hi,

Here is the Trace that you requested.

Thanks,

Ron baker

Phase #1

Tracerouting: data-cdn.mbamupdates.com

Tracing route to ne1.wpc.edgecastcdn.net [72.21.81.133]

over a maximum of 30 hops:

1 1 ms <1 ms <1 ms 192.168.0.1

2 43 ms 42 ms 43 ms fl-71-54-168-1.dhcp.embarqhsd.net [71.54.168.1]

3 42 ms 42 ms 42 ms rbflwnpk11 [67.76.124.225]

4 43 ms 43 ms 42 ms host145.embarqnow.net [205.245.14.145]

5 67 ms 67 ms 67 ms te-7-2.car2.Orlando1.Level3.net [4.79.118.177]

6 67 ms 66 ms 66 ms ae-2-9.bar2.Orlando1.Level3.net [4.69.133.70]

7 67 ms 66 ms 67 ms ae-0-11.bar1.Orlando1.Level3.net [4.69.137.145]

8 75 ms 72 ms 71 ms ae-8-8.ebr1.Atlanta2.Level3.net [4.69.137.150]

9 66 ms 67 ms 67 ms ae-27-52.car1.Atlanta4.Level3.net [4.68.103.44]

10 52 ms 52 ms 51 ms EDGECAST-NE.car1.Atlanta4.Level3.net [4.53.233.54]

11 52 ms 52 ms 52 ms 72.21.81.133

Trace complete.

DNS Info

Server: dslmodem.domain

Address: 192.168.0.1

DNS request timed out.

timeout was 2 seconds.

DNS request timed out.

timeout was 2 seconds.

Name: ne1.wpc.edgecastcdn.net

Address: 72.21.81.133

Aliases: data-cdn.mbamupdates.com

wpc.1d00.edgecastcdn.net

gs1.wpc.edgecastcdn.net

============================================================

Phase #2

Tracerouting: llnw.data-cdn.mbamupdates.com

Tracing route to mwbyte.vo.llnwd.net [68.142.101.254]

over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms 192.168.0.1

2 42 ms 42 ms 42 ms fl-71-54-168-1.dhcp.embarqhsd.net [71.54.168.1]

3 42 ms 43 ms 42 ms rbflwnpk11 [67.76.124.225]

4 43 ms 43 ms 43 ms 138.210.95.9

5 42 ms 42 ms 42 ms host.lightcore.net [208.110.248.153]

6 50 ms 49 ms 50 ms bb-miauflws-jx9-02-xe-1-1-0.core.centurytel.net [208.110.248.193]

7 49 ms 48 ms 48 ms bb-miauflws-jx9-01-ae0.core.centurytel.net [208.110.248.101]

8 56 ms 49 ms 49 ms e1-3.fr1.mia1.llnw.net [198.32.124.145]

9 49 ms 49 ms 49 ms cdn-68-142-101-254-mia1.llnw.net [68.142.101.254]

Trace complete.

DNS Info

Server: dslmodem.domain

Address: 192.168.0.1

DNS request timed out.

timeout was 2 seconds.

DNS request timed out.

timeout was 2 seconds.

Name: mwbyte.vo.llnwd.net

Addresses: 68.142.101.7

68.142.101.254

Aliases: llnw.data-cdn.mbamupdates.com

============================================================

Phase #3

Tracerouting: edge.data-cdn.mbamupdates.com

Tracing route to ne1.wpc.edgecastcdn.net [72.21.81.133]

over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms 192.168.0.1

2 43 ms 43 ms 43 ms fl-71-54-168-1.dhcp.embarqhsd.net [71.54.168.1]

3 42 ms 43 ms 42 ms rbflwnpk11 [67.76.124.225]

4 42 ms 43 ms 42 ms host145.embarqnow.net [205.245.14.145]

5 67 ms 66 ms 66 ms te-7-2.car2.Orlando1.Level3.net [4.79.118.177]

6 67 ms 66 ms 67 ms ae-2-9.bar2.Orlando1.Level3.net [4.69.133.70]

7 66 ms 161 ms 66 ms ae-0-11.bar1.Orlando1.Level3.net [4.69.137.145]

8 75 ms 72 ms 71 ms ae-8-8.ebr1.Atlanta2.Level3.net [4.69.137.150]

9 66 ms 66 ms 67 ms ae-27-52.car1.Atlanta4.Level3.net [4.68.103.44]

10 52 ms 52 ms 51 ms EDGECAST-NE.car1.Atlanta4.Level3.net [4.53.233.54]

11 52 ms 52 ms 53 ms 72.21.81.133

Trace complete.

DNS Info

Server: dslmodem.domain

Address: 192.168.0.1

DNS request timed out.

timeout was 2 seconds.

DNS request timed out.

timeout was 2 seconds.

Name: ne1.wpc.edgecastcdn.net

Address: 72.21.81.133

Aliases: edge.data-cdn.mbamupdates.com

wpc.1D00.edgecastcdn.net

gs1.wpc.edgecastcdn.net

============================================================

Finished at: 9:23:21.04

Link to post
Share on other sites

Hello ronaldb999:

Logs clearly indicate you have DNS issue, I am not conversant with 64-bit of Windows 7, however, the issue seems more likely with your router

If possible, reset router to factory default, then reconfigure, however, don't forget to change login password

Should you have any other question(s) please post back

Link to post
Share on other sites

Hello ronaldb999:

Logs clearly indicate you have DNS issue, I am not conversant with 64-bit of Windows 7, however, the issue seems more likely with your router

If possible, reset router to factory default, then reconfigure, however, don't forget to change login password

Should you have any other question(s) please post back

Hi, Well I did as you said but still no help.

For your information, I realized that i have my laptop available so I downloaded MalwareBytes onto that and then proceeded to update the laptop with no problem. (using the same router)

I have decided to forego any further investigation since it is taking too much time. I will learn to get along w/o Malwarebytes..

Thanks for your help.

Ron Baker

Link to post
Share on other sites

I seem to be having the same problem - I cannot update and MWBytes finds nothing during scans.

Traceroute Malwarebytes CDN version 1.5

Thu 09/23/2010

9:18:25.89

Phase #1

Tracerouting: data-cdn.mbamupdates.com

Tracing route to ne1.wpc.edgecastcdn.net [72.21.81.133]

over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms 192.168.64.1

2 1 ms 4 ms 1 ms 192.168.5.203

3 * * * Request timed out.

4 * * * Request timed out.

5 * * * Request timed out.

6 * * * Request timed out.

7 * * * Request timed out.

8 * * * Request timed out.

9 * * * Request timed out.

10 * * * Request timed out.

11 * * * Request timed out.

12 33 ms 32 ms 39 ms 72.21.81.133

Trace complete.

DNS Info

Server: moore2000serv.pgs.local

Address: 192.168.64.10

Name: ne1.wpc.edgecastcdn.net

Address: 72.21.81.133

Aliases: data-cdn.mbamupdates.com, wpc.1d00.edgecastcdn.net

gs1.wpc.edgecastcdn.net

============================================================

Phase #2

Tracerouting: llnw.data-cdn.mbamupdates.com

Tracing route to mwbyte.vo.llnwd.net [208.111.160.6]

over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms 192.168.64.1

2 26 ms 25 ms 16 ms 192.168.5.203

3 * * * Request timed out.

4 * * * Request timed out.

5 * * * Request timed out.

6 * * * Request timed out.

7 * * * Request timed out.

8 * * * Request timed out.

9 * * * Request timed out.

10 * * * Request timed out.

11 * * * Request timed out.

12 10 ms 10 ms 10 ms cdn-208-111-160-6.iad.llnw.net [208.111.160.6]

Trace complete.

DNS Info

Server: moore2000serv.pgs.local

Address: 192.168.64.10

Name: mwbyte.vo.llnwd.net

Addresses: 208.111.160.6, 208.111.161.254

Aliases: llnw.data-cdn.mbamupdates.com

============================================================

Phase #3

Tracerouting: edge.data-cdn.mbamupdates.com

Tracing route to ne1.wpc.edgecastcdn.net [72.21.81.133]

over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms 192.168.64.1

2 1 ms 1 ms 1 ms 192.168.5.203

3 * * * Request timed out.

4 * * * Request timed out.

5 * * * Request timed out.

6 * * * Request timed out.

7 * * * Request timed out.

8 * * * Request timed out.

9 * * * Request timed out.

10 * * * Request timed out.

11 * * * Request timed out.

12 10 ms 10 ms 10 ms 72.21.81.133

Trace complete.

DNS Info

Server: moore2000serv.pgs.local

Address: 192.168.64.10

Name: ne1.wpc.edgecastcdn.net

Address: 72.21.81.133

Aliases: edge.data-cdn.mbamupdates.com, wpc.1d00.edgecastcdn.net

gs1.wpc.edgecastcdn.net

============================================================

Finished at: 9:24:37.38

Link to post
Share on other sites

@ charris

That traceroute log shows a DNS issue, and it's possible that your DNS settings have been hijacked. If you connect to the Internet through a router, then I would highly recommend that you reset it to it's factory default settings by holding the 'Reset' button on the back of the router until the power light starts blinking. This will clear all of the settings, including DNS settings, and reset them to the factory defaults, which should resolve the issue.

Please note that you will need to set the router back up after performing this reset.

Also, if you know how to check the router's DNS settings manually, then you can change the DNS settings in the router to resolve the issue without resetting it. :P

Link to post
Share on other sites

charris here is a better set of instructions for you.....

Try this - It is general solution that works most times -

You may want to copy/paste this to notepad as you will disconnect from the internet for a while -

1. Very important: First disconnect your computer from the internet. Just Log Off- while you reset the router -

2. Router Reset: Next you must reset the router to its default configuration. This can be done by inserting something tiny like a paper clip end or pencil tip into a small hole labeled "reset" located on the back of the router. Press and hold down the small button inside until the lights on the front of the router blink off and then on again (usually about 10 seconds).

3. Reset the IP/DNS settings of your interent connection:

Download this Microsoft Item

4. Flush the DNS cache:

  • Click the Start logo in the bottom left corner of the screen
  • Click on Run or press Windows Logo+R
  • In the command window copy/paste the following:
    ipconfig /flushdns


  • Then hit enter and a black box will flash .
  • Exit the command window.

Thank You -

Link to post
Share on other sites

Hi, Well I did as you said but still no help.

For your information, I realized that i have my laptop available so I downloaded MalwareBytes onto that and then proceeded to update the laptop with no problem. (using the same router)

I have decided to forego any further investigation since it is taking too much time. I will learn to get along w/o Malwarebytes..

Thanks for your help.

Ron Baker

Same here. I will find something else to use instead of Malwarebytes.

Java, AVG, Windowsk, spybot....all update fine except this piece of software. I'm glad it was a free trial.

Link to post
Share on other sites

@ charris -

Your return of 72.21.81.133 lists These Sites as the content -

Not one of them are Malwarebytes - The link left by above was a known return link to Malwarebytes - I have tested it several times -

You do have an infection either in the router or your computer -

Thank You -

3 * * * Request timed out.

4 * * * Request timed out.

5 * * * Request timed out.

6 * * * Request timed out.

7 * * * Request timed out.

8 * * * Request timed out.

9 * * * Request timed out.

10 * * * Request timed out.

11 * * * Request timed out. This is not normal - I can return the link in 10 hops (maximum) from Australia -

Please see my results on page 2 -

Link to post
Share on other sites

For any persons interested , this is the results of the trace (from Australia) taken from the link above -

Please note the bottom highlighted item that shows I have connected to Malwarebytes updates -

Traceroute Malwarebytes CDN version 1.5

Fri 24/09/2010

8:02:57.48

Phase #1

Tracerouting: data-cdn.mbamupdates.com

Tracing route to mwbyte.vo.llnwd.net [117.121.253.254]

over a maximum of 30 hops:

1 2 ms <1 ms <1 ms mygateway1.ar7 [192.168.1.1]

2 15 ms 14 ms 15 ms lns2-loopback-0.Melbourne.netspace.net.au [203.17.101.66]

3 14 ms 15 ms 15 ms core1-ks-TenGigE-3-1.Melbourne.netspace.net.au [203.10.110.211]

4 15 ms 16 ms 16 ms te7-3.mel-pipe-bdr1.iinet.net.au [203.215.6.138]

5 28 ms 26 ms 28 ms gi2-1.mel-pipe-bdr2.iinet.net.au [203.215.20.139]

6 26 ms 26 ms 26 ms 203.215.20.106

7 36 ms 26 ms 26 ms p38622.syd.equinix.com [202.167.228.57]

8 29 ms 29 ms 29 ms data [117.121.253.254]

Trace complete.

DNS Info

Server: mygateway1.ar7

Address: 192.168.1.1

Name: data-cdn.mbamupdates.com

Address: 117.121.253.254

============================================================

Phase #2

Tracerouting: llnw.data-cdn.mbamupdates.com

Tracing route to mwbyte.vo.llnwd.net [117.121.253.254]

over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms mygateway1.ar7 [192.168.1.1]

2 15 ms 14 ms 15 ms lns2 [203.17.101.66]

3 15 ms 14 ms 15 ms core1 [203.10.110.211]

4 15 ms 14 ms 15 ms te7 [203.215.6.138]

5 28 ms 28 ms 27 ms gi2 [203.215.20.139]

6 26 ms 26 ms 26 ms 203.215.20.106

7 26 ms 27 ms 26 ms p38622.syd.equinix.com [202.167.228.57]

8 30 ms 29 ms 30 ms data [117.121.253.254]

Trace complete.

DNS Info

Server: mygateway1.ar7

Address: 192.168.1.1

Name: llnw.data-cdn.mbamupdates.com

Address: 117.121.253.254

============================================================

Phase #3

Tracerouting: edge.data-cdn.mbamupdates.com

Tracing route to gs1.wpc.edgecastcdn.net [68.232.45.133]

over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms mygateway1.ar7 [192.168.1.1]

2 14 ms 14 ms 14 ms lns2 [203.17.101.66]

3 15 ms 15 ms 16 ms core1 [203.10.110.211]

4 14 ms 14 ms 14 ms te7 [203.215.6.138]

5 26 ms 26 ms 26 ms gi1-0-5.syd-ult-core1.iinet.net.au [203.215.20.102]

6 26 ms 26 ms 26 ms as15133.sydney.pipenetworks.com [218.100.2.36]

7 27 ms 27 ms 26 ms edge.data [68.232.45.133]

Trace complete.

DNS Info

Server: mygateway1.ar7

Address: 192.168.1.1 - Note :(This is only my router IP address - Normal for most routers)

Name: edge.data-cdn.mbamupdates.com

Address: 68.232.45.133

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.