Jump to content

Error on installation v1.24


Recommended Posts

Hello i am getting error during installation:

C:\program files\malwarebytes' anti-malware\mbamext.dll

unable to register the DLL/OCX: RegSvr32 failed with exit code 0x5.

Click to try again, Ignore to proceed anyway (not recomended), or Abort to cancel installation.

If i ignore then install finishes but i get error on boot: unable to register the DLL/OCX: RegSvr32 failed with exit code 0x5.

if i try to install older version now i get the same errors.

Running on XP Pro SP3 with all updates

Any suggestions?

Thank You

Jacek

Link to post
Share on other sites

Jacek,

Can you uninstall the product, reboot the system, and reinstall the latest version. This should get rid of the error.

Marcin - and Jacek:

I've had the identical problem with installing, both with version 1.23 and now 1.24. I have uninstalled and reinstalled both versions, but continue to get the same problem.

I am running "Malwarebytes" on an AMD Athlon 64 3200 machine using XP Pro SP3, also with all updates.

After overriding this warning, in each case of installing (by ignoring the warning,) I run into other similar flags, as the application hangs during processing the complete scan about 10 minutes into the run and discovering one infection. Since the program hangs, have no way of dealing with this discovered and tagged malware.

Would like some workable advice on this problem, since know of one other person who has had the identical issue, so suspect it is not at all uncommon.

I was given such raving revues on this software that decided to try it out - even going so far as to dump both Ad-aware and Spybot.

Hope someone can fix this bug.

Thanks.

erico

Link to post
Share on other sites

  • 2 weeks later...

To the both of you having the issue:

erico: Are you able to figure out which file it gets to / what folder it is in before it actually hangs?

shulamit: Assuming you rebooted after you uninstalled the previous version, which version did you last have?

Link to post
Share on other sites

I have the very same problem on XP SP2 on one of my machines. On another, also XP SP2, v1.24 installs without a hitch. Here's what I've learned that may be helpful:

1. When the installation halted because it was unable to register mbamext.dll, I told it to ignore the error. It then continued to install flawlessly. It was able to complete a full scan. All that mbamext.dll appears to do -- when it is registered -- is provide a right-click context menu entry for scanning with Malwarebytes.

2. On a forum for a different product with the same problem, the cause for one person was lack of permission to modify the registry key(s) involved. Make sure you are logged in with admin privileges, but even that won't be enough if the registry key(s) permissions have been changed to restrict access. Perhaps someone from Malwarebytes would be kind enough to tell us which keys should be checked -- or better yet, post a reg file and instructions for manually registering mbamext.dll, if that's possible.

Link to post
Share on other sites

  • 2 months later...
  • 4 weeks later...
  • Root Admin

I'm reasonably certain I've found the solution to fixing this. Not certain what causes the issue though in the first place.

It's very late here right now and I still need to write up some documentation and do a little more testing but will try to post the fix some time this weekend.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.