Jump to content

Lost IP Address


Jake227
 Share

Recommended Posts

Hi all - I am suddenly unable to connect to the internet. After doing some playing around with it I realized that I no longer have an IP address for some reason. I have a comcast modem and a netgear wireless router. My internet works fine on my laptop - but not on my PC, so I know the internet connection itself is fine. Below is a list of things I have tried

1. Ran MBAM and it found nothing

2. Ran AVG and it found nothing

3. Tried going into internet options to repair my ip address and it could not complete.

4. I have also played around with some of the settings and tried manually entereing an IP address. This did not work - but I may not have done this correctly because I don't know exactly what to type in.

Link to post
Share on other sites

Did you try resetting the modem/router?

Yes - I just got off the phone with Comcast and I reset the modem and router. I also tried bypassing the router and Connected the ethernet cable directly from the modem to the PC, with no success.

Oh yeah, I'm running Windows XP and IE explorer for my browser if that helps.

Link to post
Share on other sites

Hi Jake,

Please use the "ADD REPLY" t_reply.gif button located at the bottom of the page when replying ;)

When you said you were playing around with it, what were you playing with?

Also, have you been infected recently to your knowledge?

Link to post
Share on other sites

Well, I guess its possible I have been infected and maybe that's why this is happening. I'm really not sure. Everything else works fine though.

I tried going into network connections > Local Area Connectons > Properties > TCP/IP Properties and tried to type in a different IP address and DNS server. That didn't work, so I just put it back at "Obtain IP address automatically" Right now it is set at 0.0.0.0

Link to post
Share on other sites

Hmm.

Are you on a second machine right now?

If you think you may have been infected, please follow the directions below. Otherwise, let's wait and see if someone else may have an answer for you, I have no idea what to do if resetting the router and the other things you did don't work. Comcast wasn't able to figure out what it was either, huh? :)

Please read and follow the directions here, skipping any steps you are unable to complete. Then post a NEW topic here.

One of the expert helpers there will give you one-on-one assistance when one becomes available.

Please note that it may take 48 hours or more for you to receive a response in the malware removal forum, as it is often busy at times. Please do not reply to your own post asking for help unless its been more than 48 hours since you originally posted, as this can make it appear as though you are being helped and take longer for you to get help.

If you are unable to do all or any of the steps in the link to the directions above, just post your problem into the forum I gave you a link to anyway and someone will be able to assist you.

After posting your new post make sure under options that you select Track this topic and choose one of the Email options so that you're alerted when someone has replied to your post.

Thank you ;)

Link to post
Share on other sites

I really have no idea if I have been infected or not - But I guess its a safe assumption considering that it used to work fine and then all of a sudden it stopped.

I have a laptop from work and a desktop that is my personal computer. I am on my laptop right now which works fine.

I will try your instructions and see if that works. But in the meantime I will continue to monitor this post and if anyone has ideas please let me know.

THANKS!!

Link to post
Share on other sites

Yes - I just got off the phone with Comcast and I reset the modem and router. I also tried bypassing the router and Connected the ethernet cable directly from the modem to the PC, with no success.

@Jake277: When you connected the desktop directly to the modem did you...

REBOOT THE DESKTOP COMPUTER

BTW: You *can* create a NEW network connection (even tho' you have one that is screwed up) by using the Network Connect Wizard and then changing from your current non-working connection to the new connection in NETWORKS to see if that fixes it as a last ditch effort. ;)

~Shy

Link to post
Share on other sites

I did reboot the computer when I connected it directly to the modem.

I'll try setting up another network connection and see if that works.

Make certain when you go into NETWORKS you click on PROPERTIES of the wireless that's not working and DISABLE it. Then make sure the NEW network connection you create is ENABLED in PROPERTIES of it. That's the extent of my personal experience with screwed Network connections which I have had a LOT of over the years. If you're still screwed please follow Mountaintree16's instructions about setting up a new topic and waiting for an experienced troubleshooter to answer your problem.

Thank you for trying what we suggested. :)

~Shy

Link to post
Share on other sites

Disable Internet Explorer Proxy Settings and Reset TCP/IP and Winsock

Disable Internet Explorer Proxy Settings and Reset TCP/IP

It is very important that these steps be carried out exactly as shown otherwise the fix will not work.

If you have any questions please ask before moving on.

  • Please start Notepad and using your mouse make sure you select and copy all the information below in the Code box into your new document.
  • Then save the file as "fixme.bat" to your Desktop
  • In the drop down box for Save as type: make sure you select All Files (*.*) and keep the quotes on the name as well. Then close the new file.
    @ECHO OFF
    reg delete "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /v ProxyServer /f
    reg delete "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /v ProxyOverride /f
    reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /v ProxyEnable /t REG_DWORD /d 0 /f
    reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /v GlobalUserOffline /t REG_DWORD /d 0 /f
    netsh int ip reset resetlog.txt
    netsh winsock reset catalog


  • On Windows XP you can double-click the file to run it.
  • On Vista/Win7 you need to Right click the file and choose Run as administrator to run it. With User Account Control on it should ask permission to run it. Click Yes
  • This will flash a black DOS box very quickly and go away, this is normal.
  • Restart your computer now.
  • Launch Internet Explorer and see if you can connect to the Internet.
  • Launch MBAM and check for Updates

Link to post
Share on other sites

^^^ Thanks Firefox - I tried that and with no success. I followed the instructions on the link posted above and I will be posting all of the logs in a new post tomorrow. However - I you have a plan B while I'm waiting to have the logs analyzed I'm all ears.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.