Jump to content

v. 1.46 Pro Updater Bug?


Recommended Posts

Hi;

Ever since updating to 1.46 on my Dell W7 Ult 64 PC yesterday, the popup balloon from the system tray notifying of a successful definitions update isn't working.

Everything was working fine in 1.45 (IOW I know how to program the scheduler).

I serendipitously was 1 of the first to update to 1.46 yesterday and, like many, ended up having to do a complete MBAM uninstall/cleanup/reinstall.

Even did the extra reboot some time later (which seemed to fix the missing date next to the definitions version in the system tray balloon when hovering).

But all seemed OK.

And, the hourly update checks are working, scans are working, right context menu is working, etc.

As recently as an hour ago, the requested flash scan after updating ran properly.

HOWEVER, I have tried several times to get the tick in the box for the updater scheduling to stick when selecting it to popup for a successful update.

So, even though (as of a while ago) the updates are happening and the requested flash scans are running, NO BALLOON.

No joy.

AND, having deleted my scheduler settings AGAIN and reset them AGAIN to try to get this to work, I now can't get even the "flash scan" option to stick.

FWIW, the options selected in the SCANNER scheduler do seem to be sticking (at least the boxes that are ticked are staying ticked).

No error message.

No problem with firewall exclusions.

I even tried turning off WinPatrol on my last attempt to reset the scheduler.

No joy.

SO, is this a bug?

Am I doing something wrong? (Should I try a reboot after configuring a "fresh" set of scheduler settings?)

Or do I need to try (as some have been advised to do) reinstalling 1.46 on top of itself, or (heaven forbid) ANOTHER uninstall/cleanup/reinstall?

TYIA,

daledoc1

Link to post
Share on other sites

Hi daledoc1 -

So far this is the only report of this kind I have seen - Take down the McAfee protection and do the full Un/Re install is my first thought -

You know the routine (or can find it quick enough) so I won't list it here - Do ALL the settings to the scanner while off line and prior to reactivating McAfee again - Then make sure all the exclusions are back in McAfee (as per FAQ) -

I was looking for GT500 to check this but that has not come about yet - If you see him on the board then PM him or AdvancedSetup -

Regards -

Link to post
Share on other sites

Also check your taskbar settings to make sure that it is set to show alerts from Malwarebytes' Anti-Malware (the Windows 7 taskbar allows hiding of icons and messages in the tray for running applications). You may also need to have it show the icon in order to get the alerts.

Link to post
Share on other sites

Hello:

Thanks for writing with your excellent suggestions.

@Noknojon: FWIW, I *did* temporarily disable the McAfee AV/FW during the install, even though I don't know that it's strictly necessary for this particular security suite. In general McAfee has been playing fine with MBAM. And all the firewall exclusions are fine (McAfee consumer products don't allow specific file exclusions in the AV, but I verified that the all the MBAM exe files have full permissions.)

@exile360: Yes, I verified that the W7 taskbar is set to show icon & notifications.

Well, it seems that the flash scan after update isn't working, either, according to my logs, even though that WAS working yesterday, while I was in the process of troubleshooting this.

(The hourly update checks DO seem to be working, and the defs ARE updating; all the SCANNER settings are also working , as far as I can tell.)

So, it seems to be only the balloon popup after updates and (more recently) the flash scan after updates.

Selecting the options just doesn't seem to stick.

Darn, I thought I got a clean install the other day. :-(

I'm heading out for a while.

When I come back later, I will do the whole uninstall/cleanup/reinstall (with FW & AV disabled) again and see how that goes.

Will report back then.

Thanks,

daledoc1

Link to post
Share on other sites

Hello, Noknojon and Exile360:

Well, I *think* I may be up and running again properly.

I printed out & followed all the usual uninstall/cleanup/reinstall instructions, including downloading fresh copies of the cleaner and the 1.46 installer.

The 1st time I did it, I got an MBAM error (18 I think?) when I tried to enable active protection after registering at the end of the process.

So, I repeated the whole process AGAIN, this time even disabling Carbonite.

Even though McAfee FW had retained the full program permissions from the the previous MBAM versions (see below), I made sure it and the AV modules were off completely through the 3rd and final reboot after the MBAM reinstallation.

Everything seemed OK: MBAM icon loaded in the system tray, program updated, GUI opened, was able to set the scheduler, etc.

I *think* the scheduler options seem to be sticking properly this time.

BUT, when I ran my first Quick Scan to test it, MBAM froze out ("not responding", but no error code) on: C:\Windows\Temp\Cookies\index.dat.

It eventually ran to completion (clean) after ~1 minute of delay.

So, I did the following:

1) Ran Windows disk cleanup and CCleaner to ensure all temp files and cookies were deleted.

2) Opened IE and cleaned all history there directly (FF automatically clears history when closing).

3) Ran a McAfee quick scan (clean, as had been a full scan at 0100 h this AM).

4) Ran a SuperAS quick scan (clean).

5) Ran an MBAM flash scan (no hangups, clean).

6) Scheduled an MBAM Quick Scan for ~30 minutes later, which just now ran fine to completion (clean).

I guess in retrospect I probably should have *deleted* the original McAfee firewall permissions before attempting to reinstall MBAM, and then let McAfee ask for them and/or manually set them, even though all 3 MBAM permissions were "full access"?

(With past MBAM versions, I had no conflicts with MBAM and it has actually played very well with MBAM much more easily than the Webroot suite on my other computer.)

So, this was a long way of saying that I *think* it's all working OK now.

The hangup during the 1st Quick Scan was unnerving.

Not sure why this turned out to be such a flail this time -- 1.44 and the update to 1.45 had gone seamlessly. This time was much more complicated on BOTH the desktop and the laptop.

Unless you suggest otherwise, I'll sit tight for now, monitoring for proper protection, scanning, scheduling and notification behavior.

I would eventually like to change my scheduled scan time to early morning, but I'm a bit gun-shy about making any changes at the moment. ;-)

Thanks very much for your assistance, as always,

daledoc1

Link to post
Share on other sites

As long as it's working I wouldn't mess with it. No need to try fixing what isn't broken :). As for the locking up/not responding, I get the same on occasion, but as long as the scan eventually does continue and it doesn't hang up for more than a minute or so you should be fine.

Please keep us posted should the issue return.

Thanks :)

Link to post
Share on other sites

Hi, exile360:

Everything seems to be working OK, as of the moment. :-)

***I wonder though, if it might be better to disable the updater setting to "automatically download and install program updates"?***

Since the last 2 program updates caught me (and others) by surprise, and since the "automatic" update to 1.46 seems to have been so problematic, might it be better to manually install program updates?

If a clean MBAM update install requires (at the least) temporarily disabling the resident AV application, then maybe allowing for automatic MBAM program updates isn't such a good thing?

(Some of the other standalone security apps & suites I use/have used provide a separate notification -- usually a popup balloon from the system tray -- with something along the lines of, "new software updates are available. install NOW or LATER?" At least that way, we know before we start the update process to be prepared for (at the least) a reboot or 2, AND for the need to take whatever "precautionary" measures are indicated in order to avoid installation conflicts, crashes, errors. I suspect I, and perhaps others, might have experienced a smoother update to 1.46, if we had been able to do so.)

All of which gets back to my "original" question/thread from last week: perhaps for starters a more NOTICEABLE way of alerting customers to the availability of the version/software update might be helpful?

Anyway, I am most appreciative of the excellent program, and the outstanding support here at MBAM.

Thanks very much,

daledoc1

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.