Jump to content

JavaRa problem


chimpy
 Share

Recommended Posts

I got a "blocked and disabled ad-on" notice from FF today about a java plug in so I decided to finally get round to removing all old copys with JavaRa, I clicked the link hxxp://prm753.bchea.org/software.html which then took me to hxxp://raproducts.org/, I DL's the zip and ran it and if found jre1.6.0 and removed it, then said it had made a log file which would be opened, it was not and nor can I file the file.

Also clicking the "remove older versions" just brings up what it had supposedly removed before, but I have alot of java in my ad-ons which is still there (consoles ect)

Is JavaRa still supported?

Link to post
Share on other sites

Make sure that All Java installs are removed in Add/Remove Programs while you have All browser sessions ended in Task Manager.

Firefox is notorious for not ending when you tell it to.

JavaRa has not been updated since July 15, 2009 as it has not needed to be as the newest versions of Java updates have been frairly clean but the latest Version 6 Update 20 fails to remove the previous Version 6 Update 19 files I have found out.

Link to post
Share on other sites

I have checked add/remove and I only have version 19 for java installed but in the FF ad-on list all previous consoles are still listed.

I tried JavaRa again but now its not working and I can't find it listed in Revo to uninstall it before I try a fresh install :)

Link to post
Share on other sites

This is AdvancedSetup's canned speech for updating Java:

Older versions have vulnerabilities that malware can use to infect your system. Please follow these steps to remove older version Java components and update.

  • Download the latest version of Java Runtime Environment (JRE) 20 and save it to your desktop.
  • Scroll down to where it says JDK 6 Update 20 (JDK or JRE)
  • Click the Download JRE button to the right
  • Select the Windows platform from the dropdown menu.
  • Read the License Agreement and then check the box that says: "I agree to the Java SE Runtime Environment 6u20 with JavaFX 1 License Agreement". Click on Continue.The page will refresh.
  • Click on the link to download Windows Offline Installation and save the file to your desktop.
  • Close any programs you may have running - especially your web browser.
  • Go to Start > Control Panel, double-click on Add or Remove Programs and remove all older versions of Java.
  • Check (highlight) any item with Java Runtime Environment (JRE or J2SE or Java 6) in the name.
  • Click the Remove or Change/Remove button.
  • Repeat as many times as necessary to remove each Java versions.
  • Reboot your computer once all Java components are removed.
  • Then from your desktop double-click on jre-6u20-windows-i586.exe to install the newest version.

  • After the install is complete, go into the Control Panel (using Classic View) and double-click the Java Icon. (looks like a coffee cup)
    • On the General tab, under Temporary Internet Files, click the Settings button.
    • Next, click on the Delete Files button
    • There are two options in the window to clear the cache - Leave BOTH Checked
      • Applications and Applets
        Trace and Log Files

      [*]Click OK on Delete Temporary Files Window

      Note: This deletes ALL the Downloaded Applications and Applets from the CACHE.

      [*]Click OK to leave the Temporary Files Window

      [*]Click OK to leave the Java Control Panel.

To test your Java Run-time, you may go to this page http://www.java.com/en/download/help/testvm.xml

When all is well, you should see Java Version: 1.6.0_20 from Sun Microsystems Inc.

Link to post
Share on other sites

Hi thanks for the reply's, I would remove them but the uninstall button is grayed out unless I run FF sandboxed and then of course once I restart FF as the changes were made sandboxed they just revert back which is why I was trying to use JavaRa as I presumed it would delete all the left over remnants from all Javas

Edit

I ran as admin and removed them (which is strange as that means sandboxie runs me auto as admin?) but the toolkit that FF disabled due to vulnerabilities is not showing a uninstall button. Why does JavaRa not remove these?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.