Jump to content

Problem when installing MalwareBytes Anti-Malware

Recommended Posts


I'm looking for some help with malware bytes anti-malware. I read that this is a great program so i downloaded it but get a problem when installing. It is fine when selecting the installation folder options and stuff, but when installing the files it comes up with the following error:

C:\Program Files\Malwarebytes' Anti-Malware\mbamext.dll

Unable to register the DLL/OCX: RegSvr32 failed with exit code 0x5.

This message appears when it gets to the "Registering files..." stage.

i am given the option to Abort, Ignore or Retry. Retry brings up the same error. This keeps happening after restarting the system. Also tried downloading it again, same thing happens.

It is a Windows XP SP2 system.

I have not had problems like this before. A couple of weeks back i was messing around with the registry (never messed with it before) to get rid of a worm that wouldnt let me see the hidden files and folders - i followed a guide i found on the internet, which worked perfectly, and have not had problems since.

Other programs such as Avira Anti-virus, Super Anti-Spyware, CCleaner, and some games which i installed before MBAM but after altering the registry installed completely fine. I am worried that there is something wrong with the registry that i cant fix B). I havent used CCleaner to clean the registry or anything, only used HijackThis to get rid of the USB drive worm. Will i have to use system restore? never used that before.

Thanks in advance for any help. B)

Link to post
Share on other sites

Exit code 0x5 stands for "Access Denied." Make sure that you're running as an Administrator on your computer, although I'm guessing that you are based on your post.

It's possible that the permissions on some of your registry hives have been modified. This blog entry has a good set of instructions on how to reset them.


Link to post
Share on other sites

hi, thanks for helping B)

I tried following those steps KB3LWJ. the tool seemed to work but the problem still occurred, even after restarting the system, so i selected ignore. it works fine, thanks rubber duck ;)

Dunno what a shell extension is, googled it, still dunno lol, but guessin its just that i wont be able to scan stuff from the context menu?

Also, took a couple of screenshots when i ran the SubInACL tool that might be of interest to you:


Took this one shortly after starting the tool. I was wondering what the "Failed 3" bit was all about, i guess this is the problem?

Also, why is there something in the registry called "Secrets"? What does that do?


Took this one just after the above screenshot.


This is a screenshot of the last things that appeared in the command line window.

anyways, program is installed and working, thanks again :lol:

Link to post
Share on other sites

Dunno what a shell extension is, googled it, still dunno lol, but guessin its just that i wont be able to scan stuff from the context menu?

Exactly. You won't be able to right-click and scan. Not a big deal though, as MBAM detects things best doing a Quick Scan of your entire computer anyway.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.