Jump to content

USB broadband dongle disabled since virus hit me


Recommended Posts

Hi - I wondered if anyone had experience of losing connection with a '3' network broadband dongle after clearing a virus? Witht the fantastic support from here I have cleared the Antivirus XP malware off, and everything is back to normal except I can't get my broadband dongle to work. Assumedly a setting has been changed with all the messing about. It finds the network but reports it cannot make a connection. I have checked it's allowed access by the firewall, I have checked USB sockets are not being turned off to save power, I have tried to ensure that the same COM port is being used wherever the dongle is seen, but no luck.

Could it be something simple / stupid I'm missing? Quite possible lol

Steve

Link to post
Share on other sites

Hi again and thanks for the suggestion. I'm looking at the link which says "Here is a Windows installer to create the IP Policy shortcuts. It basically runs the REG command line tool and sets the registry values or removes them.", and wondering if this could be worth trying, but I'm not strong on networking in general. I've done a lot of digging on the internet and this issue arises a lot but never seems to be solved! It appears to be happening because my Remote Access Connection Manager service won't start (called RASMAN I think), and when I try to start it I get an error code?

I've run Scannow and it seems to have repaired some system files, but I don't know which.

I have tried fixes from Microsoft's site, uninstalled and reinstalled my modem a zillion times.

I am dreading a reinstall of XP, but it looks like this is the only solution. Is it possible to do a repair of the XP files that will not delete my photos, email addresses, apps etc?

Link to post
Share on other sites

  • Root Admin

Yes it's possible to do an in-place repair of XP. You should probably seek advice in the PC Help forum for that type of help though and not here in the General forum.

Give this a try and see if it helps or not.

Click on START - RUN and copy / paste the entry below into the run line and click OK

CMD /C NETSH FIREWALL RESET

Click on START - RUN and copy / paste the entry below into the run line and click OK

CMD /C NETSH int ip reset c:\resetlog.txt

Click on START - RUN and copy / paste the entry below into the run line and click OK

CMD /C netsh winsock reset catalog

Update and Scan with Malwarebytes' Anti-Malware

  • Start MalwareBytes AntiMalware (Vista users must Right click and choose RunAs Admin)
  • Please DO NOT run MBAM in Safe Mode unless requested to, you MUST run it in normal Windows mode.
    • Update Malwarebytes' Anti-Malware
    • Select the Update tab
    • Click Update

    [*]When the update is complete, select the Scanner tab

    [*]Select Perform quick scan, then click Scan.

    [*]When the scan is complete, click OK, then Show Results to view the results.

    [*]Be sure that everything is checked, and click Remove Selected.

    [*]When completed, a log will open in Notepad. please copy and paste the log into your next reply

    • If you accidently close it, the log file is saved here and will be named like this:
    • C:\Documents and Settings\Username\Application Data\Malwarebytes\Malwarebytes' Anti-Malware\Logs\mbam-log-date (time).txt

Then post back the MBAM log

Link to post
Share on other sites

Hi again! I have input the commands as instructed and I'm afraid no improvement - I connect normally using my laptop's wireless card but the broadband dongle still gives "the connect attempt failed - check your settings".

As a matter of interest, I've just discovered the Event Log in Control Panel. When I try to start my dongle it doesn't report anything good or bad - just nothing.

Updated MBAM and run a quick scan - it found nothing, but results as follows;

Malwarebytes' Anti-Malware 1.45

www.malwarebytes.org

Database version: 3945

Windows 5.1.2600 Service Pack 3

Internet Explorer 6.0.2900.5512

02/04/2010 11:20:19

mbam-log-2010-04-02 (11-20-19).txt

Scan type: Quick scan

Objects scanned: 106068

Time elapsed: 4 minute(s), 47 second(s)

Memory Processes Infected: 0

Memory Modules Infected: 0

Registry Keys Infected: 0

Registry Values Infected: 0

Registry Data Items Infected: 0

Folders Infected: 0

Files Infected: 0

Memory Processes Infected:

(No malicious items detected)

Memory Modules Infected:

(No malicious items detected)

Registry Keys Infected:

(No malicious items detected)

Registry Values Infected:

(No malicious items detected)

Registry Data Items Infected:

(No malicious items detected)

Folders Infected:

(No malicious items detected)

Files Infected:

(No malicious items detected)

I really am at my wits end with this!

Link to post
Share on other sites

In case it's of help to anyone similarly afflicted....I searched everywhere and tried every registry fix etc etc I could find, but could not get the dongle to connect. So I did a repair reinstall of XP Home - you need a disc with Service pack updates that match your current installation, and the Windows validation code - and it worked great. All files / apps remained intact, and the dongle now works! The problem was definitely caused by the Rasman service not being able to start, but I just could not find out the reason.

Hope this helps someone in the future.

Steve

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.