Jump to content

Strange the extension might be blocked by Apple


Chas4

Recommended Posts

All of a sudden I can't add the extension to the toolbar in Safari (yet it is still installed)

image.thumb.png.a31304aef14394f2ebb0f676aa720634.png

image.thumb.png.b42a120b195e3519a2554608253c51e9.png

Link to post

Last computer restart was a few days ago (due to an old bug in discord that causes a denial of service attack from its crash bug, discord has known about the bug for at least 2+ years)

Link to post

Restarted Safari and it still can't be loaded

Link to post

macOS 11.7.6 & Safari 16.4.1

Link to post

Scam blocker has a weird bug where the database gets corrupted so it is not check but I am missing one of those image.png.5c1988cc914ce12268275226b9a3a4e5.png

Link to post

Only 3 used to have 4

Link to post
17 hours ago, Chas4 said:

If you can’t turn on extensions in Safari https://support.apple.com/en-us/HT211233

It was not there in Safe Mode also

Link to post
  • 3 weeks later...

image.thumb.png.2d49350c6365d12572c6f8f539d40da5.png

Safari 16.5 update out today and I get this.

I am able to update the database for the first time in a month

Edited by Chas4
  • Like 1
Link to post
2 minutes ago, ceckelberry said:

Thanks for update! Looks like it was a Safari issue then, as our developer on this could not reproduce.

I think Apple might have blocked it for some reason, as I was not able to enabled it in safe mode also.

It showed that prompt about 5 to 7 minutes after opening Safari 16.5, tho weird as it is not a new extension at all

Edited by Chas4
Link to post
  • 1 month later...

It is gone again (woke up form sleep (put in sleep due to power outage) and the main extension is missing)

image.png.8551ee9bc82bc53b74b99ed5d262df53.png  image.thumb.png.20c04aba1dcc56335a2057664d8a4fb4.png

Edited by Chas4
Link to post

Safari debug menu

image.thumb.png.e0921295a4357c921058a88430a1e930.png

Triggers

image.thumb.png.6f488c3c7b8f1729fe05884927d5ac87.png

But the extension does not turn on

 

Link to post

Strange Safari 16.5.2 allows it to be enabled again, and then asks if I want to all the extension on every site.

Link to post
  • 5 months later...

@ceckelberry

Looks like it happened again and Malwarebytes has been blocked, still have the bug with the databases getting corrupted  (forum bug has this stuck in bold, unbold does not work at all)

Link to post
29 minutes ago, ceckelberry said:

@Chas4 Sorry to hear that. Can you share your logs please(there is a button on the Support page in the extension now)? 

@ceckelberry The version I have has no log button, and yes it is installed from the App Store (it is current for the version of Safari I have here)

image.thumb.png.c43f798d7e2c58f6ebe9987e290eca18.png 

The main one that controls the button in the area around the address bar is disabled by Apple it looks like, I have to disable 2 of the 3 parts due to corrupted databases as I would get a 200% CPU spike when starting Safari.

What seems to trigger it is putting the machine to sleep for about 3 hours

 

Link to post
6 hours ago, Chas4 said:

The main one that controls the button in the area around the address bar is disabled by Apple, it looks like,

Hello @Chas4 and @ceckelberry:

This likely is where to begin your path for a solution to exposing the “Download Debug Logs” phrase/hotlink in MBG for Mac 2.3.0 supporting Safari 17.2.1.

My attached .png does visually show its presence.

HTH

Screenshot 2023-12-21 at 19.02.51.png

Edited by 1PW
Link to post
52 minutes ago, 1PW said:

Hello @Chas4 and @ceckelberry:

This likely is where to begin your path for a solution to exposing the “Download Debug Logs” phrase/hotlink in MBG for Mac 2.3.0 supporting Safari 17.2.1.

My attached .png does visually show its presence.

HTH

Screenshot 2023-12-21 at 19.02.51.png

That works on newer version of macOS as that requires macOS 12 or higher, stuck on an older version of the extension (only way to upgrade would be a 3rd party tool to upgrade macOS).

That button is completely gone and I can't readd it not sure if macOS or Safari has blocked it (as you can see I have had this on and off most of the past year

@1PWUnless you know where to manually grab the logs from

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.