Jump to content

Very Slow Chrome Page Loads with Browser Guard Enabled


Go to solution Solved by ceckelberry,

Recommended Posts

Noticed this after Chrome's latest update to version 112.0.5615.87 (64-bit). I can pinpoint the issue directly to Malware protection being enabled. The page load on Chrome is very slow to the point it would occassionally freeze for a few seconds. Once disabled, Chrome page loading returns to normal. I'm only experiencing this issue on Chrome. The only two other browsers I use are FireFox and Opera. Not of which are displaying this issue. I am experiencing this issue on both my desktop pc and laptop.

The exact settings I have right now on Browser Guard,

Protection Settings:
-Ads/Trackers -> Off
-Malware -> Off
-Scams -> On

App Settings:
-All Protection Settings -> On
-Ads/Trackers -> Off
-Malware -> Off
-Scams -> On
-gTLD Domains -> Off
-Show Block Count -> On
-Advanced Skimmer Protection -> On

  • Like 1
Link to post

I am having the same problem/issue as those above.  Running Google Chrome version 112.0.5615.121 64-bit and Malwarebytes Browser Guard 2.6.0 (I have Malwarebytes premium so not the free version of Malwarebytes Browser Guard).  With Browser Guard enabled, text will load but not pictures for about five seconds or so.  Turn it off and it is instant like it has been for years.  Browser Guard has no effect on Edge.  Edge is instant on my system, regardless of number of tabs opened up, etc...  Hope a solution is found for this soon as I have always been a Chrome user.  

  • Like 2
Link to post
  • Staff
  • Solution

This issue is only affecting Chrome (not Edge), we are still investigating why.

I'm curious to hear if updating to the latest Chrome 112.0.5615.121 solves the issue as @IanH pointed out. This was an urgent update from the Chrome team.

 

If that doesn't work, doing a factory reset of Browser Guard has been reported to resolve the issue.

To do so:

  • Open Browser Guard 
  • On the top right, click the 3 vertical dots
  • Click "Support"
  • Click "Factory Reset"

If anyone is able to share logs and upload to Box while experiencing the issue, that would be greatly appreciated.

 

 

Edited by AdvancedSetup
Corrected font issues
  • Thanks 4
Link to post
17 minutes ago, ceckelberry said:

This issue is only affecting Chrome (not Edge), we are still investigating why.

I'm curious to hear if updating to the latest Chrome 112.0.5615.121 solves the issue as @IanH pointed out. This was an urgent update from the Chrome team.

 

If that doesn't work, doing a factory reset of Browser Guard has been reported to resolve the issue.

To do so:

  • Open Browser Guard 
  • On the top right, click the 3 vertical dots
  • Click "Support"
  • Click "Factory Reset"

If anyone is able to share logs and upload to Box while experiencing the issue, that would be greatly appreciated.

 

 

Ceckelberry, 

Doing the factory reset of Browser Guard worked and now Chrome is back to running like it should.  Thanks!

 

  • Like 3
Link to post

just came to say i was also experiencing this except on opera gx (which is chromium based i believe?)

it was driving me insane i thought it was my gpu that needed to update or lack of memory until i just reset my browser's profile and started from clean, checking each extension

and lo and behold it was malwarebytes browser guard extension

i couldn't load image heavy websites (like amazon for instance) and if it loaded it would take forever otherwise it'd pretty much render my browser frozen until i task manager killed it

not sure if i got the debug logs before i tried ceckelberry's suggestion of factory resetting the extensions (which worked) but i'll upload my logs as well just in case!

BG-Logs_v2.6.0_2023-04-23_14837.txt

Link to post
  • 3 weeks later...
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.