Jump to content

USB Port Problem


Recommended Posts

Hello friends,

Please can someone help me?

I have a problem with one of my USB ports which is not working. I am operating Windows XP on a HP laptop.

I've tried different peripherals but does not make a difference - it's seems it does not register the peripheral or power it.

I've looked at 'Device Manager' and there is no 'exclaimation/question marks' next to the USB part.

I look forward to help....

THANKS SO MUCH!! <_<

Link to post
Share on other sites

Greetings ;)

Use the Device Manager and right click on your Host Controller entries one by one and select Uninstall and don't reboot until you've done that to the last one (there's usually 2-4 of these). Once you reboot open Device Manager again and right click on the name of your PC listed at the top and select Scan for Hardware Changes. It should now try to install the drivers again. If that doesn't work, let me know and also post back with the chipset manufacturer of your motherboard (ie Intel, ATI, NVIDIA etc).

Link to post
Share on other sites

Yep, that's what I needed to know ;) . It's Intel.

Please do the following now:

  • Download the Intel Chipset Software Installation Utility from here and save it to your desktop
  • Then copy and paste the following text in the Code box exactly as written into notepad (not wordpad or any other text editor):
    infinst911_autol -OVERALL -OVERIDE


  • Once you've done that click on File and select Save As...
  • In the Save dialogue box click on the drop down menu next to Save as type and select All Files
  • Name the file Install.bat (the .bat extension is very important)
  • Save the file to your desktop and double click it to run it.
  • It will take a while to install the drivers so please be patient
  • Once it's complete, reboot your computer and test the port again

Link to post
Share on other sites

Are you still with us? If so, I've got a couple of other options to try if the reg fix doesn't work:

Here's another possible fix, but be warned, if you use a USB mouse and/or keyboard this could be a problem so you should use a PS2 (the round purple and green connectors) mouse and keyboard if you have them:

Remove and reinstall all USB controllers:

  • Open the Device Manager
  • Expand Universal Serial Bus
  • Right click all devices listed there and select Uninstall
  • Reboot, then reinstall the Intel chipset drivers I had you download earlier

Instructions taken from here.

Another possible fix would be running this Microsoft Fix it and rebooting to see if that solves it.

Here's a list of MS Knowledgebase articles regarding similar problems:

Link to post
Share on other sites

Ok, no problem ;) .

If none of that fixes it, then it will be time to start troubleshooting hardware problems, but on a laptop they're so difficult to take apart and put back together that you'd likely have to take it to a tech shop to have it done.

Post back with how it went and also please provide me your exact model number located on the bottom of your HP on a sticker, it will be something similar to dvXXXXus.

Thanks :)

Link to post
Share on other sites

  • Root Admin

While the computer is booting you can probably press F10 to get into the BIOS - though being a laptop it probably does not support turning on or off different USB ports. It could be that this port is just plain broken and have nothing to do with software.

You might try downloading this tool and see if it can provide any feedback on the issue.

Nirsoft USBDeview v1.45

usbdeview.gif

Link to post
Share on other sites

AdvancedSetup is most likely right, there's a possibility it could just be plain broken.

Here's the information directly from HP

Entering the BIOS Setup utilityTo open the BIOS Setup screen:

  1. Turn off the computer and wait five seconds.
  2. Turn on the computer.
  3. When the first screen displays, immediately press the F10 key if your computer was built in 2006 or later (came with Vista). Press the F1 key if your computer was built before 2006 (XP or earlier). Press the key once every second until a BIOS Setup utility screen opens.
    NOTE: On some Compaq Presario computers (before 2002), press the F10 key at the logo screen.
  4. Use the keyboard to move through the menus.

Link to post
Share on other sites

A BIOS update is available from HP on the product's download page here, although an unlikely fix, it may solve the issue. If you've tried all the steps we've posted without success then it's likely a hardware problem and you'd need to either contact HP if it's still under warranty or take it to a repair shop, who would need to likely order a new motherboard from HP which can unfortunately be quite costly ;) .

Link to post
Share on other sites

I'm sorry to hear that :) . I believe we all suspected as much but wanted to exhaust all other possibilities first, as hardware is the most costly in this case. Hopefully that's the only problem that will arise and your other ports and motherboard components will continue to function properly. Also, remember what I said about the warranty, if it is still under warranty of any kind, this issue will be covered and it won't cost you anything to get the problem repaired.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.