Jump to content

update problems, desktop

Recommended Posts

Different sort of problem, but it's with the updater, and this has also happened 4 times, two of those times being today. This is more serious than with my laptop, as I end up having to hard boot the system, which is not a very nice way to have to treat your computer.

I manually update the Malwarebytes, it connects, runs the update, and then the message window appears saying that the program has been successfully updated from one version to the other. The window won't close when I try to close it. Then I am generally allowed one mouse click before the entire system freezes solid. The mouse is movable, but nothing responds, and I cannot bring up task manager. The system requires hard booting. When the system is restarted, Malwarebytes appears to be updated and functioning.

The second time I manually updated today, I got the 732 (0,0) message (which didn't happen the other 3 times). I tried again and the update ran, then the freezeup as indicated above. Nothing shows up in event viewer.

I'm noticing the log doesn't actually say the update was successful. Is there some way to purge the database and start over again so I can be sure the database isn't corrupted in some way? I guess the next step is a total uninstall, cleanup, and reinstall? I'm running a scan right now, but I'm not sure I can trust the results if I'm not sure if the database is OK or not.

I'm using Malwarebytes 1.41, paid version. The computer is running XP Media Center Edition 2002 SP2. It has an ethernet connection to a router, and I'm using the Windows Firewall and AVG Free 8.5.423.

Link to post
Share on other sites

Yes, it is possible to do so <_< . However, MBAM will let you know if the DB is corrupt as it's pretty sensitive to it. That being said, you can follow these instructions to purge the DB (just make sure MBAM is NOT running when you try to delete the DB):

For Windows XP:

  • Please copy and paste the following text in the Code box exactly as written into notepad (not wordpad or any other text editor):
    del "%AllUsersProfile%\Application Data\Malwarebytes\Malwarebytes' Anti-Malware\rules.ref"

  • Once you've done that click on File and select Save As...
  • In the Save dialogue box click on the drop down menu next to Save as type and select All Files
  • Name the file 703fix.bat (the .bat extension is very important)
  • Save the file to your desktop and double click it to run it.

Once that's done, open Malwarebytes' Anti-Malware again and it will show an error and ask to update. Make sure you are connected to the internet and allow it to do so.

You can also delete the database file manually, but since the folder is hidden I prefer using a batch file to make accessing it easier :)

Link to post
Share on other sites

OK, thanks. That does look a little scary, though. <_< Well, I'm feeling a bit intimidated anyway. Maybe I'll just trust MWB to tell me if the database is corrupted for now and keep this as a possibility somewhere down the road, if necessary. It's good to know, anyway, that MWB does notify the user if there's something wrong with the database. (Just another reason for MWB to be one of my favorite programs!)

Thanks again for the super-fast responses!

Link to post
Share on other sites

You're welcome <_< .

As I said, you can do it manually as well:

Show Hidden Files and Folders:

  • Click Start and select My Computer
  • Click the Tools item from the menu at the top of the window (if you don't see Tools press the Alt key on your keyboard and it will appear)
  • Select Folder Options
  • Click the View tab and make sure Show hidden files and folders is selected under Hidden files and folders
  • Next, uncheck the box next to Hide protected operating system files (Recommended)
  • Then, uncheck the box next to Hide extensions for known filetypes
  • Click Apply then click OK

Then go to C:\Documents and Settings\All Users\Application Data\Malwarebytes' Anti-Malware and delete the rules.ref file, as I said though, be sure MBAM isn't running (right click the tray and select Exit to kill the Protection Module), otherwise it probably won't let you delete the file. Then just open the scanner (mbam.exe) and it will tell you there's a problem with the database and ask to download a new copy, just let it do so :) .

Link to post
Share on other sites

You're welcome :) . That's where it is in XP, but in Vista and 7 the location is different, the drive letter is obviously different as well if Windows is installed on a different drive, that's why I wrote the batch file the way I did, as it will work regardless of the OS version and which drive Windows is installed on <_< .

Link to post
Share on other sites

The update problem occurred again today for the third time. So I found the rules.ref file, exited MWB, and deleted the rules.ref file. I then restarted MWB via the desktop icon, and it immediately said it didn't detect a database, did I want to download one. I said yes. It downloaded and installed, I got the success window, and things didn't freeze up this time. (Up to this point, it had frozen my entire system each time I ran the update today.) I had to click on the start protection button in MWB to get the real time protection going again.

I remember with other versions if something went wrong with downloading the database, you ended up with no database at all, so I was kind of relieved when that seemed to change. However, it does appear that there was a little problem with the database after all, as clearing it and starting over seems to have solved the problem. I did make those changes to AVG, but I didn't reboot immediately after I changed AVG. I don't know if that was required for the change to 'take' or not. A reboot has been forced since, however, by MWB freezing up my system again.

I'll see how it goes, anyway, and report back if anything changes.

(Maybe a button could be added within the program to purge the database if this turns out to be a common issue? It wasn't a big deal for me to navigate to the rules.ref file once I knew the name of the file to look for and where to look for it because I don't hide any of my files and folders anyway, but others might have a problem with it.)

Link to post
Share on other sites

Well, I thought it was fixed. Had one episode where the computer froze up for no apparent reason, and then went almost 2 days and tonight it happened again with the update issue. This time I uninstalled MWB and used the cleanup tool as well. I reinstalled, and we'll see where it goes from here.

I'm reading about other people having problems with the update, but their problem is of a different nature.




I did have the 732 error once, and believe me I would LOVE to have any of the other errors instead of what is happening to me. My particular problem, which results in my having to hard boot, could actually lead to file corruption, so this really can't continue.

My next step, if this doesn't work, will be to try that .exe in the first link.

Maybe it's time to rattle some cages at the AVG Free forum, as well. Since I've paid for MWB, and if AVG isn't going to work with it, then AVG is going to have to leave, I'm afraid. It would be a shame because AVG has been stable and I really hate changing security software. But this just can't continue or something else is going to get wrecked here.

Link to post
Share on other sites

Good morning, Ron. :)

My OS is Windows XP Media Center Edition 2002 SP2, 32 bit, and I am using AVG Free 8.5.423. Windows XP Firewall behind a hardware router, no other resident security software running, just AVG and Malwarebytes. I ran the MWB update this morning and I had no problem. I was thinking of adding the rules.ref file to AVG's list of exceptions and I'll try that if the problem happens again to see if that works. I also dropped a note on the AVG free forum advising them that some Malwarebytes users were having issues. I know AVG's developers do read the posts there, although they don't 'officially' offer support for the free product.

Thanks for looking into this.

Link to post
Share on other sites

  • 2 weeks later...


Unfortunately, I've started having the same problem with the update again. After nearly 8 days problem-free, I thought it was fixed. But then it happened again Nov 12th. Once I got the computer rebooted, I deleted the rules.ref file and ran the update again. When I checked AVG's exception list, I saw that I didn't have all the recommended items from the sticky added. I was missing zlib.dll and mbamtext.dll, and maybe a couple of others as well. I updated the list. I thought things were OK until just tonight. So this time, after having to hard boot the computer to get it working, I did the following:

Deleted and re-entered those items in AVG's exception list.

Uninstalled and reinstalled MWB.

Rebooted to complete the installation, as MWB said that needed to be done.

Ran the update.

My ID and key were already in the program, so all I had to do was start the real time protection.

I guess if this doesn't work, I'll try disabling AVG's resident shield prior to running the update.

I suspect AVG is not long for this particular computer anyway, since it looks like AVG is going to pull the plug on 8.5 and I'm not impressed with what I'm reading about AVG 9.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.