Jump to content

Malwarebytes and Windows Update Glitchy

Recommended Posts

Greetings and happy March 1 🌄

The title might also be: "Some system issues require your attention", not true.

Throughout the month of February, my dashboard has been giving me false messages about Windows Updates. Every day I check for Windows updates manually, download, install and run a quick scan, before I start using the desktop. MB dashboard opens to the message about system issues. Viewing details takes me to another window which shows Windows updates in RED. Viewing details there opens up Windows Update, which always shows the update status as GREEN. At first, I thought this is so small, I don't want to bring it up. As time has gone on, I've changed my mind. 

After a clean up and update of my system recently, I'm surprised this has persisted. I don't have any other "issues" ; no malware or infections of any kind. Is there some setting I've missed?

Premium version 4.5.22, licensed and up to date.

Thank you for looking at this.

Screen 1.JPG

Screen 2.JPG

Screen 3.JPG

Screen 4.JPG

Link to post
Share on other sites

  • Root Admin

It looks like your version may not be up to date. @NewTricks

Please do the following.

Please save the installer to your system.

MB4 Offline Installer

Then close all browsers and applications and install Malwarebytes over the top of your current installation.


Then restart the computer and check for program updates

Click the small gear icon



Then click on the General tab. Next, click on the Check for updates button



Then run a new Threat Scan and post back that log and let us know if the Security Advisor is still having an issue or not.

Thank you


Link to post
Share on other sites

On 3/1/2023 at 5:57 AM, NewTricks said:

... Throughout the month of February, my dashboard has been giving me false messages about Windows Updates. Every day I check for Windows updates manually, download, install ...

Screen 3.JPG


Hi NewTricks:

Have you disabled automatic Windows Updates?  If so then perhaps that's why Security Advisor is warning you that you have a problem with your Windows Update settings.

I don't know what Windows OS you use (I'm not authorized to open attached mbst-grab-results.zip files) but your Windows Update screenshot looks like you might have Win 7 SP1 or Win 8.1.  If that's correct then go to Control Panel | System and Security | Windows Update | Change Settings | Important Updates as instructed in the ComputerHope article How to Enable or Disable the Windows Automatic Updates and see if you've selected "Never Check for Updates (not recommended)".   If you deliberately disabled your automatic Windows Updates you should be able to dismiss / hide this Security Advisor warning (see Porthos' post <here>) so it doesn't nag you every time you restart your computer.
Dell Inspiron 5584 * 64-bit Win 10 Pro v22H2 build 19045.2604 * Firefox v110.0.1 * Microsoft Defender v4.18.2301.6-1.1.200000.2 * Malwarebytes Premium v4.5.23.241-1.0.1927 * Macrium Reflect Free v8.0.7279


Edited by lmacri
  • Like 1
Link to post
Share on other sites

Hi @lmacri sorry for the delay-early morning work,

I have Windows 7 Home Premium and I have never disabled Windows Updates but configured to download updates "but let me choose when to install them."  The article and @Porthospost were very helpful.  Not being nagged appeals to me. 🙂

I'll give this 24 hours for confirmation I've done it right.  

My comment "every day I check for Windows Updates manually" is me being hyper-vigilant.



Edited by NewTricks
  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.