Jump to content

Activate License - Please check your internet connection and try again.

Recommended Posts

I am trying to activate Malwarebytes Premium using key that was emailed to me. My internet connection is fine (tried both ethernet and wifi connections), but for some reason I get Network error prompt message "Please check your internet connection and try again." I tried on both of my Mac computers and both yield the same error. Any help to activate is greatly appreciated.

Screen Shot 2022-10-19 at 9.53.05 PM.png

Link to post
Share on other sites

  • Staff

The most common cause for this, if your internet is working normally, is that something on your system is blocking communication with our servers. Several of the important systems, that handle things like licensing, software updates, database updates, etc, are at internet domains ending in "mwbsys.com". Make sure you don't have any kind of outgoing firewall (Little Snitch, Lulu, or some network filter in any other antivirus programs you may have installed) that is blocking these domains. If you don't, you may also want to check your hosts file (located at /etc/hosts) to ensure they're not blocked there. (Let us know if you need assistance checking the hosts file.)

For more information about the network access requirements for Malwarebytes for Mac, see:


Link to post
Share on other sites

Thanks for the response @treed; unfortunately still not working.

I don't have any other network filter or antivirus programs installed. I even tried tethering to phone, to eliminate local network variables. Additionally, I turned off firewall altogether on the Mac. My /etc/hosts file is generic with no additions (copied and pasted contents below). For reference, I am running this on Mac OS 12.6 (Monterey) and I do have Full Disk Access enabled for Malwarebytes Protection.app. Any other ideas as to what I can try to get this license activation working?


# Host Database
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##    localhost    broadcasthost
::1             localhost


Link to post
Share on other sites

  • Staff

Hmm, that's very odd, then. Are you trying to activate using a license key or a Malwarebytes account login? If it's with a key, don't post it here, but if you send it to me via a direct message (put your mouse over my name or avatar at left, then click the Message button in the overlay that appears), I can check it to make sure there's nothing strange about the license itself.

I don't think that's likely, given the error message, though. The other thing you may need to do is collect some information using our Support Tool:


You could also send the file it generates to me via direct message, rather than posting that file here.

Link to post
Share on other sites

@treed I tried to activate using license key, as account login option wasn't available. I did try something different that got it to work, which I will explain here in case someone else runs into same problem.

Upon purchase, I clicked on download from email, which downloaded the Malwarebytes-Mac- application install package. This version of the application does not allow you to install using login account (only the key). I logged into my.malwarebytes.com/subscriptions and tried the "Add a device" option from there, since it launches the application and plugs in the key (which still gave me the network error depicted in screenshot above, so I knew it wasn't syntax error on key value). However, on a whim, I decided to try and download the app again, this time from the "Add a device" screen. This way I can compare version of app. The interesting thing is that version was different (Malwarebytes-Mac- So through process of elimination, that version (4.16) appears to be newer than the version I downloaded from the email I received from Malwarebytes yesterday (4.14). So I installed the 4.16 version and that one provided me with option to activate using account login. I proceeded to go that route and it successfully activated. Additionally, when going to Settings --> My Account, I can clearly see it pulled the key down correctly (same key that was emailed to me by Malwarebytes).

So long story short, make sure to use the 4.16 version, which allows activation using login account credentials. Hopefully this helps anyone else that may run into same problem.

Link to post
Share on other sites

  • Staff

Ahh, yes, I didn't think of that, but there was a problem with 4.14 that caused it to lose contact with the licensing server. Updating to the newest version would fix it.

Was this from an old purchase, or did you receive this e-mail recently? If it was recent, and it had a link to 4.14, I'll need to look into that.

If not, make sure not to use links in old e-mails to download. You can always get the very latest version from:


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.