Jump to content

Windows security center won't register Malwarebytes


Recommended Posts

Hi, I have a Lenovo Legion 7i, 64GB ram, Nvidia 3070 Max-P, 11800H CPU, Windows 11 Home. 

Malwarebytes premium will NOT register in the Windows security center for me either. I am noticing a few topics about this these days.

I bought this computer 6 months back on a blowout sale, but I only started using it yesterday as it was my backup computer and my main Razer has developed a major hardware fault (the one I have been using my Malwarebytes 1 of 2 seat license on for 7 months) and has to be sent in so now the Legion is the only computer I have.

My point being this is a new setup.. Now yes, Lenovo do include the dreaded Norton, but I uninstalled that first and foremost, did all my windows updates, then installed MWB.

No matter what, Defender is still running, completely unaware of MWB's existence. I am worried about conflicts of course but in any case this should not be happening. It was no problem on the Razer, also win 11 home and same CPU and GPU (but less ram at 32GB). That said, I hadn't thought to check it in the last couple months as it was always fine prior. Who knows if that is doing the same thing now with the latest MWB updates (It's already been factory restored for return).

Maybe there's a bug with MWB at the moment?

Anyway, I am formatting the Legion tonight after manually downloading all the drivers, and am doing a clean windows 10 pro install tonight, as this computer was first designed around win 10 so there's no problems doing so and I much prefer it, by a landslide, to Win 11. I will let you know if the problems persist. If not, at least we can deduce it's a MWB/Windows 11 thing. I should know in a few hours. Thanks!

 

 

 

Link to post
Share on other sites

  • Root Admin
Link to post
Share on other sites

It  has registered fine and I ended up doing a restore of Windows 11 as I couldn't get the Lenovo power profiles working properly in Windows 10. Everything else was fine, and I suppose I could have made multiple custom profiles in windows itself, but the lenovo Function Q shortcut is just too easy to lose.

Anyway, Defender sees it, all is good! Thanks as always!

Link to post
Share on other sites

  • Root Admin

Glad we could help.

If you need this topic reopened, please send a Private Message to any one of the moderating team members. Please include a link to this topic with your request.

This applies only to the originator of this thread. Other members who need assistance please start your own topic in a new thread.

Please review the following to help you better protect your computer and privacy Tips to help protect from infection

Thank you

 

 

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.