Jump to content

Exploit Protection Affects Roboform in Chrome


Recommended Posts

I could not get my Roboform extension to work properly - the main issue was the option for showing the lower toolbar did not show up in its options. After process of elimination, I can say that  it definitely is the Exploit Protection in MB. When Exploit Protection is off, the Roboform extension in Chrome works fine and all options work. When it is Exploit Protection is on, the Roboform Chrome extension does not work. I tried excluding the whole folder and several files that Roboform support told me could be the problem, but that does not work. Is there something else I can do? Can this be fixed? It must be a pretty new problem, because I did not notice it before today. 

MB.jpg

Link to post
Share on other sites

  • Staff

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes for Windows Help forum.

If you are having technical issues with our Windows product, please do the following:

Malwarebytes Support Tool - Advanced Options

This feature is designed for the following reasons:

  • For use when you are on the forums and need to provide logs for assistance
  • For use when you don't need or want to create a ticket with Malwarebytes
  • For use when you want to perform local troubleshooting on your own

How to use the Advanced Options:

Spoiler
  1. Download Malwarebytes Support Tool
  2. Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  3. Place a checkmark next to Accept License Agreement and click Next
  4. Navigate to the Advanced tab
  5. The Advanced menu page contains four categories:
    • Gather Logs: Collects troubleshooting information from the computer. As part of this process, Farbar Recovery Scan Tool (FRST) is run to perform a complete diagnosis. The information is saved to a file on the Desktop named mbst-grab-results.zip and can be added as an email attachment or uploaded to a forum post to assist with troubleshooting the issue at hand.
    • Clean: Performs an automated uninstallation of all Malwarebytes products installed to the computer and prompts to install the latest version of Malwarebytes for Windows afterwards. The Premium license key is backed up and reinstated. All user configurations and other data are removed. This process requires a reboot.
    •  Repair System: Includes various system-related repairs in case a Windows service is not functioning correctly that Malwarebytes for Windows is dependent on. It is not recommended to use any Repair System options unless instructed by a Malwarebytes Support agent.
    • Anonymously help the community by providing usage and threat statistics: Unchecking this option will prevent Malwarebytes Support Tool from sending anonymous telemetry data on usage of the program.
  6. To provide logs for review click the Gather Logs button
  7. Upon completion, click OK
  8. A file named mbst-grab-results.zip will be saved to your Desktop
  9. Please attach the file in your next reply.
  10. To uninstall all Malwarebytes Products, click the Clean button.
  11. Click the Yes button to proceed. 
  12. Save all your work and click OK when you are ready to reboot.
  13. After the reboot, you will have the option to re-install the latest version of Malwarebytes for Windows.
  14. Select Yes to install Malwarebytes.
  15. Malwarebytes for Windows will open once the installation completes successfully.

Screenshots:

Spoiler
 
 
 
 
Spoiler

 

 

01.png

02.png

03.png

04.png

05.png

06.png

 

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/hc/en-us/requests/new to get help

If you need help looking up your license details, please head here: Find my premium license key

 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

Link to post
Share on other sites

Nope. Same result. (It did change a couple of the boxes, but Roboform still does not work properly. If I turn off Google Chrome (and plug-ins) from Protected applications in MB, Roboform works properly. With it on, RF does not.

Link to post
Share on other sites

12 hours ago, FredGreco said:

I'm not sure where to find a log

You can find Scan and Protection logs within the Malwarebytes 4 program in the following location

 

image.png

 

RTP stands for Real-Time Protection and is where automatic protection operations would normally be logged

 

image.png

 

If you click on the View option you should get something similar to the following with other options available.

 

image.png

Link to post
Share on other sites

5 minutes ago, FredGreco said:

Weird. There is no log. It is as if MB is blocking something but not considering it log worthy

Please do the following Uninstall and reinstall using the Malwarebytes Support Tool

Please close all browsers and programs before running the tool. Right click and quit MB from the system tray also.

Once done it will attempt to reinstall both Malwarebytes and Privacy VPN.

Please say no and close the X button on the top right for Privacy.

Link to post
Share on other sites

Just now, FredGreco said:

Did that and the problem was not resolved. Still having problems if Exploit Protection for Chrome is turned on.

Lets get some logs please.

Please do the following so that we may take a closer look at your installation for troubleshooting:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

 

  • Download the Malwarebytes Support Tool
  • In your Downloads folder, open the mb-support-x.x.x.xxx.exe file
  • In the User Account Control pop-up window, click Yes to continue the installation
  • Run the MBST Support Tool
  • In the left navigation pane of the Malwarebytes Support Tool, click Advanced
  • In the Advanced Options, click Gather Logs. A status diagram displays the tool is Getting logs from your machine
  • A zip file named mbst-grab-results.zip will be saved to your desktop, please upload that file on your next reply

Thanks

Link to post
Share on other sites

9 minutes ago, FredGreco said:

Your computer is showing it needs to be restarted.

Also Bit Defender is known to have conflicts with Malwarebytes.

Also looks like your external is having issues as well.

Error: (03/16/2022 08:39:11 AM) (Source: disk) (EventID: 11) (User: )
Description: The driver detected a controller error on \Device\Harddisk1\DR1.

 

Quote

Pending File Rename Operations
========================================
C:\Users\Fred Greco\AppData\Local\Temp\df3f8583-6201-4a98-8479-38eb11ac7b17.tmp      
C:\Program Files\Google\Chrome                                                       
C:\Users\FREDGR~1\AppData\Local\Temp\{D8ACD132-3D1A-45FE-82B4-9ABBC793C35B}\setup.exe
C:\Program Files\Google\Chrome\Temp\scoped_dir39268_1183878910\old_chrome.exe        
C:\Program Files\Google\Chrome\Temp\scoped_dir39268_1183878910                       
C:\Program Files\Google\Chrome\Temp                                                  
C:\Windows\TEMP\{CC2220B7-2E49-4112-9D51-C31532A34105}\DPM_Setup64_3_10_0.exe        
C:\Program Files\Google\Chrome\Temp\scoped_dir9560_1371713552\old_chrome.exe         
C:\Program Files\Google\Chrome\Temp\scoped_dir9560_1371713552                        
C:\Program Files\Google\Chrome\Temp                                                  
C:\Users\FREDGR~1\AppData\Local\Temp\DEL55CD.tmp                                     
C:\Program Files\Malwarebytes         

 

Link to post
Share on other sites

1 hour ago, Porthos said:

Also after further review.

In whatever browser you use, turn off ALL other extensions temporally except RoboForm and try again. If it works then you have an extension conflict.

I have already done this on the advice of RF support. No conflicts between extensions. The only thing that causes the problem to go away/return is enabling MB exploit protection for Google Chrome. I'm not sure what you mean by "looks like your external is having issues as well." I did reboot the machine and ran the log gathering tool again (new results attached) to see if there is any difference. I know that MB and Bitdefender have some issues. But I have been using both for years now. And this problem just developed this week, so I wonder if there was a change in the MB exploit definitions?

mbst-grab-results.zip

Link to post
Share on other sites

2 minutes ago, FredGreco said:

I'm not sure what you mean by "looks like your external is having issues as well."

Error: (03/16/2022 08:39:11 AM) (Source: disk) (EventID: 11) (User: )
Description: The driver detected a controller error on \Device\Harddisk1\DR1.

3 minutes ago, FredGreco said:

But I have been using both for years now. And this problem just developed this week, so I wonder if there was a change in the MB exploit definitions?

Very possible. Things do change. I will ask @Arthi to look int this.

Link to post
Share on other sites

7 minutes ago, Porthos said:

Error: (03/16/2022 08:39:11 AM) (Source: disk) (EventID: 11) (User: )
Description: The driver detected a controller error on \Device\Harddisk1\DR1.

Very possible. Things do change. I will ask @Arthi to look int this.

OK. Thanks. Let me know if anything comes up.

As for the harddisk, it looks like that is my external  hard drive, which seems to be working fine. Is there something I should check or do with it? It is a WD Passport HD.

Link to post
Share on other sites

  • 2 weeks later...
On 3/16/2022 at 1:25 PM, Porthos said:

Error: (03/16/2022 08:39:11 AM) (Source: disk) (EventID: 11) (User: )
Description: The driver detected a controller error on \Device\Harddisk1\DR1.

Very possible. Things do change. I will ask @Arthi to look int this.

Did @Arthi have any insight? RoboForm in Chrome is still not working with exploit protection on. Interestingly, RoboForm in Firefox is working fine, even with exploit protection on.

Link to post
Share on other sites

Hello,

 

RoboForm technical support replied to me. This what they said. Does it help solve the problem?

Quote

It takes Chrome to start RoboForm's process rf-chrome-nm-host.exe (so named native messaging host) to let RoboForm extension work in co-operation with RoboForm for Desktop that makes the lower toolbar available in Chrome.
The problem is that Chrome does not starts rf-chrome-nm-host.exe directly, it starts cmd.exe first, and the Exploit Protection option makes your security software treat cmd.exe started by the browser as a potential threat.
As the result, RoboForm's process cannot start, either, and adding RoboForm files in your security software white list cannot help as your antimalware does not ban RoboForm's process indeed, it bans cmd.exe.

Unlike Chrome, Firefox does not need cmd.exe, it starts RoboForm's process directly (please don't be confused with 'chrome' in the name of rf-chrome-nm-host.exe, this is intended for all browsers with RoboForm extension including Firefox).
This problem is not a RoboForm issue and cannot be fixed in RoboForm, neither we could explain why it takes to start cmd.exe first to run native messaging host for the browser (this would affect any extension that needs native messaging).

 

Link to post
Share on other sites

This is odd (but good). I turned on beta updates and then checked for updates. MB updated and now RoboForm in Chrome works. Did the update get pushed out sooner?

version 4.5.7.186

update package 1.0.53016

component package version 1.0.1645

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.