Jump to content

Still getting Bing Redirects even after scan and deleting preferences.plist


Recommended Posts

Hi there I have a Mac here infected with a search redirect that randomly redirects to bing after a few searches. I ran a malwarebytes scan and it detected some things and I had them removed and restarted my computer but I still get the random redirects. I already tried deleting the com.apple.Safari.plist file and it didn't fix my problem. I also followed everything in the pinned "How to remove the after-effects of adware" article and I am still getting the random redirects. How can I fix this? Do I need to run the scan in safe mode? Any help is appreciated. 

Link to post
Share on other sites

You have almost certainly removed all the items that caused this problem, so running it in safe mode would almost certainly be a waste of time.

It sounds like you are only seeing this in Safari, correct? And you did everything shown for Safari in the pinned article including opening Safari Preferences to the General tab and changing the Search engine: to whatever your preferred search site is? I'm unaware of any other way to correct what you are seeing.

Are you seeing the same problem with any other browser or any other device on your network?

Link to post
Share on other sites

1 hour ago, alvarnell said:

You have almost certainly removed all the items that caused this problem, so running it in safe mode would almost certainly be a waste of time.

It sounds like you are only seeing this in Safari, correct? And you did everything shown for Safari in the pinned article including opening Safari Preferences to the General tab and changing the Search engine: to whatever your preferred search site is? I'm unaware of any other way to correct what you are seeing.

Are you seeing the same problem with any other browser or any other device on your network?

 

I haven't tested chrome but yes I see it in Safari. I have the search engine set to google. It goes through google the first few times then redirects to some fake scammy search engine after a few searches. Anything else on the network appears to be fine. 

Link to post
Share on other sites

Perhaps this is being caused by so called "malvertisements" which are ads that slip though the system to cause unexpected behaviors while browsing specific sites that subscribe to 3rd party ad services for compensation. If you are not using a good Safari ad blocker, now would be the time to give the new Malwarebytes Browser Guard for Safari a try. Requires macOS 10.15 Catalina or later.

Edited by alvarnell
Link to post
Share on other sites

4 hours ago, alvarnell said:

Perhaps this is being caused by so called "malvertisements" which are ads that slip though the system to cause unexpected behaviors while browsing specific sites that subscribe to 3rd party ad services for compensation. If you are not using a good Safari ad blocker, now would be the time to give the new Malwarebytes Browser Guard for Safari a try. Requires macOS 10.15 Catalina or later.

The thing is that I am not browsing any wierd sites or anything. It’s just going to google.com to make a few searches then after a while it does a redirect to some random fake search engine. 

Link to post
Share on other sites

There's no need to go to "weird sites" to find these poisoned ads these days. They've been found on some very common large company sites that all seem to rely on these ad consolidator to screen ads, which isn't happening. Ad blockers have become a must have now days.

It's possible the staff will want you to submit some troubleshooting logs to them to see if this is something new. They should be into work in about six hours or so.

Link to post
Share on other sites

  • Staff

I'd like to get more info from your system, just to make sure that there's nothing new that Malwarebytes is missing. Here's what I'd recommend:

1) Download and run our Mac support tool:

https://support.malwarebytes.com/hc/en-us/articles/360038519834-Upload-logs-to-your-ticket-using-the-Malwarebytes-Support-Tool-for-Mac

2) Rather than posting the file generated by the support tool here, I'd recommend submitting it via a support ticket:

https://support.malwarebytes.com/hc/en-us/requests/new

3) Post your support ticket number here so we can escalate your case and take a look at the data right away.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.