Jump to content

Mac software won't install...stalls on 'running package scripts'


Recommended Posts

  • 2 weeks later...

@mono38 Thanks for reaching out!

There was another topic made for this that suggests a workaround, you can find that topic here - 

 

Dev has confirmed that this is a valid workaround and we are currently working on resolving this issue. The next release will contain a fix but in the meantime, changing your system user profile does the trick to get past the frozen installation. The steps are to go to "System Preferences" -> "Users & Groups" and apply the default system icon for a moment to install the app and later your original picture can be restored.

If you have any other questions, please let me know. Thanks!

Link to post
Share on other sites

  • 1 month later...

I am running Mac OS 12.1 and I am also experiencing installation issues.  I tried to force quit and reinstall and I initially got a screen saying Malwarebytes was waiting for the other installation to complete.  When I quit that installation and restart my computer, I got a message (see attached image).  I am not sure what to do as it seems that the installation is stuck at this point.

1482662561_ScreenShot2022-01-25at11_37_15PM.thumb.png.eec3a0145d7f25638a428244a0526d2c.png

Link to post
Share on other sites

@SODerm Did you try changing your user icon as recommended above?

Quote

I changed it in "System Preferences" -> "Users & Groups" to one of the Apple emoji. Shutdown and restart Mac. 

Next Malwarebytes installation completes. Then, choose another user picture. 

 

 

Link to post
Share on other sites

  • Staff

We've still never managed to find the magic formula for reproducing this issue, but we've got a new release coming up soon that has some changes in the installer that we hope will fix the problem. I'll keep everyone here posted, and let you know when that new installer is available.

Link to post
Share on other sites

On 1/26/2022 at 3:51 AM, alvarnell said:

@SODerm Did you try changing your user icon as recommended above?

 

 

@alvarnellyes I tried but that didn't work. When you say to change the user icon, can you be more specific as to what that means?  I just want to make sure that I did, indeed, do it correctly.
 

Link to post
Share on other sites

  • Staff

We've just released a new installer into beta today. If you wouldn't mind testing to see if it solves your problem, that would be greatly appreciated!

More information on the beta, and download instructions, can be found here:

 

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.