Jump to content

Malwarebytes Privacy Breaks Internet Connection


jpr7575

Recommended Posts

When I first started using MBP it was great, had no issues with it.   Then, at some point, I started having a problem with losing my Internet connection when disconnecting from MBP.   While running MBP still works great, it is only after I disconnect, I have a problem.   At first, I was able to fix this by disabling and then re-enabling my Ethernet card (NIC) in Control Panel, but that no longer works, and the only way I can fix this is by rebooting my PC.  Although there are times when even that does not work and my PC gets stuck on "Restarting" and I have to power cycle my PC.   

I tried uninstalling MBP and re-installing it, but the problem is still there.  I have no other problems with network/Internet connectivity - until I start using MBP.   Can this be fixed?   If not - I will need to switch to another VPN program that works correctly.

Link to post
Share on other sites

  • Root Admin

Hello @jpr7575

What you describe sounds like the Kill Switch is enabled and you're ending the connection with it still enabled. Please make sure you end your connection properly.

Let go ahead though and have you do a clean removal of all the software and reinstall it.

 

 

Can you please do the following?

  • Download the Malwarebytes Support Tool
  • In your Downloads folder, open the mb-support-x.x.x.xxx.exe file
  • In the User Account Control pop-up window, click Yes to continue the installation
  • Run the MBST Support Tool
  • In the left navigation pane of the Malwarebytes Support Tool, click Advanced
  • In the Advanced Options, click the CLEAN button and follow the onscreen instructions to reinstall Malwarebytes
  • NOTE: Please have patience as it can take a while to remove and reinstall. The computer will restart to complete

After the restart please do the following

  • Run the MBST Support Tool
  • In the left navigation pane of the Malwarebytes Support Tool, click Advanced
  • In the Advanced Options, click Gather Logs. A status diagram displays the tool is Getting logs from your machine
  • A zip file named mbst-grab-results.zip will be saved to your desktop, please upload that file on your next reply

Thank you

 

Link to post
Share on other sites

1.  Followed the instructions to remove and then re-install MB and MBP.   

2.  After the re-install, tried to run MBP, and kept getting a message to check my Internet connection.   My Internet was connected, and it was working OK

image.thumb.png.e50916a992ffa4bb667e1e6fa0bc4a22.png

 

3.   To fix the above error, I had to reboot my PC.  After the reboot, MBP connected OK.

4.   I went to a few websites after connecting - all worked OK.

5.  I then right clicked the MBP icon in the system tray and chose Disconnect.   Immediately my network connection icon changed to a globe (no Internet)

no-internet.jpg.d28bf2e47ade5922776f76c5b6605751.jpg

6.  I then ran the "Gather Logs" from the MB tool - attached the logs to the case.

NOTE:   After maybe 15 minutes, my network connection icon changed on its own, from a globe to a little computer indicating I now had Internet access.   I did not have to reboot or do anything else.

 

mbst-grab-results.zip

Link to post
Share on other sites

  • Root Admin

Please do the following. Go to Control Panel, Programs, Programs and Features and uninstall the following

Bonjour
CCleaner
(computer experts no longer recommend the use of this program)
 

 

The Event Logs also registered that one of your USB devices is having an issue.

==================== Faulty Device Manager Devices ============

Name: Unknown USB Device (Device Descriptor Request Failed)
Description: Unknown USB Device (Device Descriptor Request Failed)
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Manufacturer: (Standard USB Host Controller)
Service:
Problem: : Windows has stopped this device because it has reported problems. (Code 43)
Resolution: One of the drivers controlling the device notified the operating system that the device failed in some manner. For more information about how to diagnose the problem, see the hardware documentation.

 

Realtek audio is also registering multiple faults

Error: (11/29/2021 09:10:22 AM) (Source: Application Error) (EventID: 1000) (User: )
Description: Faulting application name: ATKEX_cmd.exe, version: 0.0.0.0, time stamp: 0x00000000
Faulting module name: KERNELBASE.dll, version: 10.0.19041.1387, time stamp: 0xcfba7f8a
Exception code: 0x0eedfade
Fault offset: 0x0012b522
Faulting process id: 0x36e4
Faulting application start time: 0x01d7e52ad8dc79a7
Faulting application path: C:\Program Files\Realtek\Audio\HDA\ATKEX_cmd.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: 7093d87b-7bf2-4e9a-bc4a-2682d0337b6a
Faulting package full name:
Faulting package-relative application ID:

 

You may be able to ignore this one or if the hardware is old and no longer updated by the manufacturer forced to ignore it. But if there is a BIOS/UEFI update it might help.

SubmitDone
Submit(Request): Bad Request
{"Message":"Attestation statement cannot be verified, rejecting request. TPM firmware needs update."}

 

Perhaps check and see if there are updates for your motherboard

BIOS: American Megatrends Inc. 3805 05/16/2018
Motherboard: ASUSTeK COMPUTER INC. Z170 PRO GAMING

 

 

Windows Defender is also alerting with errors

Date: 2021-11-27 12:10:25
Description:
Microsoft Defender Antivirus has encountered an error trying to load security intelligence and will attempt reverting back to a known-good version.
Security intelligence Attempted: Current
Error Code: 0x80004004
Error description: Operation aborted
Security intelligence version: 1.353.1322.0;1.353.1322.0
Engine version: 1.1.18700.4

 

The computer has some services of possible concern

S3 cpuz148; \??\C:\WINDOWS\temp\cpuz148\cpuz148_x64.sys [X] (no service should run from a temp folder)
S3 WinRing0_1_2_0; \??\C:\Program Files (x86)\NZXT\CAM\OpenHardwareMonitorLib.sys [X] Is this service and driver still in use?

 

 

Is this a Business Computer? Did you bring this system home from work?

 

 

Please respond to the above questions before we proceed. @jpr7575

Thanks

 

Link to post
Share on other sites

  • Root Admin

There are thousand and thousands of errors for users all over the web for Bonjour

The computer is running an Enterprise version of Windows that does not run from home unless it's been cracked. If it has been cracked that could certainly account for issues.

I'm simply trying to help you clean up the computer for free. If you don't want help that's fine. Go ahead and reinstall the software and see if it works or not.

 

Edited by AdvancedSetup
Updated information
Link to post
Share on other sites

First of all, just because I am using an Enterprise version of Windows does not mean it is not a valid version of Windows - why would you assume it is a cracked version of Windows?  The Bonjour service, which was part of Apple's iTunes at one point, was installed when iTunes was installed, although now days it might not be needed.  However, you still have not said if there are known issues with any of this software and MBP.  You are making assumptions without correlating the MBP issue I am having with what you see in the log files.  

If this is the best support MB can provide, I can do without it.  You have a terrible attitude and don't seem know what you are doing.   I will either resolve the issue myself, or just use a different VPN program that actually works properly.

You can consider this issue closed.

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.