Jump to content

Pycharm won't display charts in the browser - triggers an RTP Error

Go to solution Solved by pbust,

Recommended Posts


I am constantly bugged when using PyCharm which is trying to serve interactive charts in the browser. It gets to the point of opening the image in the browser and then blocks it. It will not let me right click and allow it, and I have tried allowing the folder wherer the python exe file is, the python.exe file itself, the folder where I am running the scripts from and the python file that I am working on. All have been put in the allowed list but it still blocks it. I have also allowed in case that was the problem but not.

The output is here from the last block:


-Log Details-
Protection Event Date: 5/26/21
Protection Event Time: 3:00 PM
Log File: b959ede2-be2a-11eb-83e9-18c04d0f1b0b.json

-Software Information-
Components Version: 1.0.1308
Update Package Version: 1.0.40938
License: Premium

-System Information-
OS: Windows 10 (Build 19041.985)
CPU: x64
File System: NTFS
User: System

-Exploit Details-
File: 0
(No malicious items detected)

Exploit: 1
Malware.Exploit.Agent - T1055 - Defense Evasion, , Blocked, 0, 392684, 0.0.0, , 

-Exploit Data-
Affected Application: C:\Users\iwatt\anaconda3\python.exe
Protection Layer: APT Behavior Protection
Protection Technique: T1055 - Defense Evasion
File Name: 


I will run the support tool and attach to this ticket.

Mnay Thanks


Link to post
Share on other sites

  • Staff

The ZIP seems corrupt and/or incomplete. Can you please try to gather logs again? Alternatively, just post the files mbae-default.log and mbae-default.xpe. You will find them in C:\ProgramData\Malwarebytes\MBAMService\LOGS directory.


Link to post
Share on other sites

  • Staff

Welcome to the forums iwatts3519.

Can you please confirm that you don't have "pentesting mode" enabled under the anti-exploit settings?

Also, please check if there is a custom anti-exploit shield for python.exe.

Edited by pbust
Link to post
Share on other sites

20 minutes ago, pbust said:

Are you sure you didn't turn this on yourself?

Yes please, try again after turning it off.

I must have turned it on by mistake - I checked the reset to defaults and it was off so it must have been me (Sorry) - I have tested it and it is all working now

Many Thanks


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.