Jump to content

Cannot connect to registration server


Recommended Posts

Another one with this problem. I bought a license for Privacy and Malwarebytes Premium. This worked fine until i reinstalled windows this weekend. Malwarebytes Premium installed fine, and took the key. Privacy then installed and automatically took the key but it wont connect.


In my account it shows 4 users registered for Premium. For Privacy it shows trial expired and a different license key. But privacy app itself picked up the key. I have an email which confirm it was 5 users for 12 months, both apps. It worked fine up until now.


Log attached


Link to post
Share on other sites

  • Administrators

Hi Tones,

Thanks for uploading these logs.

I am sorry for the inconvenience that you are having.

We are making some adjustments on our side and will update you once they are complete, so you can continue usage of Malwarebytes Privacy.


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.