Jump to content

Malwarebytes Support Tool has a bug (stuck in a loop). Reporting for a fix.


Recommended Posts

Hi,

I just wanted to report a bug happening with the Malwarebytes Support Tool, latest version downloaded from your official link on this page (mb-support-1.8.1.883.exe).

Once launched and clicked yes for admin privilege, it shows "extracting", and upon completion a progression bar with "Getting file information" followed by "Downloading mb-support-1.8.1.883.exe", followed by the previous "extracting"... and so on.

I have reproduced this bug on 2 different computers, both of which have different hardware and are on different networks. The file isn't new (I checked on digital signature) and I have used it successfully in the past. My guess is that the problem comes from your end on the network level. The only way to use the Support Tool is to disable the internet connection and use it offline. If the internet connection is switched on while the Support Tool is currently launched, it still works as well.

Anyway, I was just reporting the bug so that you guys could fix it up and other users wouldn't be stuck as well. As of me I don't have any issue as I was just uninstalling Malwarebytes as my antivirus requires it to be uninstalled (I will of course install Malwarebytes afterward). I'm quite happy with Malwarebytes (I have the Premium + Privacy package) and have the upmost respect for your work.

Have a good one and stay safe.

PS: I have uploaded a video showing what happens, in case that could help

Link to post
Share on other sites

  • Staff

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes for Windows Help forum.

If you are having technical issues with our Windows product, please do the following:

Malwarebytes Support Tool - Advanced Options

This feature is designed for the following reasons:

  • For use when you are on the forums and need to provide logs for assistance
  • For use when you don't need or want to create a ticket with Malwarebytes
  • For use when you want to perform local troubleshooting on your own

How to use the Advanced Options:

Spoiler
  1. Download Malwarebytes Support Tool
  2. Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  3. Place a checkmark next to Accept License Agreement and click Next
  4. Navigate to the Advanced tab
  5. The Advanced menu page contains four categories:
    • Gather Logs: Collects troubleshooting information from the computer. As part of this process, Farbar Recovery Scan Tool (FRST) is run to perform a complete diagnosis. The information is saved to a file on the Desktop named mbst-grab-results.zip and can be added as an email attachment or uploaded to a forum post to assist with troubleshooting the issue at hand.
    • Clean: Performs an automated uninstallation of all Malwarebytes products installed to the computer and prompts to install the latest version of Malwarebytes for Windows afterwards. The Premium license key is backed up and reinstated. All user configurations and other data are removed. This process requires a reboot.
    •  Repair System: Includes various system-related repairs in case a Windows service is not functioning correctly that Malwarebytes for Windows is dependent on. It is not recommended to use any Repair System options unless instructed by a Malwarebytes Support agent.
    • Anonymously help the community by providing usage and threat statistics: Unchecking this option will prevent Malwarebytes Support Tool from sending anonymous telemetry data on usage of the program.
  6. To provide logs for review click the Gather Logs button
  7. Upon completion, click OK
  8. A file named mbst-grab-results.zip will be saved to your Desktop
  9. Please attach the file in your next reply.
  10. To uninstall all Malwarebytes Products, click the Clean button.
  11. Click the Yes button to proceed. 
  12. Save all your work and click OK when you are ready to reboot.
  13. After the reboot, you will have the option to re-install the latest version of Malwarebytes for Windows.
  14. Select Yes to install Malwarebytes.
  15. Malwarebytes for Windows will open once the installation completes successfully.

Screenshots:

Spoiler
 
 
 
 
Spoiler

 

 

01.png

02.png

03.png

04.png

05.png

06.png

 

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/hc/en-us/requests/new to get help

If you need help looking up your license details, please head here: Find my premium license key

 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

  • Like 1
Link to post
Share on other sites

  • Staff

Thanks, by the way, are all of these systems connecting to the same ISP?  I'm just wondering if perhaps it might be due to a routing issue.  Would you mind trying the tool with Privacy disabled (assuming it was enabled on all of your systems when you tested it) and letting us know how it goes?

  • Like 1
Link to post
Share on other sites

The 3 computers are connected to different routers (that each have their unique static IP) but they are from the same ISP (they provide one box per room, each being its own network). When using the Malwarebytes Support Tool, I was not using the Privacy VPN (or any other VPN for that matter). For the sake of it, I've tried with the Privacy VPN on, and the problem is the same.

I could be wrong, but I really don't think the problem is coming from me. Have you been able to reproduce this behavior on your end?

Thanks

Link to post
Share on other sites

  • Staff

Thanks, I just wanted to make sure.  I haven't been able to reproduce it and I haven't seen anyone else report issues with the tool so far, though that doesn't necessarily mean the issue is on your end, I just want to make sure we eliminate as many possible causes/issues as possible.

Additionally, are you able to run other self-extracting Malwarebytes tools such as ADWCleaner?

  • Like 1
Link to post
Share on other sites

  • Staff

I'm not sure if getting a memory dump would help since the tool isn't really getting hung up so much as getting stuck in a download loop.  The really odd part is how it can be seen downloading what appears to be another copy of itself and launching it (which explains the loop, since it's the same process running over and over again).  It isn't supposed to download itself; it's supposed to be downloading and running FRST, so I have no idea why that's happening.

  • Like 1
Link to post
Share on other sites

  • Staff

This portion of LiquidTension's post may be helpful to the Support Tools team if you have the time.  Replicate the issue, then:

  • Please download collect_mbst_logs.bat using the link below.
     https://malwarebytes.box.com/s/xpz34itvz4kqekayhoplqalehqh9eqnd
  • Open your Downloads folder.
  • Double-click CX41PDv.png collect_mbst_logs.bat to run the file.
  • Note: If you are prompted by Windows SmartScreen, click More info followed by Run anyway.
  • A blue window will appear.
  • Upon completion, a file named HSPwQfy.png mbst-logs.zip will be saved to your Desktop. Please attach the file in your next reply.
  • Like 2
Link to post
Share on other sites

  • Staff

Thanks for reporting this issue @IkariGradius, I haven't been able to reproduce this on my machine so the information that @Ried requested above would help a lot! If you have the time please submit that information. In the meantime our team is investigating and will respond to you once we find a root cause. 

 

 

Edited by respinoza
  • Like 1
Link to post
Share on other sites

Here are the requested logs from the collect_mbst_logs.bat as well as from the task manager dump files that were requested on the LiquidTension link. I've also included another video showing what happens on the task manager. I think all the logs you need should be there. 

I've done the best I could as it wasn't easy to select "Create dump file" as it kept appearing and disappearing on the task manager, switching from mbstud to Malwarebytes Support Tool processes.

Please keep in mind that I was able to run the Support Tool on this machine yesterday when launching it while being offline. However, while the cleanup was successful, it didn't seem to be the same as usual as it didn't prompt me for a restart. Also, this is a newly reformatted computer running Windows 10 20H2 (latest updates installed) and there have been no AVs (besides Malwarebytes) or significant tweaking on it, so I would be surprised if that would come from any of my popular and basic softwares installed.

I'm astonished to be the only one so far encountering this on 3 different machines, as I thought that was a global issue server wise.

Thanks a lot for your patience, and please let me know if you find out what it turns out to be.

mbst-logs.zip 1145132262_otherlogs.zip

Link to post
Share on other sites

  • Staff

It may also help to get Process Monitor logs to reveal what the processes are doing when this occurs, just in case the other logs don't expose it fully:

Create a Process Monitor Log:

  • Create a new folder on your desktop called Logs
  • Please download Process Monitor from here and save it to your desktop
  • Double-click on Procmon.exe to run it
  • In Process Monitor, click on File at the top and select Backing Files...
  • Click the circle to the left of Use file named: and click the ... button
  • Browse to the Logs folder you just created and type MBST Log in the File name: box and click Save
  • Exit Process Monitor and open it again so that it starts creating the logs
  • Replicate the issue so that the Support Tool loops at least once, then terminate the scan
  • Close Process Monitor
  • Right-click on the Logs folder on your desktop and hover your mouse over Send To and select Compressed (zipped) Folder
  • Please attach the Logs.zip file you just created to your next reply, or if it is too large, please upload it to WeTransfer and select the option to send the file as a link from the options menu available by clicking on the circular ... button on the page and provide us with the link to the file

Thanks

  • Like 1
Link to post
Share on other sites

43 minutes ago, Firefox said:

@respinoza I can confirm this is an issue, It is happening on my computer as well. image.png.95294bd0c3afd732f95e6470c1d28590.png

Let me know if you need help with some logs via PM

Glad I'm not the only one. Hope this gets resolved soon and we'll know what the issue was...

Link to post
Share on other sites

5 minutes ago, IkariGradius said:

Glad I'm not the only one. Hope this gets resolved soon and we'll know what the issue was...

If there is one, there is usually a few more.... when I tried to gather the logs, the tool did run successfully one time.  Then I tried one more time and it looped once again.

The logs we provided should help the team look into it.  Thanks for taking the time to help resolve the issue.

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.