Jump to content

BSOD Caused By MWB Privacy

Go to solution Solved by Kriemhild,

Recommended Posts

My Windows 10 20H2 system will crash periodically with IRQL Not Less or Equal BSOD. The Crash Dump Analysis from my WhoCrashed app points to the MWB VPN Tunnel Driver (mbtun.sys). It takes several attempts to get my system to boot properly after the BSOD crash.

I have read the other posts on this problem and want to know if you recommend installing the beta 2.0 version? I ran the MWB Support Tool and logs are attached.


Link to post
  • Solution
3 hours ago, exile360 said:


Yes, please try the following to see if it corrects the issue:

Uninstall Malwarebytes Privacy
Uninstall Malwarebytes Privacy VPN Tunnel Driver
Restart the system and install the beta from here: https://downloads.malwarebytes.com/file/mbprivacy-offline-beta-2.0

Please let us know if that fixes the issue or not.


Was having the same issue as the other fellow in the thread. When I used support tool it didn't remove the Tunnel Driver for whatever reason. When I manually deleted it, the reinstall worked.

Many thanks, @exile360!

Link to post

I have found that it is best to use the Control Panel instead of using MBST and Uninstall Malware Privacy first then uninstall Malwarebytes Privacy VPN Tunnel Driver second. Also if the Malwarebytes Privacy VPN Tunnel Driver doesn't uninstall the first time then try a second time from the control panel. Then if that fails you can go to the Device Manager and uninstall the Tunnel Driver from there in Network Drivers. Also if you happen to see mbtun 2, mbtun 3 and mbtun 4 in Network Drivers then also uninstall those too from the Network Driver list. Then you will not see the BSOD when installing the last beta posted above.

Hope that helps anyone that is having issues with BSOD.

Link to post

Here is something interesting I encountered after installing 2.4.

I was having problems submitting a reply here. Here is the popup error I was getting after clicking on the Submit Reply button: 

We’re sorry but our system has detected wording in your post consistent with spam, It may be by accident, please try changing the wording and try to post again.
If you’re still unable to, then please contact our Helpdesk at the following link: https://support.malwarebytes.com/hc/en-us/requests/new

I had MWB Privacy turned on when I was trying to reply. When I turned off Privacy, I was able to reply.


Link to post
34 minutes ago, JBR64 said:

I typed "I will try again." and clicked on the Submit Reply button. Privacy was turned on. The popup error appeared.

I turned Privacy off and was able to post this reply.

Try rebooting and log back into the forum with Privacy turned on and see if that clears the issue. Post again please.

Edited by Hardhead
add last sentence
Link to post

Rebooted and logged back in to forum with Privacy turned on. Will now click on Submit Reply. Received same popup error as posted above.

I am using the latest release of Chrome, and I have MWB Browser Guard paused. Same popup error result. When I turn Privacy off, I am able to submit a reply.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.