Jump to content

License Key not activating Premium ver for single Mac. Error 2 many devices


Recommended Posts

Hi I got a renewal key today for Malwarebytes premium for Mac. Which I run on one MacBook . Problem is key valid, but on clicking Activation i'm told that I am trying to activate too many devices on a single license. Having only had the key for less than 24 hours I am wondering if this has anything to do with the key having to sync with my account?

I have used this product since 2016 and never had any problems before. On going to my account under subscriptions, their are no valid subscriptions, only one that has expired. TIA for any help.

Gym

Link to post
Share on other sites

  • Staff

Greetings,

Please try adding your license key to your account manually as described in this support article to see if that gets it to show up.  If it does, try using the Deactivate all option described in this support article to see if that gets it to work.

If that doesn't resolve the issue then you will probably need to contact Malwarebytes Support directly to seek their assistance by filling out the form on this page, just keep in mind that it may take several days to receive a response as there is currently a long queue for support tickets.

I hope this helps and if there is anything else we might assist you with please let us know.

Thanks

Link to post
Share on other sites

Thanks for the advice , unfortunately I have had to raise a ticket. On trying to register the key manually - tried a few times - am either told key invalid or already in use. But am using the key I just got today in my renewal email. Appreciate your efforts on my behalf 🙂

Link to post
Share on other sites

When you log into https://my.malwarebytes.com/ you should see the devices that are linked to each key and under "Manage devices" delete any that are incorrect.

I should also mention that when my license renewed a couple weeks ago, it updated automagically without my having to do anything.

Link to post
Share on other sites

Unfortunately there is only one licence / device listed under subscriptions in my account. So I think it maybe a syncing problem as suggested by exile360. Will update you both on what problem was here when it's fixed. Thanks for help and quick replies.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.